bugGNU Octave - Bugs: bug #32074, title is incorrectly positioned...

 
 

bug #32074: title is incorrectly positioned for fltk

Submitted by:  Ben Abbott <bpabbott>
Submitted on:  Fri 07 Jan 2011 02:17:38 PM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Fixed Assigned to:  None
Originator Name:  Ben Abbott Open/Closed:  Closed
Release:  dev Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 11 Jan 2011 01:06:35 AM UTC, comment #6: 

After confirming that my MacBook Pro isn't getting the same result as another Mac I use as work I found that if I rotate the plot after running the demo everything works as it should.

Please push this change.  Be sure to fix the ChangeLog so the entry occurs at the top of the file and is dated today.

Ben Abbott <bpabbott>
Project Member
Mon 10 Jan 2011 07:55:27 PM UTC, comment #5: 

I see no problem with demo('axis',6)

Konstantinos Poulios <logari81>
Mon 10 Jan 2011 02:38:20 AM UTC, comment #4: 

After applying this patch the 6th demo for axis.m no longer works for me.

    demo ("axis", 6)

Running the demo gives me a blank screen. I often misapply patches, so the problem may be on my end.

Ben Abbott <bpabbott>
Project Member
Sun 09 Jan 2011 11:28:21 AM UTC, comment #3: 

The attached patch should fix the problem in demo 5 as well. Please test it.

(file #22377)

Konstantinos Poulios <logari81>
Sat 08 Jan 2011 06:01:41 PM UTC, comment #2: 

I've pushed your changeset.

http://hg.savannah.gnu.org/hgweb/octave/rev/ae96756561d0

I don't see any other problems with the title, so I'm closing this bug.

Ben Abbott <bpabbott>
Project Member
Fri 07 Jan 2011 11:20:40 PM UTC, comment #1: 

In the attached file you can find the fix for demos 2 and 4. Please test it and commit it.

The problem with demo 5 shouldn't be related to any recent changes. This one will be fixed along with the implementation of the tightinset functionality.

(file #22374)

Konstantinos Poulios <logari81>
Fri 07 Jan 2011 02:17:38 PM UTC, original submission:  

The title, of the 1st axis, for demos 2, 4 and 5 of axis() are incorrectly positioned.

demo ("axis", [2, 4, 5])

The fourth demo displays correctly, but produces the incorrect result when printed.

I've attached three png's.

Ben Abbott <bpabbott>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #22377:  title-positioning.changeset added by logari81 (2KiB - application/octet-stream - patch)
file #22374:  fix-bug-32074.changeset added by logari81 (1KiB - application/octet-stream - patch)
file #22370:  axis_2_1.png added by bpabbott (27KiB - image/png)
file #22371:  axis_4_1.png added by bpabbott (58KiB - image/png)
file #22372:  axis_5_1.png added by bpabbott (15KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by logari81 (Updated the item)
  • -email is unavailable- added by bpabbott (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-08-01 bpabbott StatusReady For Test => Fixed
    2011-01-09 logari81 Attached File- => Added title-positioning.changeset, #22377
    2011-01-08 bpabbott StatusNone => Ready For Test
        Open/ClosedOpen => Closed
    2011-01-07 logari81 Attached File- => Added fix-bug-32074.changeset, #22374
    2011-01-07 bpabbott Attached File- => Added axis_2_1.png, #22370
        Attached File- => Added axis_4_1.png, #22371
        Attached File- => Added axis_5_1.png, #22372

    Back to the top


    Powered by Savane 3.5