bugGNU Octave - Bugs: bug #31108, "--no-line-editing"...

 
 

bug #31108: "--no-line-editing" option and fltk backend

Submitted by:  Daisuke TAKAGO <takago>
Submitted on:  Thu 23 Sep 2010 09:27:35 AM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  3 - Low Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Daisuke TAKAGO Open/Closed:  Closed
Release:  dev Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 29 Mar 2014 07:19:51 PM UTC, comment #3: 

I just noticed this bug is exactly the same as bug #37795. There is more discussion on that bug report, so I'm going to close this one as a duplicate of that one even though this was reported much earlier.

Mike Miller <mtmiller>
Project Administrator
Sun 31 Oct 2010 04:59:15 PM UTC, comment #2: 

This bug is confirmed on a recent dev tip (2010-10-31). 

The plot window is essentially "dead" -- no button clicks work, re-sizing the window changes nothing, etc.

I have changed the priority to low, as this has an easy workaround of not using the --no-line-editing option or switching to the gnuplot backend.

Rik <rik5>
Project Administrator
Mon 27 Sep 2010 07:22:12 AM UTC, comment #1: 

If I understand the problem, I think this happens because unless readline is used, events are not processed when Octave is waiting for input.

John W. Eaton <jwe>
Project Administrator
Thu 23 Sep 2010 09:27:35 AM UTC, original submission:  

hello,
I noticed that figure window does not close correctly in the fltk backended octave launched with "--no-line-editing" option. Noting is happend, when I click [X] button directly.

The gnuplot backended octave launched with "--no-line-editing" option have no such a problem.

I think this problem is involved in octave-mode of emacs. In the octave-mode of emacs, "--no-line-editing" option is used internally, so the same thing happens.

Daisuke TAKAGO <takago>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Updated the item)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by takago (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-03-29 mtmiller StatusConfirmed => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #37795
    2013-10-28 mtmiller CategoryNone => Plotting with OpenGL
        Item GroupNone => Incorrect Result
    2010-10-31 rik5 Dependencies- => bugs #30996 is dependent
    2010-10-31 rik5 Priority5 - Normal => 3 - Low
        StatusNone => Confirmed

    Back to the top


    Powered by Savane 3.5