bugGNU Octave - Bugs: bug #59329, The MacOS GUI freezes after...

 
 

bug #59329: The MacOS GUI freezes after drawing a sombrero

Submitted by:  None
Submitted on:  Sat 24 Oct 2020 02:01:20 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Duplicate Assigned to:  None
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  5.2.0
Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 24 Oct 2020 07:31:30 AM UTC, comment #1: 

There are known issues with the Octave 5.2 GUI
in macos, these are hopefully fixed in the upcoming
6.1 release.

If you want to try it out you can check out a release
candidate here :

https://github.com/octave-app/octave-app/releases/tag/v6.0.90-rc1

marking as duplicate of bug #56270 and bug #55630

Carlo de Falco <cdf>
Project Member
Sat 24 Oct 2020 02:01:20 AM UTC, original submission:  

I have 5.2.0 in Mac OS Mojave, installed recently using MacPorts. For fun, because I saw the example in Wikipedia, I typed 'sombrero' and pressed enter.

The plot appeared. But after a few seconds, the interface starts showing the beachball and doesn't seem to recover at all. There is no CPU load at all.

This has been reproducible now three times out of four.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #50078:  Sample@of@Octave.txt added by None (75KiB - text/plain)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by cdf (Posted a comment)
  • -email is unavailable- added by ksundqv (I'm the originator of this)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-10-24 cdf Dependencies- => Depends on bugs #56270
    2020-10-24 cdf Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #55630
    2020-10-24 cdf StatusNone => Duplicate
    2020-10-24 ksundqv Carbon-Copy- => Added kimmo.sundqvist@gmail.com
    2020-10-24 None Attached File- => Added Sample@of@Octave.txt, #50078

    Back to the top


    Powered by Savane 3.6