bugGNU Octave - Bugs: bug #55630, macOS GUI freezes on launch

 
 

bug #55630: macOS GUI freezes on launch

Submitted by:  Andrew Janke <apjanke>
Submitted on:  Sat 02 Feb 2019 09:22:44 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  5.0.90 Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sun 17 Feb 2019 10:41:54 PM UTC, comment #6: 

I'm going to close this bug.  There is a solution--removing the qt-settings file--and this is likely to only affect developers swapping between multiple versions.

If this turns out to be incorrect and there are widespread occurrences among average users of the 5.1 release then we can re-open it.

Rik <rik5>
Project Administrator
Wed 06 Feb 2019 10:40:55 PM UTC, comment #5: 

Yes; removing the qt-settings file fixed it.

Andrew Janke <apjanke>
Tue 05 Feb 2019 09:53:00 PM UTC, comment #4: 

And was it sufficient to remove the qt-settings file for fixing the hang?

Torsten Lilge <ttl>
Project Member
Tue 05 Feb 2019 12:39:40 PM UTC, comment #3: 

I was able to reproduce a hang. I was using Octave 4.4.1 earlier today, and then later I fired up the stable RC 5.0.91, and it hung on startup.

Here's my ~/.config/octave files: file #46181:  octave-config-with-GUI-hang-on-5.0.91.tar.gz

I'll also try removing my Dropbox directory from the path. Though I wouldn't expect a Dropbox directory to cause NFS-like timeouts: as I understand it, a Dropbox directory is not a network-mounted directory. It's a regular local directory whose files are updated locally by a background process; all file access to it by normal programs operates as normal local filesystem access.

Andrew Janke <apjanke>
Sun 03 Feb 2019 03:20:36 PM UTC, comment #2: 

It does sound possible that you are moving between multiple versions of Octave installed on the same computer and that the qt-settings file from one version is not always compatible with another.

The other thing I might try is removing the Dropbox-synced directory in your octaverc.  There have been reports, particularly on Windows, where NFS-mounted shared result in what appear to be hangs of Octave, when it was in fact very long network timeouts on mounted directories.

Try both ideas.  Since it isn't completely certain what is happening I'm marking this bug as WON'T FIX on the Bug Fix List (https://wiki.octave.org/Bug_Fix_List_-_5.0_Release#Bugs_marked_as_Crash)

Rik <rik5>
Project Administrator
Sat 02 Feb 2019 02:18:58 PM UTC, comment #1: 

Andrew, could you please just remove the preferences file in .config/octave/qt-settings next time the issue occurs and post it here (maybe with anonymized paths)?

Torsten Lilge <ttl>
Project Member
Sat 02 Feb 2019 09:22:44 AM UTC, original submission:  

Hey, Octave folks,

Sorry if I'm being whiny here, but I'm having an issue with Octave stable (5.0.90) on macOS. It frequently hangs on launch. About half the time when I launch octave-stable, it'll hang on launch – the GUI will come up, but it will beachball before I can enter any input at the command line.

I'm fiddling with a lot of code right now, so it's hard to narrow down a repro case.

It seems like once Octave gets in a state where it hangs on launch, all subsequent launches will also hang, until I blow away all my Octave settings files.

I'm attaching some crash logs (produced when I Force Quite the hung Octave app), along with my .octaverc and Octave Qt prefs/state.

I don't think my ~/.octaverc is causing it. I moved it away to ~/.octaverc-OFF, and tried `octave-stable --gui` in both states. Sometimes it hung with .octaverc present; sometimes it didn't. And with ~/.octaverc absent, sometimes it hung, and sometimes it didn't. But you never know, so I'm attaching it anyway, as "octaverc".

Andrew Janke <apjanke>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #46163:  octaverc added by apjanke (516B - application/octet-stream)
file #46164:  config-octave.tgz added by apjanke (57KiB - application/gzip)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by apjanke (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-02-17 rik5 StatusNone => Wont Fix
        Open/ClosedOpen => Closed
    2019-02-05 apjanke Attached File- => Added octave-config-with-GUI-hang-on-5.0.91.tar.gz, #46181
    2019-02-02 apjanke Attached File- => Added octave-gui-macos-crash-logs-stable-2019_02_01.zip, #46162
        Attached File- => Added octaverc, #46163
        Attached File- => Added config-octave.tgz, #46164

    Back to the top


    Powered by Savane 3.5