bugGNU Octave - Bugs: bug #56976, pause() with no arguments returns...

 
 

bug #56976: pause() with no arguments returns immediately on Linux

Submitted by:  Bruno Ciscato <bciscato>
Submitted on:  Tue 01 Oct 2019 12:54:08 PM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 23 Oct 2019 08:06:35 PM UTC, comment #28: 

I fixed this on the default branch, see bug #55854.

Mike Miller <mtmiller>
Project Administrator
Thu 10 Oct 2019 07:54:25 PM UTC, comment #27: 

Closing report as a duplicate of bug #55854 .

Pantxo Diribarne <pantxo>
Project Member
Mon 07 Oct 2019 03:28:19 PM UTC, comment #26: 

Hi Mike,

I can confirm that if I click above the current cursor position, pause works fine. If I click anywhere after the current cursor position it does not work anymore.
Pause also works if I go back to the command window without using the mouse, as you suggested.

Cheers

Bruno Ciscato <bciscato>
Sat 05 Oct 2019 10:51:28 PM UTC, comment #25: 

Thanks.

Yes, if I do not click directly on command windows, the pause works as expected.

Dmitri.

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 10:42:15 PM UTC, comment #24: 

For example, in my GNOME desktop environment, I can use Alt+` to switch from the figure window back to the main Octave window (where I have the command window docked), and it gives focus to the command window without any clicking. Or I can click on the Octave window main toolbar to restore focus without clicking directly on the command window.

The behavior that I think this is is caused by a mouse click in the command window typing area specifically, and even more specifically the click must be below or to the right of the current cursor position. As I said, see bug #45003 for the details of this feature (that I think is a mis-feature and should be removed).

Mike Miller <mtmiller>
Project Administrator
Sat 05 Oct 2019 08:49:19 PM UTC, comment #23: 

I do not quite understand -- if you do not click on command window, you cannot pass a char to pause() so it never returns.

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 07:25:07 PM UTC, comment #22: 

Can you only reproduce this behavior after clicking in the command window, somewhere after the cursor position? If you avoid clicking in the command window entirely does pause work correctly for you?

If so, this may be another problem with the hack that was put in place to try to move the cursor based on mouse clicks (see bug #55854 and bug #45003).

Mike Miller <mtmiller>
Project Administrator
Sat 05 Oct 2019 05:13:48 PM UTC, comment #21: 

Hi Dmitri,

this script works. Creating a separate script to run before my script does not help. I have also noticed that Ctrl-C, crashes my Desktop Manager (Deeping). I will try with Gnome too. Only with --gui. In the cli everthing works fine.

comment #18:

> Bruno -- does the following script work as expected for you?
>
> (run in a new octave session "octave --gui -f")
>

> disp("1")
> pause
> disp("2")
> pause
> disp("3")
> pause
>

>
> Dmitri.
> --
>

Bruno Ciscato <bciscato>
Sat 05 Oct 2019 03:51:31 PM UTC, comment #20: 

The problem seems to be related to the plot windows stealing the focus away from command window (actually I think it is figure() that steals the focus).

If I do figure() first, then return to command window and run
tpause script the plots will re-use the existing plot window
w/o stealing the focus and the pause just works.

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 03:44:40 PM UTC, comment #19: 

I can also confirm the bug in ClearLinux
(it also uses glibc 2.30).
Unfortunately the workaround does not work there --
a script with pause after a plot seems to break pause().

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 03:29:55 PM UTC, comment #18: 

Bruno -- does the following script work as expected for you?

(run in a new octave session "octave --gui -f")

disp("1")
pause
disp("2")
pause
disp("3")
pause

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 03:26:35 PM UTC, comment #17: 

I played with the script:

disp("start")
pause
plot(1:3)
pause
plot(1:5)
pause
plot(1:10)
pause

and while it mostly works, at least once  I was able to trigger
the problem. So it appears to be intermittent.
What happens if you make a separate script (say "mystart.m")
with disp("start") ; pause in it and run this script manually
before starting your main script?

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 03:18:35 PM UTC, comment #16: 

Thanks, Dmitri. I’m glad that you were able to confirm the bug.
I have added

  disp("start")
  pause

at the beginning of my script, but I still have the same problem.

Bruno Ciscato <bciscato>
Sat 05 Oct 2019 03:11:43 PM UTC, comment #15: 

Bruno -- I guess untill the problem is solved, a workaround for you would be to add something like that:


disp("start")
pause

at the beginning of your scripts.

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 02:59:12 PM UTC, comment #14: 

Also, having plot in there seems to be important too.
The script


$ cat tpause2.m
disp("1")
pause
disp("2")
pause
disp("3")
pause

works as expected in both --gui and cli version.

Moreover, if I run this script first, then the script with plots (tpause) works as expected. And if I run tpause first it messes up the tpause2 as well!

This one works

>> tpause2
1

2

3

>> tpause



>>

This one does not:


>> tpause
                                                                              >>
>> tpause2
1
2
3
>>

Dmitri.

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 02:43:11 PM UTC, comment #13: 

Confirmed.

The fact this is script is essential.
I can reproduce this.

If I use the following script:

plot(1:3)
pause
plot(1:5)
pause
plot(1:10)
pause

(In octave --gui)
On first run it pauses after first plot (1:3) and after
clicking on the command windows plot jumps to the last one
(1:10) and returns to prompt immediately.
Subsequent runs of the script in the same octave
session it does not pause at all.

In cli version it works as expected. Unfortunately I do not have Fedora 30 any more to check it there.

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 02:24:12 PM UTC, comment #12: 

Thanks, Dmitri.
That fixed it. I installed qt5-devel.
I still have the same problem, though.
Only the first instance of pause; works.
My script creates a graph and then pauses. The graph's window grabs the focus. When I click on the Command Window the script continues and does not stop at any subsequent pause;
If I relaunch the same scripts it does not pause at the first instance anymore.
It seems like only the first instance of pause; after I launch octave --gui works.

Bruno Ciscato <bciscato>
Sat 05 Oct 2019 01:53:17 PM UTC, comment #11: 

So qscintilla-dev has pulled in most of the other -devel packages.
I think for Qt5Help you need to install qt5-qttools-devel-5.12.4-2.fc31.x86_64

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 01:11:46 PM UTC, comment #10: 

The error message is somewhat misleading.
You have run-time libraries, but probably are missing
some -devel packages (header files).
Make sure you have qt5-devel installed

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 05 Oct 2019 01:10:30 PM UTC, comment #9: 

After installing:

dnf install qscintilla-qt5-devel

I only get a missing Qt5Help error:
Build Octave Qt GUI:                  no (missing:Qt5Help)

Bruno Ciscato <bciscato>
Sat 05 Oct 2019 12:25:10 PM UTC, comment #8: 

I can't get 'configure' to see the qt5 libraries. They are all in /usr/lib64 but I always get a:
 Build Octave Qt GUI:                  no (missing:Qt5Core Qt5Gui Qt5Network Qt5PrintSupport Qt5Help Qt5Xml)

I have also tried with:

../src/octave/configure --prefix=/usr/local/octave/dev --with-blas=/usr/lib64/lib/libopenblas.so --with-lapack=/usr/lib64/liblapack.so --with-qt=5 --enable-64 --enable-lib64-directory

They seem to be there, though:

[bruno@fedora build]$ ll /usr/lib64/libQt5*
lrwxrwxrwx. 1 root root       27 Sep 25 19:45 /usr/lib64/libQt53DAnimation.so.5 -> libQt53DAnimation.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 19:45 /usr/lib64/libQt53DAnimation.so.5.12 -> libQt53DAnimation.so.5.12.5
-rwxr-xr-x. 1 root root   771992 Sep 25 19:47 /usr/lib64/libQt53DAnimation.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 19:45 /usr/lib64/libQt53DCore.so.5 -> libQt53DCore.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 19:45 /usr/lib64/libQt53DCore.so.5.12 -> libQt53DCore.so.5.12.5
-rwxr-xr-x. 1 root root   616000 Sep 25 19:47 /usr/lib64/libQt53DCore.so.5.12.5
lrwxrwxrwx. 1 root root       24 Sep 25 19:45 /usr/lib64/libQt53DExtras.so.5 -> libQt53DExtras.so.5.12.5
lrwxrwxrwx. 1 root root       24 Sep 25 19:45 /usr/lib64/libQt53DExtras.so.5.12 -> libQt53DExtras.so.5.12.5
-rwxr-xr-x. 1 root root   883664 Sep 25 19:47 /usr/lib64/libQt53DExtras.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 19:45 /usr/lib64/libQt53DInput.so.5 -> libQt53DInput.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 19:45 /usr/lib64/libQt53DInput.so.5.12 -> libQt53DInput.so.5.12.5
-rwxr-xr-x. 1 root root   728744 Sep 25 19:47 /usr/lib64/libQt53DInput.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 19:45 /usr/lib64/libQt53DLogic.so.5 -> libQt53DLogic.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 19:45 /usr/lib64/libQt53DLogic.so.5.12 -> libQt53DLogic.so.5.12.5
-rwxr-xr-x. 1 root root    79264 Sep 25 19:47 /usr/lib64/libQt53DLogic.so.5.12.5
lrwxrwxrwx. 1 root root       32 Sep 25 19:45 /usr/lib64/libQt53DQuickAnimation.so.5 -> libQt53DQuickAnimation.so.5.12.5
lrwxrwxrwx. 1 root root       32 Sep 25 19:45 /usr/lib64/libQt53DQuickAnimation.so.5.12 -> libQt53DQuickAnimation.so.5.12.5
-rwxr-xr-x. 1 root root    72776 Sep 25 19:47 /usr/lib64/libQt53DQuickAnimation.so.5.12.5
lrwxrwxrwx. 1 root root       29 Sep 25 19:45 /usr/lib64/libQt53DQuickExtras.so.5 -> libQt53DQuickExtras.so.5.12.5
lrwxrwxrwx. 1 root root       29 Sep 25 19:45 /usr/lib64/libQt53DQuickExtras.so.5.12 -> libQt53DQuickExtras.so.5.12.5
-rwxr-xr-x. 1 root root   100984 Sep 25 19:47 /usr/lib64/libQt53DQuickExtras.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 19:45 /usr/lib64/libQt53DQuickInput.so.5 -> libQt53DQuickInput.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 19:45 /usr/lib64/libQt53DQuickInput.so.5.12 -> libQt53DQuickInput.so.5.12.5
-rwxr-xr-x. 1 root root    67408 Sep 25 19:47 /usr/lib64/libQt53DQuickInput.so.5.12.5
lrwxrwxrwx. 1 root root       29 Sep 25 19:45 /usr/lib64/libQt53DQuickRender.so.5 -> libQt53DQuickRender.so.5.12.5
lrwxrwxrwx. 1 root root       29 Sep 25 19:45 /usr/lib64/libQt53DQuickRender.so.5.12 -> libQt53DQuickRender.so.5.12.5
-rwxr-xr-x. 1 root root   241296 Sep 25 19:47 /usr/lib64/libQt53DQuickRender.so.5.12.5
lrwxrwxrwx. 1 root root       30 Sep 25 19:45 /usr/lib64/libQt53DQuickScene2D.so.5 -> libQt53DQuickScene2D.so.5.12.5
lrwxrwxrwx. 1 root root       30 Sep 25 19:45 /usr/lib64/libQt53DQuickScene2D.so.5.12 -> libQt53DQuickScene2D.so.5.12.5
-rwxr-xr-x. 1 root root   122288 Sep 25 19:47 /usr/lib64/libQt53DQuickScene2D.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 19:45 /usr/lib64/libQt53DQuick.so.5 -> libQt53DQuick.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 19:45 /usr/lib64/libQt53DQuick.so.5.12 -> libQt53DQuick.so.5.12.5
-rwxr-xr-x. 1 root root   229728 Sep 25 19:47 /usr/lib64/libQt53DQuick.so.5.12.5
lrwxrwxrwx. 1 root root       24 Sep 25 19:45 /usr/lib64/libQt53DRender.so.5 -> libQt53DRender.so.5.12.5
lrwxrwxrwx. 1 root root       24 Sep 25 19:45 /usr/lib64/libQt53DRender.so.5.12 -> libQt53DRender.so.5.12.5
-rwxr-xr-x. 1 root root  4163416 Sep 25 19:47 /usr/lib64/libQt53DRender.so.5.12.5
lrwxrwxrwx. 1 root root       25 Sep 25 17:19 /usr/lib64/libQt5Bluetooth.so.5 -> libQt5Bluetooth.so.5.12.5
lrwxrwxrwx. 1 root root       25 Sep 25 17:19 /usr/lib64/libQt5Bluetooth.so.5.12 -> libQt5Bluetooth.so.5.12.5
-rwxr-xr-x. 1 root root  1337032 Sep 25 17:19 /usr/lib64/libQt5Bluetooth.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 06:02 /usr/lib64/libQt5Concurrent.so.5 -> libQt5Concurrent.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 06:02 /usr/lib64/libQt5Concurrent.so.5.12 -> libQt5Concurrent.so.5.12.5
-rwxr-xr-x. 1 root root    37592 Sep 25 06:05 /usr/lib64/libQt5Concurrent.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 25 06:01 /usr/lib64/libQt5Core.so.5 -> libQt5Core.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 25 06:01 /usr/lib64/libQt5Core.so.5.12 -> libQt5Core.so.5.12.5
-rwxr-xr-x. 1 root root  6042792 Sep 25 06:05 /usr/lib64/libQt5Core.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 25 06:02 /usr/lib64/libQt5DBus.so.5 -> libQt5DBus.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 25 06:02 /usr/lib64/libQt5DBus.so.5.12 -> libQt5DBus.so.5.12.5
-rwxr-xr-x. 1 root root   870248 Sep 25 06:05 /usr/lib64/libQt5DBus.so.5.12.5
lrwxrwxrwx. 1 root root       38 Sep 25 06:02 /usr/lib64/libQt5EglFSDeviceIntegration.so.5 -> libQt5EglFSDeviceIntegration.so.5.12.5
lrwxrwxrwx. 1 root root       38 Sep 25 06:02 /usr/lib64/libQt5EglFSDeviceIntegration.so.5.12 -> libQt5EglFSDeviceIntegration.so.5.12.5
-rwxr-xr-x. 1 root root   992680 Sep 25 06:05 /usr/lib64/libQt5EglFSDeviceIntegration.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 06:02 /usr/lib64/libQt5EglFsKmsSupport.so.5 -> libQt5EglFsKmsSupport.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 06:02 /usr/lib64/libQt5EglFsKmsSupport.so.5.12 -> libQt5EglFsKmsSupport.so.5.12.5
-rwxr-xr-x. 1 root root   376608 Sep 25 06:05 /usr/lib64/libQt5EglFsKmsSupport.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 06:01 /usr/lib64/libQt5Gui.so.5 -> libQt5Gui.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 06:01 /usr/lib64/libQt5Gui.so.5.12 -> libQt5Gui.so.5.12.5
-rwxr-xr-x. 1 root root  6185176 Sep 25 06:05 /usr/lib64/libQt5Gui.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 26 07:37 /usr/lib64/libQt5Help.so.5 -> libQt5Help.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 26 07:37 /usr/lib64/libQt5Help.so.5.12 -> libQt5Help.so.5.12.5
-rwxr-xr-x. 1 root root   571120 Sep 26 07:39 /usr/lib64/libQt5Help.so.5.12.5
lrwxrwxrwx. 1 root root       24 Sep 25 17:34 /usr/lib64/libQt5Location.so.5 -> libQt5Location.so.5.12.5
lrwxrwxrwx. 1 root root       24 Sep 25 17:34 /usr/lib64/libQt5Location.so.5.12 -> libQt5Location.so.5.12.5
-rwxr-xr-x. 1 root root  2635680 Sep 25 17:35 /usr/lib64/libQt5Location.so.5.12.5
lrwxrwxrwx. 1 root root       34 Sep 25 17:24 /usr/lib64/libQt5MultimediaGstTools.so.5 -> libQt5MultimediaGstTools.so.5.12.5
lrwxrwxrwx. 1 root root       34 Sep 25 17:24 /usr/lib64/libQt5MultimediaGstTools.so.5.12 -> libQt5MultimediaGstTools.so.5.12.5
-rwxr-xr-x. 1 root root   440048 Sep 25 17:24 /usr/lib64/libQt5MultimediaGstTools.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 17:24 /usr/lib64/libQt5MultimediaQuick.so.5 -> libQt5MultimediaQuick.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 17:24 /usr/lib64/libQt5MultimediaQuick.so.5.12 -> libQt5MultimediaQuick.so.5.12.5
-rwxr-xr-x. 1 root root   168216 Sep 25 17:24 /usr/lib64/libQt5MultimediaQuick.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 17:24 /usr/lib64/libQt5Multimedia.so.5 -> libQt5Multimedia.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 17:24 /usr/lib64/libQt5Multimedia.so.5.12 -> libQt5Multimedia.so.5.12.5
-rwxr-xr-x. 1 root root  1269776 Sep 25 17:24 /usr/lib64/libQt5Multimedia.so.5.12.5
lrwxrwxrwx. 1 root root       33 Sep 25 17:24 /usr/lib64/libQt5MultimediaWidgets.so.5 -> libQt5MultimediaWidgets.so.5.12.5
lrwxrwxrwx. 1 root root       33 Sep 25 17:24 /usr/lib64/libQt5MultimediaWidgets.so.5.12 -> libQt5MultimediaWidgets.so.5.12.5
-rwxr-xr-x. 1 root root   142512 Sep 25 17:24 /usr/lib64/libQt5MultimediaWidgets.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 06:01 /usr/lib64/libQt5Network.so.5 -> libQt5Network.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 06:01 /usr/lib64/libQt5Network.so.5.12 -> libQt5Network.so.5.12.5
-rwxr-xr-x. 1 root root  2129824 Sep 25 06:05 /usr/lib64/libQt5Network.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 17:19 /usr/lib64/libQt5Nfc.so.5 -> libQt5Nfc.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 17:19 /usr/lib64/libQt5Nfc.so.5.12 -> libQt5Nfc.so.5.12.5
-rwxr-xr-x. 1 root root   473136 Sep 25 17:19 /usr/lib64/libQt5Nfc.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 06:02 /usr/lib64/libQt5OpenGL.so.5 -> libQt5OpenGL.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 06:02 /usr/lib64/libQt5OpenGL.so.5.12 -> libQt5OpenGL.so.5.12.5
-rwxr-xr-x. 1 root root   421848 Sep 25 06:05 /usr/lib64/libQt5OpenGL.so.5.12.5
lrwxrwxrwx. 1 root root       32 Sep 25 17:34 /usr/lib64/libQt5PositioningQuick.so.5 -> libQt5PositioningQuick.so.5.12.5
lrwxrwxrwx. 1 root root       32 Sep 25 17:34 /usr/lib64/libQt5PositioningQuick.so.5.12 -> libQt5PositioningQuick.so.5.12.5
-rwxr-xr-x. 1 root root    91960 Sep 25 17:35 /usr/lib64/libQt5PositioningQuick.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 17:34 /usr/lib64/libQt5Positioning.so.5 -> libQt5Positioning.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 17:34 /usr/lib64/libQt5Positioning.so.5.12 -> libQt5Positioning.so.5.12.5
-rwxr-xr-x. 1 root root   655224 Sep 25 17:35 /usr/lib64/libQt5Positioning.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 06:02 /usr/lib64/libQt5PrintSupport.so.5 -> libQt5PrintSupport.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 06:02 /usr/lib64/libQt5PrintSupport.so.5.12 -> libQt5PrintSupport.so.5.12.5
-rwxr-xr-x. 1 root root   549376 Sep 25 06:05 /usr/lib64/libQt5PrintSupport.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 09:25 /usr/lib64/libQt5Qml.so.5 -> libQt5Qml.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 09:25 /usr/lib64/libQt5Qml.so.5.12 -> libQt5Qml.so.5.12.5
-rwxr-xr-x. 1 root root  6402056 Sep 25 09:27 /usr/lib64/libQt5Qml.so.5.12.5
lrwxrwxrwx. 1 root root       30 Sep 25 17:23 /usr/lib64/libQt5QuickControls2.so.5 -> libQt5QuickControls2.so.5.12.5
lrwxrwxrwx. 1 root root       30 Sep 25 17:23 /usr/lib64/libQt5QuickControls2.so.5.12 -> libQt5QuickControls2.so.5.12.5
-rwxr-xr-x. 1 root root   263232 Sep 25 17:24 /usr/lib64/libQt5QuickControls2.so.5.12.5
lrwxrwxrwx. 1 root root       30 Sep 25 09:25 /usr/lib64/libQt5QuickParticles.so.5 -> libQt5QuickParticles.so.5.12.5
lrwxrwxrwx. 1 root root       30 Sep 25 09:25 /usr/lib64/libQt5QuickParticles.so.5.12 -> libQt5QuickParticles.so.5.12.5
-rwxr-xr-x. 1 root root   821824 Sep 25 09:27 /usr/lib64/libQt5QuickParticles.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 09:25 /usr/lib64/libQt5QuickShapes.so.5 -> libQt5QuickShapes.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 09:25 /usr/lib64/libQt5QuickShapes.so.5.12 -> libQt5QuickShapes.so.5.12.5
-rwxr-xr-x. 1 root root   259992 Sep 25 09:27 /usr/lib64/libQt5QuickShapes.so.5.12.5
lrwxrwxrwx. 1 root root       21 Sep 25 09:25 /usr/lib64/libQt5Quick.so.5 -> libQt5Quick.so.5.12.5
lrwxrwxrwx. 1 root root       21 Sep 25 09:25 /usr/lib64/libQt5Quick.so.5.12 -> libQt5Quick.so.5.12.5
-rwxr-xr-x. 1 root root  6420472 Sep 25 09:27 /usr/lib64/libQt5Quick.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 17:23 /usr/lib64/libQt5QuickTemplates2.so.5 -> libQt5QuickTemplates2.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 17:23 /usr/lib64/libQt5QuickTemplates2.so.5.12 -> libQt5QuickTemplates2.so.5.12.5
-rwxr-xr-x. 1 root root  1733288 Sep 25 17:24 /usr/lib64/libQt5QuickTemplates2.so.5.12.5
lrwxrwxrwx. 1 root root       25 Sep 25 09:25 /usr/lib64/libQt5QuickTest.so.5 -> libQt5QuickTest.so.5.12.5
lrwxrwxrwx. 1 root root       25 Sep 25 09:25 /usr/lib64/libQt5QuickTest.so.5.12 -> libQt5QuickTest.so.5.12.5
-rwxr-xr-x. 1 root root   202240 Sep 25 09:27 /usr/lib64/libQt5QuickTest.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 09:25 /usr/lib64/libQt5QuickWidgets.so.5 -> libQt5QuickWidgets.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 09:25 /usr/lib64/libQt5QuickWidgets.so.5.12 -> libQt5QuickWidgets.so.5.12.5
-rwxr-xr-x. 1 root root   102672 Sep 25 09:27 /usr/lib64/libQt5QuickWidgets.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 17:24 /usr/lib64/libQt5Script.so.5 -> libQt5Script.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 17:24 /usr/lib64/libQt5Script.so.5.12 -> libQt5Script.so.5.12.5
-rwxr-xr-x. 1 root root  3215568 Sep 25 17:24 /usr/lib64/libQt5Script.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 17:24 /usr/lib64/libQt5ScriptTools.so.5 -> libQt5ScriptTools.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 17:24 /usr/lib64/libQt5ScriptTools.so.5.12 -> libQt5ScriptTools.so.5.12.5
-rwxr-xr-x. 1 root root  1085728 Sep 25 17:24 /usr/lib64/libQt5ScriptTools.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 17:21 /usr/lib64/libQt5Sensors.so.5 -> libQt5Sensors.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 17:21 /usr/lib64/libQt5Sensors.so.5.12 -> libQt5Sensors.so.5.12.5
-rwxr-xr-x. 1 root root   313784 Sep 25 17:22 /usr/lib64/libQt5Sensors.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 17:19 /usr/lib64/libQt5SerialPort.so.5 -> libQt5SerialPort.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 17:19 /usr/lib64/libQt5SerialPort.so.5.12 -> libQt5SerialPort.so.5.12.5
-rwxr-xr-x. 1 root root   116632 Sep 25 17:19 /usr/lib64/libQt5SerialPort.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 06:01 /usr/lib64/libQt5Sql.so.5 -> libQt5Sql.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 06:01 /usr/lib64/libQt5Sql.so.5.12 -> libQt5Sql.so.5.12.5
-rwxr-xr-x. 1 root root   363808 Sep 25 06:05 /usr/lib64/libQt5Sql.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 17:22 /usr/lib64/libQt5Svg.so.5 -> libQt5Svg.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 17:22 /usr/lib64/libQt5Svg.so.5.12 -> libQt5Svg.so.5.12.5
-rwxr-xr-x. 1 root root   449848 Sep 25 17:22 /usr/lib64/libQt5Svg.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 25 06:02 /usr/lib64/libQt5Test.so.5 -> libQt5Test.so.5.12.5
lrwxrwxrwx. 1 root root       20 Sep 25 06:02 /usr/lib64/libQt5Test.so.5.12 -> libQt5Test.so.5.12.5
-rwxr-xr-x. 1 root root   397704 Sep 25 06:05 /usr/lib64/libQt5Test.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 17:20 /usr/lib64/libQt5TextToSpeech.so.5 -> libQt5TextToSpeech.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 25 17:20 /usr/lib64/libQt5TextToSpeech.so.5.12 -> libQt5TextToSpeech.so.5.12.5
-rwxr-xr-x. 1 root root    75552 Sep 25 17:20 /usr/lib64/libQt5TextToSpeech.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 19:34 /usr/lib64/libQt5VirtualKeyboard.so.5 -> libQt5VirtualKeyboard.so.5.12.5
lrwxrwxrwx. 1 root root       31 Sep 25 19:34 /usr/lib64/libQt5VirtualKeyboard.so.5.12 -> libQt5VirtualKeyboard.so.5.12.5
-rwxr-xr-x. 1 root root  2022104 Sep 25 19:34 /usr/lib64/libQt5VirtualKeyboard.so.5.12.5
lrwxrwxrwx. 1 root root       29 Sep 25 17:22 /usr/lib64/libQt5WaylandClient.so.5 -> libQt5WaylandClient.so.5.12.5
lrwxrwxrwx. 1 root root       29 Sep 25 17:22 /usr/lib64/libQt5WaylandClient.so.5.12 -> libQt5WaylandClient.so.5.12.5
-rwxr-xr-x. 1 root root  1216984 Sep 25 17:22 /usr/lib64/libQt5WaylandClient.so.5.12.5
lrwxrwxrwx. 1 root root       33 Sep 25 17:22 /usr/lib64/libQt5WaylandCompositor.so.5 -> libQt5WaylandCompositor.so.5.12.5
lrwxrwxrwx. 1 root root       33 Sep 25 17:22 /usr/lib64/libQt5WaylandCompositor.so.5.12 -> libQt5WaylandCompositor.so.5.12.5
-rwxr-xr-x. 1 root root  1756040 Sep 25 17:22 /usr/lib64/libQt5WaylandCompositor.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 19:34 /usr/lib64/libQt5WebChannel.so.5 -> libQt5WebChannel.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 19:34 /usr/lib64/libQt5WebChannel.so.5.12 -> libQt5WebChannel.so.5.12.5
-rwxr-xr-x. 1 root root   189688 Sep 25 19:34 /usr/lib64/libQt5WebChannel.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 20:14 /usr/lib64/libQt5WebKit.so.5 -> libQt5WebKit.so.5.212.0
-rwxr-xr-x. 1 root root 49712472 Sep 25 20:18 /usr/lib64/libQt5WebKit.so.5.212.0
lrwxrwxrwx. 1 root root       30 Sep 25 20:14 /usr/lib64/libQt5WebKitWidgets.so.5 -> libQt5WebKitWidgets.so.5.212.0
-rwxr-xr-x. 1 root root   340680 Sep 25 20:18 /usr/lib64/libQt5WebKitWidgets.so.5.212.0
lrwxrwxrwx. 1 root root       26 Sep 25 17:21 /usr/lib64/libQt5WebSockets.so.5 -> libQt5WebSockets.so.5.12.5
lrwxrwxrwx. 1 root root       26 Sep 25 17:21 /usr/lib64/libQt5WebSockets.so.5.12 -> libQt5WebSockets.so.5.12.5
-rwxr-xr-x. 1 root root   262032 Sep 25 17:21 /usr/lib64/libQt5WebSockets.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 06:01 /usr/lib64/libQt5Widgets.so.5 -> libQt5Widgets.so.5.12.5
lrwxrwxrwx. 1 root root       23 Sep 25 06:01 /usr/lib64/libQt5Widgets.so.5.12 -> libQt5Widgets.so.5.12.5
-rwxr-xr-x. 1 root root  7848296 Sep 25 06:05 /usr/lib64/libQt5Widgets.so.5.12.5
lrwxrwxrwx. 1 root root       25 Sep 25 17:22 /usr/lib64/libQt5X11Extras.so.5 -> libQt5X11Extras.so.5.12.5
lrwxrwxrwx. 1 root root       25 Sep 25 17:22 /usr/lib64/libQt5X11Extras.so.5.12 -> libQt5X11Extras.so.5.12.5
-rwxr-xr-x. 1 root root    24592 Sep 25 17:22 /usr/lib64/libQt5X11Extras.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 06:02 /usr/lib64/libQt5XcbQpa.so.5 -> libQt5XcbQpa.so.5.12.5
lrwxrwxrwx. 1 root root       22 Sep 25 06:02 /usr/lib64/libQt5XcbQpa.so.5.12 -> libQt5XcbQpa.so.5.12.5
-rwxr-xr-x. 1 root root  1923832 Sep 25 06:05 /usr/lib64/libQt5XcbQpa.so.5.12.5
lrwxrwxrwx. 1 root root       28 Sep 26 08:20 /usr/lib64/libQt5XdgIconLoader.so.3 -> libQt5XdgIconLoader.so.3.3.1
-rwxr-xr-x. 1 root root    91304 Sep 26 08:20 /usr/lib64/libQt5XdgIconLoader.so.3.3.1
lrwxrwxrwx. 1 root root       18 Sep 26 08:20 /usr/lib64/libQt5Xdg.so.3 -> libQt5Xdg.so.3.3.1
-rwxr-xr-x. 1 root root   229400 Sep 26 08:20 /usr/lib64/libQt5Xdg.so.3.3.1
lrwxrwxrwx. 1 root root       27 Sep 25 14:40 /usr/lib64/libQt5XmlPatterns.so.5 -> libQt5XmlPatterns.so.5.12.5
lrwxrwxrwx. 1 root root       27 Sep 25 14:40 /usr/lib64/libQt5XmlPatterns.so.5.12 -> libQt5XmlPatterns.so.5.12.5
-rwxr-xr-x. 1 root root  5631384 Sep 25 14:41 /usr/lib64/libQt5XmlPatterns.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 06:01 /usr/lib64/libQt5Xml.so.5 -> libQt5Xml.so.5.12.5
lrwxrwxrwx. 1 root root       19 Sep 25 06:01 /usr/lib64/libQt5Xml.so.5.12 -> libQt5Xml.so.5.12.5
-rwxr-xr-x. 1 root root   307728 Sep 25 06:05 /usr/lib64/libQt5Xml.so.5.12.5

Bruno Ciscato <bciscato>
Fri 04 Oct 2019 06:12:24 PM UTC, comment #7: 

Try to install and build octave against qt5.

Dmitri.

Dmitri A. Sergatskov <dasergatskov>
Fri 04 Oct 2019 03:20:45 PM UTC, comment #6: 

Everything is the same but Qt. I have got:

Name        : qt
Epoch       : 1
Version     : 4.8.7
Release     : 50.fc31

Bruno Ciscato <bciscato>
Thu 03 Oct 2019 09:27:08 PM UTC, comment #5: 

Try running "./run-octave -q -f" (and "./run-octave --gui -q -f") -- may be you have something in your init files...

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 03 Oct 2019 09:19:22 PM UTC, comment #4: 

I cannot reproduce on Fedora 31 with

octave:3> _octave_config_info_ ("hg_id")
ans = 8ba19629d5ef

Some other info:

uname -r
5.3.2-300.fc31.x86_64

gcc version 9.2.1 20190827 (Red Hat 9.2.1-1) (GCC)

ld -v
GNU ld version 2.32-24.fc31

rpm -qi glibc
Name        : glibc
Version     : 2.30
Release     : 5.fc31
Architecture: x86_64
Install Date: Fri 27 Sep 2019 12:29:54 PM CDT

Qt 5.12.5

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 03 Oct 2019 08:59:42 PM UTC, comment #3: 

I cannot reproduce neither of those problems on Fedora 31.
octave:1> _octave_config_info_ ("hg_id")
ans = e94868c1369f

(this is a few days old version, I will check with the current tip)

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 03 Oct 2019 08:37:09 PM UTC, comment #2: 

I have just found out that pause; works if I use the cli. It does not work if I use the GUI.

Both on Fedora 31 with:
[bruno@fedora build]$ ldd --version
ldd (GNU libc) 2.30
Copyright (C) 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

and on Fedora 30 with:
[bruno@localhost build]$ ldd --version
ldd (GNU libc) 2.29
Copyright (C) 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

The other strange thing is that on Fedora 31 it takes about 30 seconds to get a cli prompt or the GUI after I enter:

./run-octave or ./run-octave --gui

Bruno Ciscato <bciscato>
Tue 01 Oct 2019 05:22:48 PM UTC, comment #1: 

I can't reproduce this with the default branch on Debian. I notice that Debian is on glibc 2.29 and Fedora 31 is on glibc 2.30, maybe another glibc change affecting this function? Can you confirm that pause does work correctly on Fedora 30 (with glibc 2.29)? Can you determine why the loop is returning early with no input from the user?

Just for clarification, the bug in Octave 5.1 with glibc ≥ 2.28 has been fixed on the stable branch, and the correct report is bug #55029.

Mike Miller <mtmiller>
Project Administrator
Tue 01 Oct 2019 12:54:08 PM UTC, original submission:  

This is like #55943, but on Linux.
I just compiled Octave 6.0.0 from source on Fedora 31 beta using these instructions: https://wiki.octave.org/Octave_for_Red_Hat_Linux_systems, because in 5.1.0 the opposite happens: it ignores key press, #56776?.

Bruno Ciscato <bciscato>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by bciscato (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-10-10 pantxo StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #55854
    2019-10-01 mtmiller Releaseother => dev
    2019-10-01 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5