bugGNU Octave - Bugs: bug #53657, Ambiguous 'Ctrl+F' shortcut

 
 

bug #53657: Ambiguous 'Ctrl+F' shortcut

Submitted by:  Alexander Wilms <alexanderw>
Submitted on:  Sun 15 Apr 2018 10:19:16 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.3.90 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sun 15 Apr 2018 06:21:08 PM UTC, comment #6: 

I created a new bug report for the _find_dialog behavior here:

https://savannah.gnu.org/bugs/index.php?53663

Dan Sebald <sebald>
Sun 15 Apr 2018 04:26:37 PM UTC, comment #5: 

Or the title could be changed to reflect the comments I wrote about the Editor's search facility behavior.  Are you seeing what I described on your system?  I.e., the search only seems partially useful when Editor is docked, and not really useful when Editor is floated?

Dan Sebald <sebald>
Sun 15 Apr 2018 04:18:52 PM UTC, comment #4: 

Yes, this was reported earlier as bug #53640 which was fixed quickly.  Marking as a duplicate and closing.

Rik <rik5>
Project Administrator
Sun 15 Apr 2018 04:13:43 PM UTC, comment #3: 

4.3.90 candidate.  OK, looking at tags in thg interface, that is prior to the bug fix that I linked to.

However, in my testing here with the latest stable version I'm seeing some annoying bugs concerning the Editor's Ctrl+F find behavior.  Ctrl+F, Ctrl+G, Ctrl+Shift+G and Escape all work, but the context in which they are active is dependent on which window has focus.  The way I currently see this is practically an unusable search.

When Editor is docked and focused, Ctrl+F opens a dialog search window.  Ctrl+G, Ctrl+Shift+G and Escape all work when the dialog window has focus.  But if clicking in the Editor to focus, these three no long work.  It would be nice if they did because then those shortcuts would still work even though the dialog box is closed.  (See the Documentation window behavior, and note that FireFox browser does the same thing...Ctrl+G still works after closing its "find footer".)

When Editor is floating, Ctrl+F also opens a dialog search window, but the situation is worse in the sense that the floated Editor window moves behind the main Octave GUI window.  Trying to get the Editor window and search dialog box visible at the same time doesn't work.

It appears to me that the Editor's Ctrl+F search dialog box has the wrong parent (the main GUI window) when it should be the Editor window as parent.

Dan Sebald <sebald>
Sun 15 Apr 2018 03:48:32 PM UTC, comment #2: 

Ctrl+Shift+F works, but Ctrl+G and Ctrl+Shift+G and Esc don't do anything, and they aren't listed in the preferences either.

Only Ctrl+F works if the editor window is floating

I tested with https://alpha.gnu.org/gnu/octave/octave-4.3.90.tar.lz

Alexander Wilms <alexanderw>
Sun 15 Apr 2018 03:40:06 PM UTC, comment #1: 

Is it just Ctrl+F?  There has been some activity with Ctrl+F, Ctrl+G, Ctrl+Shft+G, Escape recently:

https://savannah.gnu.org/bugs/?53640#postcomment
http://hg.savannah.gnu.org/hgweb/octave/rev/e74d85f7ac47

Those shortcuts are used by both the Editor and the Documentation widgets/windows (in the same meaning, they just open different search features), but with recent changes they are supposed to behave specific to the window that is active.  Does something change when the Editor and Documentation are/aren't floated?

Also, it appears that stable branch changes haven't recently been merged with default.  Which are you testing?

Dan Sebald <sebald>
Sun 15 Apr 2018 10:19:16 AM UTC, original submission:  

When the editor is focused and one presses Ctrl+F, the following message window appears:

[Ambiguous shortcut detected]
The key sequence 'Ctrl+F' is ambiguous. Use 'Configure Shortcuts' from the 'Settings' menu to solve the ambiguity.
No action will be triggered.

Resetting the shortcuts doesn't help and the issue occurs both with the en_US and de_DE locales.

Alexander Wilms <alexanderw>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by sebald (Posted a comment)
  • -email is unavailable- added by alexanderw (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-15 rik5 StatusNone => Duplicate
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5