bugGNU Octave - Bugs: bug #53529, Qt and osmesa related dection...

 
 

bug #53529: Qt and osmesa related dection error for stable

Submitted by:  Tatsuro MATSUOKA <tmacchant>
Submitted on:  Sat 31 Mar 2018 06:08:19 AM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  None Assigned to:  None
Originator Name:  Tatsuro MASTAUOKA Open/Closed:  Closed
Release:  dev Operating System:  GNU/Linux

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 03 Apr 2018 06:26:50 AM UTC, comment #9:

As Dan wrote in comment #1.

This is not a bug.

So please close this.

Tatsuro MATSUOKA <tmacchant>
Tue 03 Apr 2018 05:06:33 AM UTC, comment #8:

@Mike: thank you very much for you help (comment #5).
It fixed the QT5 problem for me.

Can you edit also https://wiki.octave.org/Octave_for_Debian_systems according to comment #5?

Can this report be closed as fixed?

Avinoam Kalma <avinoam>
Project Member
Sat 31 Mar 2018 08:53:36 PM UTC, comment #7:

Now that you mention it, I too recall some problems installing the Qt help tools. I'm not sure exactly which package it was, but "qttools5-dev-tools" rings a bell. I went to the Synaptic Package Manager (Mint, based on Ubuntu) and some package indicated installed, but instead of a green box, it was grey with an exclamation point in it. I simply uninstalled that and another nearby grey package and re-installed and things worked fine.

Dan Sebald <sebald>
Sat 31 Mar 2018 08:43:34 PM UTC, comment #6:

I followed the instruction
https://www.scivision.co/compiling-octave-4-on-ubuntu/

The tools you indicated were already installed.

(qtcore tools is installed at gnuplot build-dep install.)

However, some troubles happened after install.
(That breaks my wine install)

In struggling stage, I perhaps lost Qt5Help dev tool.
I installed qttools5-dev-tools to Ubuntu 16.04 on WSL
(Windows Subsystem on LInux) in my home PC.
As you said, qttools5-dev-tools installs Qt5Help dev tools.

I once remove qttools5-dev-tools and re-install it tomorrow.

Thanks!

Tatsuro MATSUOKA <tmacchant>
Sat 31 Mar 2018 07:35:15 PM UTC, comment #5:

Tatsuro - on Ubuntu you should only need to install the following Qt 5 packages

  • libqt5opengl5-dev
  • libqt5scintilla2-dev
  • qtbase5-dev
  • qtbase5-dev-tools
  • qttools5-dev
  • qttools5-dev-tools

The Qt5Help library is provided by the 'qttools5-dev' package.

Mike Miller <mtmiller>
Project Administrator
Sat 31 Mar 2018 05:20:23 PM UTC, comment #4:

I pushed the following changeset to disallow using both --gui and --no-gui-libs and to also exit if --gui is used when Octave is not built with the GUI.

http://hg.savannah.gnu.org/hgweb/octave/rev/53440f9bffba

John W. Eaton <jwe>
Project Administrator
Sat 31 Mar 2018 08:44:54 AM UTC, comment #3:

I write my workaround stable octave work again.

For Ubuntu 16.04 distribution , for Qt5Help, only run-time libraries are available. One have to construct dev kit using source of qttools.

Goto
https://launchpad.net/ubuntu/+source/qttools-opensource-src/5.5.1-3ubuntu0.1

Download
https://launchpad.net/ubuntu/+archive/primary/+files/qttools-opensource-src_5.5.1.orig.tar.xz

Archive it and copy header files for Qt5Help to standard location same as other Qt5 header files. Some header files are the indication to header files in src/assistant. Merger header file from src/assistant.

Copy another pkg-config file to Qt5Help.pc and modify it for Qt5Help.

Two symlinks were required in my case.

That's all my workaround for new stable source build.
(Ubuntu 16.04)

HTH

Tatsuro

Tatsuro MATSUOKA <tmacchant>
Sat 31 Mar 2018 06:43:29 AM UTC, comment #2:

Thanks. Perhaps Qt for Ubuntu 16.04 is incomplete.
libqt5help5 is installed but there is not Qt5Help.pc nor include files.

There seem to be no dev packages.

I will struggle for qt.

Anyway pleas close this tracker.

Tatsuro MATSUOKA <tmacchant>
Sat 31 Mar 2018 06:26:37 AM UTC, comment #1:

The fact that the GUI is not being built in your case is not a bug. There has a been a recent addition of embedded Documentation via the octave_interpreter.qhc and octave_interpreter.qch files. This requires some additional Qt features, in particular QHelpEngine, QHelpSearchEngine, etc. These new features appear in the package Qt5Help. The configure is reporting that you don't have this package, so you must install it.

However, the poster's original discussion list message was:

"
I have tried to execute octave gui

./run-octave --gui

But CLI octave start.
"

which I'm opening for discussion as a bug. My experience with command line options (in Unix) makes me think the program should fail to execute and return an error message if the --gui option is given and no GUI is available.

Dan Sebald <sebald>
Sat 31 Mar 2018 06:08:19 AM UTC, original submission:

Ubuntu 16.04, gcc-5.4.0, ID b940e457e11f

./configure --prefix=/opt/octave-stable --with-qt=5 --with-sundials_ida-includedir='/usr/local/include/ida' --with-sundials_ida-libdir='/usr/local/lib'

Compressed full config.log is attached.

Tatsuro MATSUOKA <tmacchant>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #43737:  config.log.tar.xz added by tmacchant (71KiB - application/x-xz)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Updated the item)
  • -email is unavailable- added by avinoam (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by sebald (Posted a comment)
  • -email is unavailable- added by tmacchant (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-04 rik5 Open/ClosedOpen => Closed
    2018-03-31 tmacchant Attached File- => Added config.log.tar.xz, #43737

    Back to the top


    Powered by Savane 3.4