bugGNU Octave - Bugs: bug #52855, Implementation of histcounts

 
 

bug #52855: Implementation of histcounts

Submitter:  Guillaume <gyom>
Submitted:  Wed 10 Jan 2018 10:16:20 AM UTC
   
 
Category:  Octave Function Severity:  1 - Wish
Priority:  3 - Low Item Group:  Feature Request
Status:  Invalid / Not an Octave Bug Assigned to:  None
Originator Name:  Guillaume Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Wed 10 Jan 2018 01:18:17 PM UTC, comment #2: 

Any further communication should happen in patch #8801 .

Closing report.

Kai Torben Ohlhus <siko1056>
Group Member
Wed 10 Jan 2018 12:11:51 PM UTC, comment #1: 

Apart from the few little fixes I advised, just time from the core devs.
I have used the functions a few times and saw no issues.

But why do you open a bug report if there's already a patch report?

Philip Nienhuis <philipnienhuis>
Group Member
Wed 10 Jan 2018 10:16:20 AM UTC, original submission:  

There is an histcounts function in Matlab:
https://www.mathworks.com/help/matlab/ref/histcounts.html
for which Lars Winterfeld proposed an implementation in Octave:
https://lists.gnu.org/archive/html/octave-maintainers/2015-11/msg00123.html
https://lists.gnu.org/archive/html/octave-maintainers/2015-11/msg00220.html
https://savannah.gnu.org/patch/index.php?8801
is there anything preventing its inclusion in Octave?
(sorry if this appears as a duplicate of the patch entry but it prevents a search on histcounts to be unsuccessful when searching through bugs)

Guillaume <gyom>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by gyom (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-01-10 siko1056 Severity3 - Normal 1 - Wish
        Priority5 - Normal 3 - Low
        StatusNone Invalid / Not an Octave Bug
        Open/ClosedOpen Closed

    Back to the top

    Powered by Savane 3.13-4b48.
    Corresponding source code