bugGNU Octave - Bugs: bug #46978, Octave crashes when typing an...

 
 

bug #46978: Octave crashes when typing an apostrophe in editor

Submitted by:  None
Submitted on:  Tue 26 Jan 2016 08:49:47 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Hervé Audren Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.0.0
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Fri 26 Feb 2016 06:10:41 AM UTC, comment #6: 

Are you sure that you cannot work around this by clearing the environment variables?

I can still reproduce bug #42469, but running

env QT_IM_MODULE= QT4_IM_MODULE= octave

avoids crashing Octave. Please try that exact command line, and run "getenv QT_IM_MODULE" and "getenv QT4_IM_MODULE" in Octave to verify that they are empty.

Even if you have a slightly different symptom, I think it's still safe to say this falls under the same category of Qscintilla not playing nice with input methods.

Mike Miller <mtmiller>
Project Administrator
Thu 28 Jan 2016 08:59:47 AM UTC, comment #5: 

Hello,

The bug seems to be the same indeed, octave crashes after displaying autocompletion and inputting a special character. However, I can't seem to make the bug go away by either unsetting QT_IM_MODULE and QT4_IM_MODULE or killing ibus-daemon. In both cases, the bug persists.

Cheers,
Hervé

Hervé Audren <haudren>
Wed 27 Jan 2016 10:07:12 AM UTC, comment #4: 

Hello,

It does seem so indeed. I don't have time to test this issue tonight so I cannot really confirm. It does seem to also affect fcitx though. But that may be the same root cause.

Cheers,
Hervé

Hervé Audren <haudren>
Wed 27 Jan 2016 04:40:19 AM UTC, comment #3: 

Is this the same as bug #42469? If so, this is a known issue with QScintilla (not just Octave) and can be worked around by uninstalling or disabling the ibus input module for Qt.

Mike Miller <mtmiller>
Project Administrator
Wed 27 Jan 2016 01:25:26 AM UTC, comment #2: 

Hello,

The only key that seems to trigger the incorrect behavior is the apostrophe key two columns left of the enter key, keycode 40, followed by the spacebar, keycode 57.

On a side note, the bug was confirmed by a colleague using another layout manager, fcitx did encounter the same crash. I don't think that this could be really relevant, but we are both using Alienware laptops (Unless this could be relevant to nvidia drivers that are quite bug-prone on those machines).

I was again able to crash Octave this morning in no time.

Cheers,
Hervé

Hervé Audren <haudren>
Tue 26 Jan 2016 08:13:36 PM UTC, comment #1: 

Thank you for the report. I am not able to reproduce the crash with the current default branch. I recognized several keys providing some sort of apostrophe on the US international keyboard layout. Which key exactly is leading to the crash on your system?

Torsten Lilge <ttl>
Project Member
Tue 26 Jan 2016 08:49:47 AM UTC, original submission:  

Hello,

When using Octave 4.0.0 on Ubuntu 14.04 (64bit) and the English (US) international keyboard layout (Selection is switched using ibus), typing an apostrophe in the editor tab causes Octave to crash. Note that in this layout, typing <'> does not output an apostrophe, it is used with another key to output accents such as <'> followed by <e> reesults in é or the literal apostrophe with <'> followed by <space>. Upon tapping the spacebar, octave crashes.

This does not occur with the regular English keyboard.

This bug does not occur all the time, to reproduce:
- Setup ibus to have both English (US) and English (US, International)
- Launch octave with "octave&" or "octave"
- Switch to the editor tab
- Type in some characters using the English (US) layout or English (US, International)
- Switch to English (US, International) if not already in use
- Type in an apostrophe (<'> + <space>)
- Program crashes

Upon crashing, I only get this console output:

octave exited with signal 11

Please contact me if I can provide any additional details.

---
octave --version
GNU Octave, version 4.0.0
Copyright (C) 2015 John W. Eaton and others.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.

Octave was configured for "x86_64-pc-linux-gnu".

---
Package: octave
Priority: optional
Section: math
Installed-Size: 4370
Maintainer: Mike Miller <mtmiller@debian.org>
Architecture: amd64
Version: 4.0.0-3ubuntu2~octave~trusty3

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by haudren (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-05-05 mtmiller StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
    2016-04-24 lachlan Dependencies- => bugs #47768 is dependent
    2016-02-08 lachlan Dependencies- => Depends on bugs #42469
    2016-01-27 mtmiller StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5