bugGNU Octave - Bugs: bug #47768, Octave crash when typing sqrt(A^...

 
 

bug #47768: Octave crash when typing sqrt(A^ in editor

Submitted by:  None
Submitted on:  Sat 23 Apr 2016 10:12:19 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Francois M Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.0.0
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Thu 05 May 2016 07:37:30 PM UTC, comment #14: 

I don't know why that prevents the crash for me but not for you. I still don't see anything different about this bug from the one we've seen before, it's reproducible in any qscintilla2 project, not just Octave. I'm going to just mark this as a duplicate and refer to bug #42469, which will have to be fixed in a future version of qscintilla2.

Mike Miller <mtmiller>
Project Administrator
Thu 05 May 2016 06:25:08 AM UTC, comment #13: 

Hi Mike,

I had indeed tried the method you proposed in comment #4 without success. I checked here after running the commands that both variables were properly unset but it did not prevent the crash.

Francois M <mfrancois>
Wed 04 May 2016 05:09:37 PM UTC, comment #12: 

Hi Francois,

I thought I gave enough information in comment #4, and in comment #5 you claim to have tried it and it did not work, but I'll be more explicit this time.

Open a terminal, and run the following at your shell prompt.

unset QT_IM_MODULE
unset QT4_IM_MODULE
octave --force-gui

The Octave GUI will appear. Run the following in Octave to make sure that both return empty strings

getenv QT_IM_MODULE
getenv QT4_IM_MODULE

If they are both empty (you just see "ans ="), then they are correctly unset. Now test the editor again and see if this prevents the crash from happening.

Mike Miller <mtmiller>
Project Administrator
Wed 04 May 2016 04:27:45 PM UTC, comment #11: 

Disabling the completion pop-up prevents the crash (at least if I don't call it manually).
I don't know how I can disable QT_IM_MODULE and QT4_IM_MODULE variables. They are currently both set to ibus.

Francois M <mfrancois>
Sat 30 Apr 2016 01:51:25 PM UTC, comment #10: 

I don't think it is possible, because the keyboard layout can be changed at any time on the fly, even if Qt has a way to query that.

Mike Miller <mtmiller>
Project Administrator
Fri 29 Apr 2016 01:24:39 AM UTC, comment #9: 

François, I see that the layout has two "^" symbols (in red).  I was using the one on the "6" key, but you were presumably using the one next to the "P" key.

Mike, until this bug is fixed in Scintilla, would it be worth looking for a way to check if the keyboard has dead keys, and clearing those variables explicitly before launching the editor?

Alternatively, is disabling the completion pop-up a feasible work-around?  I find it more distraction than help anyway and so disabled it.) Françcois, could you try disabling it through the Edit->Preferences->Editor menu?

Lachlan Andrew <lachlan>
Thu 28 Apr 2016 09:36:56 PM UTC, comment #8: 

I have added the standard Belgian keyboard layout, and I see the exact same symptoms as bug #46978. Specifically, only "dead keys" crash Octave, only when they are entered in the editor (because the bug is in Qscintilla), and only after a code completion popup is shown and dismissed. If I unset the QT_IM_MODULE and QT4_IM_MODULE environment variables, the crash does not occur.

Francois, you say that clearing those environment variables does not prevent the crash for you. I am certain that this should prevent the crash, it does for me. Can you run "getenv QT_IM_MODULE" and "getenv QT4_IM_MODULE" inside of Octave's command window to verify that they are both not set? Then can you also try the following:

  • completely uninstall the system "ibus-qt4" package
  • log out
  • log in again
  • run Octave and try to crash the editor again
Mike Miller <mtmiller>
Project Administrator
Thu 28 Apr 2016 09:06:08 PM UTC, comment #7: 

It is the standard Belgian layout. You can see it here :
https://commons.wikimedia.org/wiki/File:Belgian_keyboard_layout.png

Francois M <mfrancois>
Wed 27 Apr 2016 09:56:38 AM UTC, comment #6: 

I've just installed a keyboard that calls itself "Belgian", but can't reproduce this error.

It doesn't require pressing any key twice, or a space, but there are about 7 different Belgian variants in my system.  Can you be more specific about which Belgian layout you are using?

Lachlan Andrew <lachlan>
Mon 25 Apr 2016 07:54:46 PM UTC, comment #5: 

It seems it does not prevent the crash.
It exits with signal 11 in terminal.

Francois M <mfrancois>
Mon 25 Apr 2016 03:04:27 PM UTC, comment #4: 

Francois, can you try the workaround in the linked bug report?

Specifically, try running

env QT_IM_MODULE= QT4_IM_MODULE= octave

in a terminal and see if that prevents the crash.

Mike Miller <mtmiller>
Project Administrator
Sun 24 Apr 2016 11:34:30 AM UTC, comment #3: 

It may not interfere with â, but it is still a "compound" key, which may be triggering the same bug in Scintilla.  I'll put cross-references between these two bugs.

Lachlan Andrew <lachlan>
Sun 24 Apr 2016 10:16:07 AM UTC, comment #2: 

I'm using a Belgian keyboard.
In order to type '^' I have to press it twice or followed by a space, which should not interfer with Â.

Francois M <mfrancois>
Sun 24 Apr 2016 07:28:51 AM UTC, comment #1: 

François, what keyboard are you using?

There is a known problem (bug #46978) with creating accents on US-iternational keyboards.  Since ^ can be used to create â, I'm wondering if it is related.

Lachlan Andrew <lachlan>
Sat 23 Apr 2016 10:12:19 AM UTC, original submission:  

when typing the '^' character in

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by mfrancois (Posted a comment)
  • -email is unavailable- added by lachlan (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-05-05 mtmiller Dependencies- => Depends on bugs #42469
    2016-05-05 mtmiller StatusWorks For Me => Duplicate
        Open/ClosedOpen => Closed
    2016-04-28 rik5 Carbon-CopyRemoved 72865 => -
    2016-04-28 rik5 StatusNone => Works For Me
    2016-04-24 lachlan Dependencies- => Depends on bugs #46978

    Back to the top


    Powered by Savane 3.5