bugGNU Octave - Bugs: bug #45719, Segmentation faults during build

 
 

bug #45719: Segmentation faults during build

Submitted by:  Stefan Husmann <haawda>
Submitted on:  Fri 07 Aug 2015 08:40:47 PM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 04 May 2016 05:27:52 PM UTC, comment #6: 

We already have a fix in place for Octave built without OSMesa. The doc build will automatically fall back to gnuplot and continue.

The only remaining problem is if the nvidia OpenGL library causes a segmentation fault, we currently have no way to detect or work around that at runtime.

There are two other open bugs about this nvidia/osmesa conflict, see bug #44478 and bug #44979. I don't think there's anything different enough about this bug to keep it open, so closing as a duplicate of one of those. I'll add some information on bug #44478 since that is the most active, and the fix for that, if any, will probably fix this as well.

Mike Miller <mtmiller>
Project Administrator
Sat 08 Aug 2015 03:02:51 PM UTC, comment #5: 

Do we want to do anything specific to building the documentation to work around this issue? Prevent building the docs in cases where osmesa was not found or where we know it will segfault (if we are able to detect)?

Mike Miller <mtmiller>
Project Administrator
Sat 08 Aug 2015 09:29:03 AM UTC, comment #4: 

This is a duplicate of bug #44478

@Stefan: You could also try to preload the mesa driver with something like

export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libGL.so

Andreas Weber <andy1978>
Project Member
Sat 08 Aug 2015 09:09:58 AM UTC, comment #3: 

Indeed the problem went away when I install the nouveau drivers.

Stefan Husmann <haawda>
Sat 08 Aug 2015 07:52:25 AM UTC, comment #2: 

Yes, it fails.

[haawda@frege octave-build]$ LANG=C ./run-octave --path ../libinterp/dldfcn --eval "test _osmesa_print_"
panic: Segmentation fault -- stopping myself...
octave exited with signal 11

And yes, I use nvidia propiatary drivers. Would it help to switch to nouveau?

Stefan Husmann <haawda>
Fri 07 Aug 2015 11:21:09 PM UTC, comment #1: 

Looks like this may be due to either OpenGL or OSMesa. Do you happen to be using NVIDIA drivers and OpenGL stack? Can you try

$ ./run-octave --path ../libinterp/dldfcn --eval "test __osmesa_print__"

Does that also segfault? If so, I think this is still an open issue. If not, do you get segfaults from running any plots or demos of plot functions interactively?

Mike Miller <mtmiller>
Project Administrator
Fri 07 Aug 2015 08:40:47 PM UTC, original submission:  

Under Arch Linux 64 bit build fails with lots of segfaults when the various eps-files should be created.

Stefan Husmann <haawda>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #34593:  buildlog.txt added by haawda (2MiB - text/plain)

 

Carbon-Copy List
  • -email is unavailable- added by andy1978 (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by haawda (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-05-04 mtmiller Open/ClosedOpen => Closed
    2016-05-04 mtmiller Dependencies- => Depends on bugs #44979
    2015-08-08 mtmiller CategoryDocumentation => Configuration and Build System
    2015-08-08 mtmiller Dependencies- => Depends on bugs #44478
    2015-08-08 andy1978 StatusNeed Info => Duplicate
    2015-08-07 mtmiller StatusNone => Need Info
    2015-08-07 haawda Attached File- => Added buildlog.txt, #34593

    Back to the top


    Powered by Savane 3.5