bugGNU Octave - Bugs: bug #44979, check for osmesa is done at...

 
 

bug #44979: check for osmesa is done at runtime and not configure

Submitted by:  CarnĂ« Draug <carandraug>
Submitted on:  Fri 01 May 2015 12:40:30 PM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.0.0 Operating System:  GNU/Linux

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 17 May 2018 10:27:15 PM UTC, comment #4:

OSMesa is now disabled by default when building with a recent enough version of Qt. I doubt any changes will be made in the way Octave detects and uses OSMesa, until we finally remove it because it's been so problematic. Closing as wont fix.

Mike Miller <mtmiller>
Project Administrator
Tue 02 Jun 2015 04:10:56 PM UTC, comment #3:

Retagging release from 4.0.0-rc4 to 4.0.0.

John W. Eaton <jwe>
Project Administrator
Fri 01 May 2015 08:04:51 PM UTC, comment #2:

@Andreas: Do you want to bring up the question of making OSMesa experimental on the OCtave-Maintainer's mailing list? It would be simplest for this release to make it experimental.

Rik <rik5>
Project Administrator
Fri 01 May 2015 02:43:50 PM UTC, comment #1:

There is in configure.ac:

We had a quick discussion on the mailinglist that the configure script doesn't check for versions but rather for bugs or functions. The problem here is, that OSMesa only fails if linked with Octave. (a typical bootstrap problem).

On my tests with OSMesa on Debian I figured out that one symptom from linking Octave against an old libosmesa is, that the buffer_depths are totally screwed up when reading back and I used this to show an hint.

We have alo bug #44478 which makes OSMesa completely useless if proprietary Nvidia drivers are used.

Perhaps we should mark OSMesa as experimental and disable it per default.

Andreas Weber <andy1978>
Project Member
Fri 01 May 2015 12:40:30 PM UTC, original submission:

Testing octave 4.0.0-rc4 on CentOS 5.11. Tests for osmesa_print fail correctly because of old version being used.

Indeed Octave was built with version OSMesa 6.5.1 but if we know this, shouldn't this test be done by configure instead?

Carnë Draug <carandraug>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by andy1978 (Posted a comment)
  • -email is unavailable- added by carandraug (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-05-17 mtmiller StatusNone => Wont Fix
        Open/ClosedOpen => Closed
    2016-05-04 mtmiller Dependencies- => bugs #45719 is dependent
    2015-06-02 jwe Release4.0.0-rc4 => 4.0.0

    Back to the top


    Powered by Savane 3.3