bugGNU GRUB - Bugs: bug #59286, Grub 2.04 loopback command hangs...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #59286: Grub 2.04 loopback command hangs in UEFI systems

Submitted by:  Hedayat Vatankhah <hedayat>
Submitted on:  Sat 17 Oct 2020 01:16:49 PM UTC  
 
Category:  Booting Severity:  Major
Priority:  5 - Normal Item Group:  Software Error
Status:  None Privacy:  Public
Assigned to:  None Originator Name: 
Open/Closed:  Open Release: 
Release:  other Reproducibility:  Every Time
Planned Release:  None

Sat 17 Oct 2020 01:16:49 PM UTC, original submission:  

With Grub 2.04 on UEFI systems, running the following command in grub hangs:
loopback loop /isodir/distro_iso_file.iso

As already being noted in Debian/Ubuntu bug reports [1][2], unloading tpm module fixes the problem. They guess that grub is trying to verify the whole ISO. I'm also seeing this problem in Fedora, and the 'rmmod tpm' workaround works for me too.

[1] https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1851311
[2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=959425

Hedayat Vatankhah <hedayat>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by hedayat (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.5