bugGNU GRUB - Bugs: bug #50749, Boot fails due to EFI grub.cfg...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #50749: Boot fails due to EFI grub.cfg missing braces around root partition e.g. hd0,gpt4

Submitted by:  Derek Macias <dmacias>
Submitted on:  Fri 07 Apr 2017 02:38:27 PM UTC  
 
Category:  Booting Severity:  Major
Priority:  5 - Normal Item Group:  None
Status:  Invalid Privacy:  Public
Assigned to:  None Originator Name:  Derek Macias
Open/Closed:  Closed Release: 
Release:  2.02~beta1 Reproducibility:  Every Time
Planned Release:  None

Fri 07 Apr 2017 04:51:08 PM UTC, comment #1: 

Upstream does not create grub.cfg on ESP. Please open report in Ubuntu bug tracker.

Andrei Borzenkov <arvidjaar>
Project Member
Fri 07 Apr 2017 02:38:27 PM UTC, original submission:  

I created a UEFI usb boot disk of Linux Mint 18.1 Cinnamon x64. Installation is on a 256GB internal SSD (/dev/sda). I have /dev/sda1 which is 100 MiB EFI system partition with mount point at /boot/efi formatted to fat32 and /dev/sda4 is root formatted to xfs. Install went fine except that on reboot I get the grub console. I tracked down the problem to grub-efi-amd64 or grub-efi-amd64-signed created a /boot/efi/EFI/ubuntu/grub.cfg with missing () arround the root partition which is the reason for the failed boot. Here is the line created in grub.cfg:

search.fs_uuid 6ef44b4a-5164-4f1d-83b2-1cc82720dde0 root hd0,gpt4

should be:sudo apt install --reinstall grub-efi-amd64-signed or
sudo apt install --reinstall grub-efi-amd64

search.fs_uuid 6ef44b4a-5164-4f1d-83b2-1cc82720dde0 root (hd0,gpt4)

This can be recreated by deleting the /boot/efi/EFI/ubuntu/grub.cfg and running

sudo apt install --reinstall grub-efi-amd64-signed or
sudo apt install --reinstall grub-efi-amd64ed the package

4/5/17) I upgraded (2.02~beta2-36ubuntu3.8) to 2.02~beta2-36ubuntu3.9. The same result. No braces around root partition.

Derek Macias <dmacias>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by arvidjaar (Posted a comment)
  • -email is unavailable- added by dmacias (Submitted the item)
  • -email is unavailable- added by dmacias
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-04-07 arvidjaar StatusNone => Invalid
        Open/ClosedOpen => Closed
    2017-04-07 dmacias Carbon-Copy- => Added derekmacias@live.com

    Back to the top


    Powered by Savane 3.7