bugGNU GRUB - Bugs: bug #50232, No input on usb keyboard after...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #50232: No input on usb keyboard after terminal_input at_keyboard command

Submitted by:  sean <alpharoot>
Submitted on:  Mon 06 Feb 2017 01:14:26 AM UTC  
 
Category:  Booting Severity:  Major
Priority:  5 - Normal Item Group:  None
Status:  Invalid Privacy:  Public
Assigned to:  None Originator Name:  alpharoot
Open/Closed:  Closed Release: 
Release:  other Reproducibility:  Every Time
Planned Release:  None

Sun 05 Mar 2017 08:01:45 AM UTC, comment #1: 

You need to use usb_keyboard and appropriate USB controller drivers, not at_keyboard

Vladimir Serbinenko <phcoder>
Project Administrator
Mon 06 Feb 2017 01:14:26 AM UTC, original submission:  

I'm using Gentoo on my desktop with the latest grub-2.02_beta3-r1. I'm trying to set my grub (EFI) up to use a non qwerty layout so I can more easily type in grub (and specifically use grub encryption and type in a long passphrase). The steps to do so seem pretty straight forward :

`ckbcomp dvorak | grub2-mklayout -o /boot/grub/dvorak.gkb`
(no problem, keymap file is good)

either append to the end of grub.cfg, use one of the grub.d files (or /etc/default/grub GRUB_TERMINAL_INPUT variable) to make the following changes, or just type in the commands manually when booted in grub, either way the results are always the same :
`terminal_input at_keyboard`
(grub wont allow any input from the usb keyboard anymore - although ctrl+alt+del still works)

I tried 3 different USB keyboards, across usb 2, 3, 3.1 ports on 3 different motherboards (with different chipsets), all produced the same issue. I tried to reproduce the issue on my laptop then - and it didn't exist! So on my laptop I was able to use the built-in keyboard and do :
`terminal_input at_keyboard`
(didn't stop responding this time)
`insmod keylayouts`
`keymap /boot/grub/dvorak.gkb`

and it properly loaded my dvorak keymap. What was interesting though when I plugged a USB keyboard into my laptop, it would still stop responding to input on the usb keyboard, after issuing the `terminal_input at_keyboard` command. However, when the usb keyboard was in a "frozen" state, the on-board laptop keyboard was still functional.

I tried going through the BIOS on each of these systems and tried every combination of USB keyboard settings (EHCI Handoff etc), and it didn't help. I tried various combinations of before/after `terminal_input at_keyboard` issuing insmod ehci/uhci/ohci and it still didn't help.

If I issue this command instead on my laptop with USB keyboard plugged in:
`terminal_input at_keyboard console`

that keeps both the on-board keyboard and usb keyboard active input wise. So if I then try :
`insmod keylayouts`
`keymap /boot/grub/dvorak.gkb`

it only changes the keylmap of the on-board keyboard and the USB one remains default/qwerty.

I also tried to replicate this in VMware and I couldn't.

This bug reported to debian a few years ago seems like it may be the same issue :
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741464

In there Marco said he had success with this command :
`terminal_input at_keyboard ; outb 0x64 0x60 ; outb 0x60 0x64`

However, it did not change the behaviour for me on my laptop.

I noticed Andrei's comment in a similar (but much different) bug :
https://savannah.gnu.org/bugs/?func=detailitem&item_id=46135

Saying : "It could also be hardware related. at_keyboard competes with BIOS for input characters and may leave system in strange state." I'm not sure what exactly that implies and if it's resolvable somehow.

I'm not really sure where else to go from here. This has to be a specific bug that only effects some people, since a lot of the world doesn't use QWERTY I have to imagine this isn't a problem for them, or there's another way to go about changing the keymap in grub that I couldn't find.

sean <alpharoot>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by phcoder (Posted a comment)
  • -email is unavailable- added by alpharoot (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-03-05 phcoder StatusNone => Invalid
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.7