bugGNU GRUB - Bugs: bug #493, grub-install should make a backup...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #493: grub-install should make a backup of the boot sector

Submitted by:  Jason Thomas <jthomas>
Submitted on:  Wed 29 May 2002 12:52:54 AM UTC  
Votes:  80  
 
Category:  Installation Severity:  Minor
Priority:  1 - Later Item Group:  Feature Request
Status:  Wont Fix Privacy:  Public
Assigned to:  Yoshinori K. Okuji <okuji> Originator Name: 
Open/Closed:  Closed Release:  0.92
Release:  None Reproducibility:  Every Time
Planned Release:  None

Fri 21 Apr 2017 05:02:00 PM UTC, comment #4: 

Probably instead of a full "uninstall feature", GRUB could just automatically make a copy of at least the MBR to, say:

/boot/grub/backup/mbr_[timestamp]

That's what most users do anyway using the 'dd' command before installing GRUB on the MBR, and most of the times that copy is not needed, or if it's needed the user would know (or learn) how to use it. It would help when they forget to do that backup or if the wrong command was issued.

Mar Goli <golimarrrr>
Sat 29 Jun 2002 09:07:15 PM UTC, comment #3: 

I decided to close this report, because nobody shows
interest in it seriously. If you want the feature really,
post another report to the BTS with your opinion on how
it should work.

Okuji

Yoshinori K. Okuji <okuji>
Project AdministratorIn charge of this item.
Fri 31 May 2002 12:32:04 AM UTC, comment #2: 

Uggh... The URL in the previous message wasn't processed correctly.
This is the correct URL (I hope this will be processed properly):

http://www.mail-archive.com/bug-grub%40gnu.org/msg05769.html

Okuji

Yoshinori K. Okuji <okuji>
Project AdministratorIn charge of this item.
Thu 30 May 2002 05:29:49 PM UTC, comment #1: 

I posted a proposal to bug-grub:

http://www.mail-archive.com/bug-grub@gnu.org/msg05769.html

There is no follow-up until now. So I assume that the priority
is really low. Probably I won't work on that, unless someone
replies to me.

Okuji

Yoshinori K. Okuji <okuji>
Project AdministratorIn charge of this item.
Wed 29 May 2002 12:52:54 AM UTC, original submission:  
Jason Thomas <jthomas>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by golimarrrr (Posted a comment)
  • -email is unavailable- added by golimarrrr (Voted in favor of this item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 80 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 10 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-04-21 golimarrrr Carbon-Copy- => Added golimarrrr
    2002-06-29 okuji SeverityMajor => (Error - Not Found)
        StatusNone => (Error - Not Found)
        Open/ClosedAccepted => (Error - Not Found)
        Closed on- => -
    2002-05-30 okuji Priority100(Error - Not Found) => (Error - Not Found)
        Assigned toNone => NA
        Open/ClosedOpen => (Error - Not Found)
        Release =>
        ReproducibilityNone => (Error - Not Found)

    Back to the top


    Powered by Savane 3.7