bugGNU GRUB - Bugs: bug #43983, alloc magic is broken at...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #43983: alloc magic is broken at 0x7ff16f90 when nativedisk usbms

Submitted by:  adrian15 <adrian15sgd>
Submitted on:  Mon 12 Jan 2015 02:15:49 AM UTC  
 
Category: TerminalSeverity: Major
Priority: 6Item Group: None
Status: NonePrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: OpenRelease: 
Release: Git masterReproducibility: Every Time
Planned Release: 2.02

Thu 29 Jan 2015 03:30:43 PM UTC, comment #3:

Grub cannot run two platforms at the same time, so there is no need to have second one.

I do not use VB, I use QEMU.

Andrei Borzenkov <arvidjaar>
Project Member
Sun 18 Jan 2015 02:40:59 AM UTC, comment #2:

If you check my last comment you will see that my commands make sure that I do not have any grub2 package installed.

If you know how to build both pc and efi platforms in the same command so that I can use your proposed command to avoid having to install grub2 with make install into my chroot that would be nice.

What Virtualbox version are you using?

adrian15 <adrian15sgd>
Sat 17 Jan 2015 10:21:18 AM UTC, comment #1:

I can't reproduce it using current git. Your command grub-mkrescue does not use build directory so you are using some grub version provided by your distribution. To create rescue CD from just compiled grub use

pkgdatadir=$PWD ./grub-mkrescue -d grub-core -o /tmp/test1.iso

from build directory after make has completed.

Andrei Borzenkov <arvidjaar>
Project Member
Mon 12 Jan 2015 02:15:49 AM UTC, original submission:

Jessie chroots - Package I installed
--------------------------------------------

python autoconf bison flex unicode libfreetype6-dev

Affected GIT commit
-------------------

bac5d1a64ab4191058a8fd4c05f6b3b339e249e7

Build system
-------------

Debian Jessie from 12 January 2015
Build options

./configure --with-platform=efi at first pass.
./configure --with-platform=pc at second pass.

How do I build and prepare my system
------------------------------------
Make sure no Debian grub package is found in chroot

apt-get remove '.grub.'
Grub2 (efi+pc)) Build and installation

# Make sure we are testing the right revision
mkdir grub_upstream
cd grub_upstream
git clone git://git.savannah.gnu.org/grub.git .
git checkout COMMIT-TO-TEST
# Remove any non git related file - BEGIN
git reset --hard
git clean -f -d
git clean -f -x -d

# Remove any non git related file - END
# Build efi based grub and install it - BEGIN
./autogen.sh && ./configure --enable-grub-mkfont --with-platform=efi && make
# Dont forget to delete any rest of previous installation - BEGIN
sudo rm -rf /usr/local/etc/grub.d/ /usr/local/bin/grub-* /usr/local/share/grub/
# Dont forget to delete any rest of previous installation - END
sudo make install
# Build efi based grub and install it - END
make clean # Prepare for next build
./configure --enable-grub-mkfont --with-platform=pc && make # Prepare for a i386 build
sudo make install # Install i386 build

Super Grub2 Disk build
----------------------
grub-mkrescue --output=/tmp/test1.iso

VM system
----------

Virtualbox 4.3.10 r93012
Enable EFI option is unchecked!
Cdrom drive: super_grub2_disk_2.00s2.iso
Disk 1: Windows 7 and Debian

How to reproduce the bug
-------------------------

If needed press 'c' to go to grub shell.

# Test 1 (Which does not rise the bug. Just for your reference.)

grub> nativedisk pata
error: no device connected.
error: no device connected.
error: no device connected.
grub> nativedisk ahci
grub> nativedisk usbms
grub> nativedisk ohci
grub> nativedisk uhci
grub> nativedisk ehci
grub>

# Test 2 (Identical to Test 1 but adding ls commands. Now the bug is risen.)

grub> nativedisk pata
error: no device connected.
error: no device connected.
error: no device connected.
grub> ls
(ata2) (ata2,apple4) (ata2,apple3) (ata2,apple2) (ata2,apple1) (ata2,gpt3) (ata2,gpt2) (ata2,gpt1)
grub> nativedisk ahci
grub> ls
(ahci0) (ata2) (ata2,apple4) (ata2,apple3) (ata2,apple2) (ata2,apple1) (ata2,gpt3) (ata2,gpt2) (ata2,gpt1)
grub> nativedisk usbms
alloc magic is broken at 0x7ff16f90: 0
Aborted. Press any key to exit.
# I press a key
FATAL: INT18: BOOT FAILURE
(Grub is hang).

I'm using Virtualbox 4.3.20 r96996.

adrian15 <adrian15sgd>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Updated the item)
  • -unavailable- added by arvidjaar (Posted a comment)
  • -unavailable- added by adrian15sgd (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 11 Oct 2016 12:45:23 PM UTCphcoderPriority3 - Low=>6
    Tue 11 Oct 2016 12:45:05 PM UTCphcoderPriority5 - Normal=>3 - Low
    Wed 02 Mar 2016 02:15:48 PM UTCphcoderPlanned ReleaseNone=>2.02

    Back to the top


    Powered by Savane 3.1-cleanup1