bugGNU GRUB - Bugs: bug #41447, pxechainloader fails to load a pxe...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #41447: pxechainloader fails to load a pxe image

Submitted by:  dchawla <dchawla>
Submitted on:  Mon 03 Feb 2014 07:51:55 PM UTC  
 
Category: BootingSeverity: Major
Priority: 5 - NormalItem Group: None
Status: NonePrivacy: Public
Assigned to: NoneOriginator Name: dchawla
Open/Closed: OpenRelease: 
Release: Git masterReproducibility: Every Time
Planned Release: None

Mon 03 Feb 2014 07:51:55 PM UTC, original submission:

I have a setup where pxe clients boot grub over the network and boot different operating systems based on user's choice.
Now I have a need to load a custom PXE boot loader from pxegrub and pxechainloader seems to load the image (confirmed with tcpdump output) but running the boot command after pxechainloader, it resets the pxe client.
I have verified that the PXE image works fine with used without pxegrub (pxe clients can directly load and run the custom pxe image).
I also tried reloading the pxegrub image from within the PXE booted grub, but it too reset the pxe client.

I'm using grub from the git master as pxechainloader seems to be broken in grub-2.00

Commands to reproduce:

pxechainloader pxegrub.0
boot

dchawla <dchawla>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by dchawla (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup