bugGNU GRUB - Bugs: bug #41393, super grub2 and grub in general...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #41393: super grub2 and grub in general doesn't read ext2 usb flash when the system only supports legacy usb devices

Submitted by:  Alan Fujinami <needgrace>
Submitted on:  Wed 29 Jan 2014 05:05:39 PM UTC  
 
Category: BootingSeverity: Major
Priority: 5 - NormalItem Group: Software Error
Status: InvalidPrivacy: Public
Assigned to: NoneOriginator Name: Alan Fujinami
Open/Closed: ClosedRelease: 
Release: 1.98Reproducibility: None
Planned Release: None

Fri 28 Feb 2014 09:14:05 AM UTC, comment #1:

You have to use nativedisk for such cases.

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 29 Jan 2014 05:05:39 PM UTC, original submission:

Debian 7.2 netinst install fails to boot after installation.

The symptom on trying to boot from the newly installed debian from the usb flash drive is "error: unknown filesystem" and then dropping out into the grub rescue prompt.

The system is a Pentium 4 based system. In other words it is an older system. dmidecode shows USB "legacy is supported".

Much digging through various website/usergroups shows several people who seem to have the same symptoms but some of those who offer "solutions" don't seem to have a problem booting USB installation of debian/ubuntu...

taking one of the "solution" suggestions was to get super grub 2 disk. So I did. But that could not find the installed linux. It reported that no OS was found.

Upon many attempts, one attempt was to partition my 16GB flash drive to have 2GB vfat16, 12GB ext2,1GB swap and the rest unused...

The linux installation was installed on the ext2 partition which had the master boot record pointing to it. Then I copied the /boot directory onto the vfat paritian and supergrub2 was able to see that "OS"... attempting to run that, however, did not quite work but it was able to recognize its existence and attempt to load it.

I then able to get to the grub prompt and any attempt to reference the ext2 partitian also resulted in "unknown filesystem".

If I am not mistake, grub2 uses the built in driver to read the "disk" but this built in driver is only for msdos formatted drives. So, whether a USB flash drive or a USB physical drive formatted as ext2 results in this same error whereas an internal ide drive formatted to ext2 installs and boots up without a problem.

Obviously one solution would be to upgrade the bios if that is possible. But that doesn't seem possible in this case as the systems are old and it isn't clear that an upgrade is available.

Perhaps the answer is I am SOL... I hope not though... it seems like if I can install grub onto the vfat partitian and have that be able to see the ext2 partitian then that would be a workable solution.

Additional information is that the computer, given a driver, can read USB flash formatted as ext2. Just not during boot up.

Alan Fujinami <needgrace>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Posted a comment)
  • -unavailable- added by needgrace (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 28 Feb 2014 09:14:05 AM UTCphcoderStatusNone=>Invalid
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup