bugGNU GRUB - Bugs: bug #39750, Booting from syslinux via lnxboot...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #39750: Booting from syslinux via lnxboot no longer figures out root partition

Submitted by:  Josh Triplett <joshtriplett>
Submitted on:  Sun Aug 11 06:24:27 2013  
 
Category: BootingSeverity: Major
Priority: 5 - NormalItem Group: Software Error
Status: FixedPrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: ClosedRelease: 
Release: Bazaar - trunkReproducibility: Every Time
Planned Release: None

Thu Sep 19 15:18:20 2013, comment #4:

> As discussed on IRC offsets used seem to contradict official boot protocol documentation. Where did you get those values?


From the original GRUB code removed in bzr revno 3592, from the syslinux source, and from testing and verifying that this code works.

I'd be happy to drop the BSD disklabel support from the patch, since I have no way of testing it (I just copied it from the assumed-working previous GRUB code), but the BIOS disk support most definitely works and fixes the observed regression.

Josh Triplett <joshtriplett>
Thu Sep 19 08:09:24 2013, comment #3:

As discussed on IRC offsets used seem to contradict official boot protocol documentation. Where did you get those values?

Vladimir Serbinenko <phcoder>
Project Administrator
Mon Aug 19 19:47:26 2013, comment #2:

I've attached a new version of the patch, which removes extraneous autogen noise, and adds a changelog entry to be added to ChangeLog when applying the patch.

Josh Triplett <joshtriplett>
Sun Aug 11 22:22:27 2013, comment #1:

Attaching a patch that fixes this issue. With this patch, GRUB can again find its root device when booting on a partitioned disk via syslinux and lnxboot.

(file #28814)

Josh Triplett <joshtriplett>
Sun Aug 11 06:24:27 2013, original submission:

When booting a grub image from syslinux via lnxboot on a partitioned disk, grub used to properly detect the root filesystem, and thus find its modules and config file. Current versions of grub have broken this, and no longer detect the partition; grub looks for its files on (hd0)/boot/grub rather than (hd0,1)/boot/grub, which won't work on a partitioned disk.

It looks like this change occurred in bzr revno 3592, on the assumption that the only way the partition number would be set is via the archaic "setdevice" command (run on a Linux kernel image before booting it). However, that same mechanism is also used by other bootloaders that know how to boot a Linux kernel image, such as syslinux.

Please consider re-adding this functionality.

Josh Triplett <joshtriplett>

 

Attached Files
file #28879:  grub-lnxboot-boot-device-partition.patch added by joshtriplett (1kB - text/x-diff - Updated patch; removes extraneous autogen noise, and adds a changelog entry to be added to ChangeLog when applying the patch.)
file #28814:  grub-lnxboot-boot-device-partition.patch added by joshtriplett (997B - text/x-diff - Patch to re-add support to lnxboot for saving the boot device partition)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Posted a comment)
  • -unavailable- added by joshtriplett
  • -unavailable- added by joshtriplett (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon Sep 23 12:32:55 2013phcoderStatusNone=>Fixed
      Open/ClosedOpen=>Closed
    Mon Aug 19 19:46:35 2013joshtriplettAttached File-=>Added grub-lnxboot-boot-device-partition.patch, #28879
    Sun Aug 11 22:22:27 2013joshtriplettAttached File-=>Added grub-lnxboot-boot-device-partition.patch, #28814
    Sun Aug 11 06:26:33 2013joshtriplettCarbon-Copy-=>Added -unavailable-

    Back to the top


    Powered by Savane 3.1-cleanup