bugGNU GRUB - Bugs: bug #38738, GRUB hangs up when booting if...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #38738: GRUB hangs up when booting if GRUB_GFXMODE=auto

Submitted by:  Iván De Gyves <foxburu>
Submitted on:  Mon 15 Apr 2013 06:44:34 AM UTC  
 
Category: BootingSeverity: Major
Priority: 5 - NormalItem Group: Software Error
Status: NonePrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: OpenRelease: 
Release: Bazaar - trunkReproducibility: Every Time
Planned Release: None

Tue 16 Apr 2013 03:45:56 AM UTC, comment #5:

Here the grub.cfg and the /etc/default/grub file.

(file #27886, file #27887)

Iván De Gyves <foxburu>
Mon 15 Apr 2013 02:23:50 PM UTC, comment #4:

Please attach your noth grub.cfg (you confuse concept so I'm not sure what you really mean) and don't use debug=all on EFI, it doesn't work due to EFI memory management.

Vladimir Serbinenko <phcoder>
Project Administrator
Mon 15 Apr 2013 08:14:57 AM UTC, comment #3:

Oh, yes, File #27881 is on "console", #27879 is on "auto". The corrupted screen on #27880 is visible on the top of screen.

Iván De Gyves <foxburu>
Mon 15 Apr 2013 08:13:21 AM UTC, comment #2:

It hangs after the choice of entry. The last think i see is the line "Loading Linux Kernel..." then it hangs.

I've put some debug info, and the corrupted screen on attachments. Also the videoinfo on "auto" and "console".

I'll try adding resolution explicitly and see if that changes the whole thing.

(file #27879, file #27880, file #27881)

Iván De Gyves <foxburu>
Mon 15 Apr 2013 07:09:20 AM UTC, comment #1:

At which stage does it hang? Before or after the choice of entry? What's the last thing that you see? There is no GRUB_GFXMODE=text, you just make mode selection fail and it's equivalent to setting GRUB_TERMINAL_OUTPUT=console. Can you attach a picture of this corruption and the output of "videoinfo" when booted in text mode? Did you try setting resolution explicitly?

Vladimir Serbinenko <phcoder>
Project Administrator
Mon 15 Apr 2013 06:44:34 AM UTC, original submission:

I have a problem when booting on GRUB while using GRUB_GFXMODE=auto on BZR Revision 4820. I have a Inspiron 14z, with hybrid graphics (ATI / Intel, Muxless system), bios revision A10, booting with UEFI.

If I set the mode to auto, it just hangs up and a small screen corruption is seen on the screen. If i put GRUB_GFXMODE=text on /etc/default/grub and then regenerate the /boot/grub/grub.cfg, the system works correctly.

More specs:

OS: Arch Linux x86_64
GRUB: grub-efi-x86_64-bzr [Rev. 4820]
Linux Kernel: 3.8.6-1-ARCH

Output of lspci and dmesg | efi on files.

Iván De Gyves <foxburu>

 

Attached Files
file #27886:  default_grub added by foxburu (2kB - application/octet-stream)
file #27887:  grub.cfg added by foxburu (4kB - application/octet-stream)
file #27879:  IMG_20130415_025338.jpg added by foxburu (492kB - image/jpeg)
file #27880:  IMG080.jpg added by foxburu (704kB - image/jpeg)
file #27881:  IMG_20130415_025136.jpg added by foxburu (462kB - image/jpeg)
file #27877:  lspci.txt added by foxburu (2kB - text/plain)
file #27878:  dmesg-efi.txt added by foxburu (11kB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Posted a comment)
  • -unavailable- added by foxburu (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 16 Apr 2013 03:45:56 AM UTCfoxburuAttached File-=>Added default_grub, #27886
      Attached File-=>Added grub.cfg, #27887
    Mon 15 Apr 2013 08:13:21 AM UTCfoxburuAttached File-=>Added IMG_20130415_025338.jpg, #27879
      Attached File-=>Added IMG080.jpg, #27880
      Attached File-=>Added IMG_20130415_025136.jpg, #27881
    Mon 15 Apr 2013 06:44:34 AM UTCfoxburuAttached File-=>Added lspci.txt, #27877
      Attached File-=>Added dmesg-efi.txt, #27878

    Back to the top


    Powered by Savane 3.1-cleanup