bugGNU GRUB - Bugs: bug #38358, grub-install Manpage/Info should...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #38358: grub-install Manpage/Info should include --root-directory

Submitted by:  Jan Anlauff <j4n>
Submitted on:  Wed 20 Feb 2013 08:21:58 PM UTC  
 
Category: DocumentationSeverity: Major
Priority: 5 - NormalItem Group: Feature Request
Status: Wont FixPrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: ClosedRelease: 
Release: Bazaar - trunkReproducibility: Every Time
Planned Release: None

Sun 24 Feb 2013 03:13:59 PM UTC, comment #1:

--root-directory is just a compatibility alias, intentionaly undocumented. Using --root-directory=$x or --boot-directory=$x/boot are completely equivalent. --root-directory=DEVICE doesn't exist. Nor does --boot-directory=DEVICE. If autodetection fails upgrade, if bug persist please supply more info so we can know where the problem is.Adding bunch of overrides is nearly never a solution.

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 20 Feb 2013 08:21:58 PM UTC, original submission:

When re-installing grub from a live CD, the option --root-directory <device> comes in very handy when /boot is on a RAID 1, as auto-detection fails. It is not documented in the manpage, only the --boot-directory. I propose the following addition:

Jan Anlauff <j4n>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Posted a comment)
  • -unavailable- added by j4n (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 05 Apr 2013 07:44:10 AM UTCphcoderOpen/ClosedOpen=>Closed
    Sun 24 Feb 2013 03:13:59 PM UTCphcoderStatusNone=>Wont Fix

    Back to the top


    Powered by Savane 3.1-cleanup