bugGNUstep - Bugs: bug #34551, menus don't work when using os x...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #34551: menus don't work when using os x 10.4 X11.app

Submitted by:  Eric Wasylishen <ericw>
Submitted on:  Fri 14 Oct 2011 07:46:57 PM UTC  
 
Category: BackendSeverity: 2 - Minor
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Sat 22 Oct 2011 01:13:57 PM UTC, comment #1:

You will have to debug into the method [XGServer mouseLocationOnScreen:window:] to find out what is going on here.

Fred Kiefer <FredKiefer>
Project Member
Fri 14 Oct 2011 07:46:57 PM UTC, original submission:

I tested GNUstep with the X display running on an OS X 10.4 machine's X11.app. Clicking on the menu didn't do anything; -[NSWindow mouseLocationOutsideOfEventStream] was failing (some X errors were logged) and retuning {-1, -1}. The X errors were that the root window for the screen wasn't a valid window.

Could just be a buggy X server, but it would be nice if it worked.

Eric Wasylishen <ericw>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by FredKiefer (Posted a comment)
  • -unavailable- added by ericw (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup