bugGNU GRUB - Bugs: bug #3343, fails to compile: undefined...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #3343: fails to compile: undefined reference to memcpy

Submitted by:  Invalid User ID <Invalid User ID>
Submitted on:  Sun 27 Apr 2003 11:21:42 AM UTC  
 
Category: CompilationSeverity: Major
Priority: 5 - NormalItem Group: Non-software Error
Status: Wont FixPrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: ClosedRelease: 0.93
Release: NoneReproducibility: Every Time
Planned Release: None

Fri 09 Jan 2004 09:50:08 PM UTC, comment #3:

The problem is NOT caused by -O3. It's caused by a poor API.

Anonymous
Fri 09 Jan 2004 09:48:44 PM UTC, comment #2:

There's a better fix. The API to ti_get_term() and ti_set_term() should use a pointer instead of implicitly copying the argument by using assigment. Since there's only a single user of the "struct terminfo" (builtins.c), there's no need to copy. Please fix it this way instead of hacking around this.

Anonymous
Sun 16 Nov 2003 02:37:11 PM UTC, comment #1:

Do not specify -O3 or other options to gcc.

Yoshinori K. Okuji <okuji>
Project Administrator

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

Follow 2 latest changes.

Date Changed By Updated Field Previous Value => Replaced By
Sun 16 Nov 2003 02:37:11 PM UTCokujiStatusNone=>(Error - Not Found)
  Open/ClosedOpen=>(Error - Not Found)

Back to the top


Powered by Savane 3.1-cleanup