bugGNU GRUB - Bugs: bug #26874, support for crashkernel= in...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #26874: support for crashkernel= in 10_linux.in

Submitted by:  Michael Vogt <mvogt>
Submitted on:  Wed 24 Jun 2009 09:49:52 AM UTC  
 
Category: BootingSeverity: Major
Priority: 5 - NormalItem Group: None
Status: Wont FixPrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: ClosedRelease: 1.96
Release: 1.96Reproducibility: Every Time
Planned Release: None

Mon 04 Nov 2013 09:00:19 PM UTC, comment #1:

It's not appropriate for upstream to change this. On many systems just rebooting as quickly as possible in case of panic is the desired behaviour (think of servers).
I understand importance of collecting crash dumps but we can't change defaults in such a way.
And fo someone who would go into config file to set
GRUB_ENABLE_CRASHKERNEL=y
could as well just add static arguments to his GRUB_LINUX_CMDLINE.

Vladimir Serbinenko <phcoder>
Project Administrator
Wed 24 Jun 2009 09:49:52 AM UTC, original submission:

Hello,

in Ubuntu we are working on making it easier to capture kernel
crashes. The system we use is based around kdump and it works by
triggering a kexec of a special crashdump kernel if the regular
kernels crashes. In order for this to work the normal kernel needs a
additional commandline option "crashkernel=".

Attached is a very simple patch that adds this option automatically if
kexec and makedumpfile are available.

If its not general enough for inclusion into the default grub2, may a
mechanism to pass additional kernel commandline paramters via some
sort of defaults.d/ directory would be the right apporoach? Then I
could just ship a config file in kexec-tools that looks like this:

GRUB_LINUX_CMDLINE_EXTRA="$GRUB_LINUX_CMDLINE_EXTRA crashkernel=384M-2G:64M,2G-
:128M"

Thanks,
Michael

Michael Vogt <mvogt>

 

Attached Files
file #18313:  10_crashkernel.patch added by mvogt (919B - text/x-patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by phcoder (Posted a comment)
  • -unavailable- added by mvogt (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 04 Nov 2013 09:00:19 PM UTCphcoderStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
      ReleaseNone=>1.96
    Wed 24 Jun 2009 09:49:52 AM UTCmvogtAttached File-=>Added 10_crashkernel.patch, #18313

    Back to the top


    Powered by Savane 3.1-cleanup