bugGNUstep - Bugs: bug #24708, Slow scrolling speed

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #24708: Slow scrolling speed

Submitted by:  Stef <stefanbidi>
Submitted on:  Fri 31 Oct 2008 01:24:22 AM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  Bug Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed

Sun 02 Nov 2008 03:07:53 PM UTC, comment #3: 

OK, I tested it some more, and actually, Firefox is doing the something similar on certain pages, so this would suggest there's something going on with my X setup.

If this works correctly, I just invalidated the bug report.

Stef <stefanbidi>
Project Member
Sun 02 Nov 2008 01:37:24 PM UTC, comment #2: 

Sorry about that, I know I was going to forget important details!

I'm using the cairo backend, but I'll try with the art as soon as I boot back into that installation.

I'm also using the knob to scroll.  Clicking on the scrollbar (that is, to jump to wherever I want it to) doesn't seem to be as effected, however, there's still a lag.

Another thing that might be of interest is that I'm using the "nvidia" driver since this is on a laptop.

I also have my CPU throttling set to "ondemand", which scales the speed down to as low as 500MHz, but is generally fairly responsive on bringing it back to 2000MHz.  When I set the throttling to "conservative", making it very slow to switch between the speeds (sometimes it'll get stuck on 500MHz), the scrolling is noticably slower.

Like I mentioned before, I'll try with the art backend and report back as soon as I get a chance.

Stef <stefanbidi>
Project Member
Sat 01 Nov 2008 10:43:49 PM UTC, comment #1: 

I am not able to reproduce this issue. I tried Terminal and apart from the horrible font it started up it works quite nicely and fast.
Could you please specify, which of the different GNUstep drawing backends (xlib, art, cairo) is showing this slow behaviour for you.
Does this already happen for you, when you only have a few lines to scroll back to or do you need hundreds of lines to reproducs it?
Are you using mouse wheel scrolling, the scroll buttons, did you click on the scroll bar or drag the knob? All of these are working correctly for me.

Fred Kiefer <FredKiefer>
Project Member
Fri 31 Oct 2008 01:24:22 AM UTC, original submission:  

I'm not sure if this is really a bug, change request, or what.  Scrolling is just extremely slow for me in Slackware 12.1, and stable version of the core packages.  If I move the mouse fast enough the scroll bar just can't seem to keep up!  It takes almost half a second for the scroll bar to catch up to the new position.

I noticed this in GWorkspace and Terminal (the only two applications I'm using that I can use scroll bars extensively).

Stef <stefanbidi>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by FredKiefer (Posted a comment)
  • -email is unavailable- added by stefanbidi (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2008-11-02 stefanbidi Open/ClosedOpen => Closed
    2008-11-02 stefanbidi StatusNone => Invalid

    Back to the top


    Powered by Savane 3.5