bugGNU troff - Bugs: bug #24215, font references in MM (and ME?)...

 
 

bug #24215: font references in MM (and ME?) need to be regularized

Submitted by:  Michael H Bianchi <mbianchi>
Submitted on:  Sat 06 Sep 2008 02:50:03 PM UTC  
 
Severity: 3 - NormalItem Group: None
Status: DuplicatePrivacy: Public
Assigned to: Michael H Bianchi <mbianchi>Open/Closed: Open
Planned Release: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 06 Sep 2008 03:52:01 PM UTC, comment #1:

Looking into the complaint about the fonts and MM .FG command, I discover
that this was fixed in 2006 and is in the current CVS download, but not in
the 1.18.1 version distributed with Ubuntu 8.04.

In fact, it was fixed by Werner in delta 2.29 2006-03-28, to
groff/contrib/mm/m.tmac,v ...

So the problem is that the fix is not currently wrapped up in a
distribution yet.

Mike Bianchi

Michael H Bianchi <mbianchi>
Project MemberIn charge of this item.
Sat 06 Sep 2008 02:50:03 PM UTC, original submission:

The font references occur both by position, e.g. .ft 1 , and
by name, .ft R .

This means that in order to change from say R I B to H HI HB
fonts across the board you need to use both .fp and .fpr to catch all the cases. (By "all" I mean all that I have looked at.)

This appears to work.

There is evidence that the same problem exists in the ME macros.

Mike Bianchi

Michael H Bianchi <mbianchi>
Project MemberIn charge of this item.

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mbianchi (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 06 Sep 2008 03:53:18 PM UTCmbianchiStatusFixed=>Duplicate
    Sat 06 Sep 2008 03:53:02 PM UTCmbianchiStatusConfirmed=>Fixed

    Back to the top


    Powered by Savane 3.1-cleanup