bugGNU Octave - Bugs: bug #54604, doc command problem using cli

 
 

bug #54604: doc command problem using cli

Submitted by:  Ian McCallion <ianmcc>
Submitted on:  Fri 31 Aug 2018 02:16:34 PM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error
Status:  Fixed Assigned to:  None
Originator Name:  Ian Open/Closed:  Closed
Release:  4.4.1 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 05 Sep 2018 07:04:55 PM UTC, comment #5: 

I pushed a change to mxe to not install our own info.exe when using msys2.

http://hg.octave.org/mxe-octave/rev/21e184cc4fd7

So assuming the next release of octave for windows will eb msys2 as it was marked as the default settings, this is fixed for windows.

John Donoghue <lostbard>
Project Member
Fri 31 Aug 2018 10:06:50 PM UTC, comment #4: 

When is the switch to msys2 supposed to be complete?

Rik <rik5>
Project Administrator
Fri 31 Aug 2018 02:59:44 PM UTC, comment #3: 

And is probally due t the fact we render in info with termcap rather than ncurses.
Easties way to fix is use the msys2 info.exe we are installing anyway.

John Donoghue <lostbard>
Project Member
Fri 31 Aug 2018 02:42:04 PM UTC, comment #2: 

Actually tuning more, its a problem with info.exe that we build as mxe-octave - using the msys2 info.exe works fine

John Donoghue <lostbard>
Project Member
Fri 31 Aug 2018 02:36:25 PM UTC, comment #1: 

Looks like it is continuously redrawing the doc page. However, I do not beleive this is an octave issue itself.

If I run a terminal window and type 'info', the info contents is flashing, and isn't when legacy is on.

Perhaps, since we are moving towards using msys2, we can use mintty as the console as it doesnt seem to be doing it for me

John Donoghue <lostbard>
Project Member
Fri 31 Aug 2018 02:16:34 PM UTC, original submission:  

Using the GUI the doc command simply switches to the documentation pane, which is fine.

Using the CLI though the doc command goes a bit mad! It is clearly in a loop with the home page of the CLI version of the manual flashing rapidly on and off.

This is related to https://savannah.gnu.org/bugs/?func=detailitem&item_id=52496 because the doc command works correctly using the CLI when using the legacy console.

Ian McCallion <ianmcc>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by ianmcc (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-09-05 rik5 StatusConfirmed => Fixed
        Open/ClosedOpen => Closed
    2018-08-31 lostbard StatusNone => Confirmed

    Back to the top


    Powered by Savane 3.5