bugGNU Octave - Bugs: bug #64564, octave-8.3.0-w32: "Access...

 
 

bug #64564: octave-8.3.0-w32: "Access violation" crash at PDF print() saving

Submitter:  Benjamin Szőke <livius>
Submitted:  Thu 17 Aug 2023 08:49:47 PM UTC
   
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Wont Fix Assigned to:  None
Originator Name:  Livius Open/Closed:  * Closed
Release:  * 8.3.0 Operating System:  * Microsoft Windows
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

Thu 26 Oct 2023 11:16:06 AM UTC, comment #20: 

The Octave community will stop distributing 32-bit binaries for Windows.
People who need binaries for that platform are kindly referred to other distributors, e.g., MSYS2:
https://packages.msys2.org/package/mingw-w64-i686-octave?repo=mingw32

Closing as won't fix.

Markus Mützel <mmuetzel>
Group administrator
Fri 15 Sep 2023 03:43:59 AM UTC, comment #19: 

Thank you Dmitri, that did the trick. Apparently I didn't have the same issue as Benjamin.

Steve <mouse>
Fri 15 Sep 2023 03:29:57 AM UTC, comment #18: 

Steve -- try to change the OpenGL driver to "Software"
(there is a small utility to do that which comes with octave's installer).

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Fri 15 Sep 2023 03:22:21 AM UTC, comment #17: 

I too am not able to print to pdf. Likewise if I use the '-nosvgconvert' flag such as print(f, "sin.svg", "-dsvg", "-nosvgconvert");

I don't see errors but rather Octave becomes unresponsive and takes up over 1 CPU core.

If I use
print(f, "foo.jpg", "-djpg")
it works.

I used octave-8.3.0-w64-installer.exe to install. I've tried installing as admin and installing to locations with and without spaces in the name. I've even ran the post-install.bat but nothing seems to fix it.

Steve <mouse>
Mon 21 Aug 2023 06:19:47 PM UTC, comment #16: 

No,


octave:1> x = 0:0.1:5;
octave:2> y = sin(x);
octave:3> f = figure;
octave:4> plot(x, y)
octave:5> print(f, "sin.pdf", "-dpdf", "-nosvgconvert");
Magick: caught exception 0xC0000005 "Access violation"...



octave:1> x = 0:0.1:5;
octave:2> y = sin(x);
octave:3> f = figure;
octave:4> plot(x, y)
octave:5> print(f, "sin.svg", "-dsvg", "-nosvgconvert");
Magick: caught exception 0xC0000005 "Access violation"...


comment #15:

> Does it work if you add `-nosvgconvert` as a flag to the print command?
>

Benjamin Szőke <livius>
Mon 21 Aug 2023 05:30:33 PM UTC, comment #15: 

Does it work if you add `-nosvgconvert` as a flag to the print command?

Markus Mützel <mmuetzel>
Group administrator
Mon 21 Aug 2023 04:08:10 PM UTC, comment #14: 

works:

print(f, "sin.png", "-dpng");
print(f, "sin.jpg", "-djpg");


does not work:

print(f, "sin.pdf", "-dpdf");
print(f, "sin.svg", "-dsvg");
print(f, "sin.ps", "-dps");
print(f, "sin.eps", "-deps");


So, i think, all of Vector Formats are not working in Octave 8.3.0 Win-32bit, only Raster Formats are ok.
https://docs.octave.org/latest/Printing-and-Saving-Plots.html

Benjamin Szőke <livius>
Mon 21 Aug 2023 04:00:59 PM UTC, comment #13: 


> Bug is in the GNU Octave sure not in any graphic card driver (it is easy to say always, i know), please fix with a 100% solution in Octave 8.4.0 and do not provide any quick and dirty workarounds.


I'm not sure if this is the first time you are interacting with a volunteer project. So, some words for the usual conduct:
Orders like that aren't appreciated at all.

If you like that something is fixed, ask nicely if there is someone interested to fix it for you. And if there is no one, fix it yourself. (Or have it fixed by someone you can order to do work for you. The volunteers here aren't your workforce.)

Markus Mützel <mmuetzel>
Group administrator
Mon 21 Aug 2023 04:00:44 PM UTC, comment #12: 

No, it is not working to SVG!


octave:1> x = 0:0.1:5;
octave:2> y = sin(x);
octave:3> f = figure;
octave:4> plot(x, y)
octave:5> print(f, "sin.svg", "-dsvg");
Magick: caught exception 0xC0000005 "Access violation"...C:\Octave\octave-8.3.0-w32\mingw32\bin>Failed to parse XML contents
unexpected end of file


comment #11:

> Can you print to svg?
>
> Dmitri.
> --
>

Benjamin Szőke <livius>
Mon 21 Aug 2023 03:49:13 PM UTC, comment #11: 

Can you print to svg?

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Mon 21 Aug 2023 03:14:39 PM UTC, comment #10: 

Print() to PDF is stopped to work since octave-8.1.0-w32. Let's see what is the different between Octave 7.3.0 and 8.1.0 and please fix it.


C:\Octave\octave-8.1.0-w32\mingw32\bin>octave.bat --no-gui
GNU Octave, version 8.1.0
Copyright (C) 1993-2023 The Octave Project Developers.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type 'warranty'.

Octave was configured for "i686-w64-mingw32".

Additional information about Octave is available at https://www.octave.org.

Please contribute if you find this software useful.
For more information, visit https://www.octave.org/get-involved.html

Read https://www.octave.org/bugs.html to learn how to submit bug reports.
For information about changes from previous versions, type 'news'.

octave:1> x = 0:0.1:5;
octave:2> y = sin(x);
octave:3> f = figure;
octave:4> plot(x, y)
octave:5> print(f, "sin.pdf", "-dpdf");
Magick: caught exception 0xC0000005 "Access violation"...C:\Octave\octave-8.1.0-w32\mingw32\bin>Failed to parse XML contents
unexpected end of file
Error: /undefinedfilename in (C:\\Users\\zks2bp\\AppData\\Local\\Temp\\oct-cSiVxt)
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
Dictionary stack:
   --dict:733/1123(ro)(G)--   --dict:0/20(G)--   --dict:75/200(L)--
Current allocation mode is local
Last OS error: No such file or directory
GPL Ghostscript 9.50: Unrecoverable error, exit code 1


Benjamin Szőke <livius>
Mon 21 Aug 2023 02:46:10 PM UTC, comment #9: 

I am using "octave.bat --no-gui" without GUI (it is also not works with GUI). I tried to use 3 different PC with different GPUs (Intel IGP, Nvidia GPU) no one can print() PDF with octave-8.3.0-w32.

Bug is in the GNU Octave sure not in any graphic card driver (it is easy to say always, i know), please fix with a 100% solution in Octave 8.4.0 and do not provide any quick and dirty workarounds. In Octave 7.3.0 it was worked perfectly.

Benjamin Szőke <livius>
Mon 21 Aug 2023 01:10:05 PM UTC, comment #8: 

Just tested with the Octave distributed by MSYS2 for their MINGW32 environment. It seems to be working. (But that doesn't mean much if this is actually caused by a bug in your graphics drivers.)

Would that be an option for you?

After installation of MSYS2, open the MINGW32 shell (the grey icon) and run the following to install Octave (only needed once):

pacman -Syyu
pacman -S mingw-w64-i686-octave


To open the GUI, run the following command also from a MINGW32 shell:

octave --gui


Does that work for you?

Markus Mützel <mmuetzel>
Group administrator
Mon 21 Aug 2023 06:57:42 AM UTC, comment #7: 

Alternatively, you could check if Octave works for you in the 32-bit version that is distributed by the MSYS2 project:
https://packages.msys2.org/package/mingw-w64-i686-octave?repo=mingw32

Markus Mützel <mmuetzel>
Group administrator
Mon 21 Aug 2023 06:52:52 AM UTC, comment #6: 

Octave is a projects that is developed by volunteers. Afaict, there are currently no volunteers that are using Octave on 32-bit Windows. Unfortunately, that might lead to a situation where support for that target slowly withers away unless someone offers to step in and provide patches.

All of Octave's sources are open:
https://hg.savannah.gnu.org/hgweb/octave

Octave for Windows is built using MXE Octave which is also open source:
https://hg.octave.org/mxe-octave

If you are interested in support for Windows 32-bit, I'd be happy to review and apply patches you can provide.

Markus Mützel <mmuetzel>
Group administrator
Sat 19 Aug 2023 08:36:43 AM UTC, comment #5: 

https://docs.octave.org/latest/Hardware-vs-Software-Rendering.html

Based on this, i try to use SW openGL, it can not help. Octave is in freeze state at execution of print() with 30% CPU load forever. After more then 5 minutes i killed octave-gui.exe.

Benjamin Szőke <livius>
Fri 18 Aug 2023 08:00:18 AM UTC, comment #4: 

If you used the installer, there should be an icon in the start menu that says something like "Switch OpenGL" or similar (away from a PC currently).

Is inter-process communication really impossible between 32-bit and 64-bit processes using a pipe? I thought it was mainly linking that's not possible...

Markus Mützel <mmuetzel>
Group administrator
Fri 18 Aug 2023 07:51:43 AM UTC, comment #3: 

What is the command to check and cahnge the render options to OpenGL? It is extremly not nice what you say about drop-out win 32-bit support because there is an issue now. Pleas,e do you really thing this is a good way, instead of fix it and finalize 32-bit support with a last bugless release?

Yes, i have to use octave 32 bits in Windows frequently, because i have a 32 bits windows executable which is use it over command line piping, and if octave is not a 32 bits app, it can not see and can not get its PID from Windows 10 to use in pipe mode.


comment #2:

> Might also be an issue with your graphics driver. Does it work if you switch to "Software OpenGL"?

Benjamin Szőke <livius>
Fri 18 Aug 2023 06:11:34 AM UTC, comment #2: 

Might also be an issue with your graphics driver. Does it work if you switch to "Software OpenGL"?

Markus Mützel <mmuetzel>
Group administrator
Fri 18 Aug 2023 05:49:07 AM UTC, comment #1: 

Thank you for the report.

We were considering stopping the distribution of Windows 32-bit binaries for Octave 9. But if the current version is already broken, one option could be to pull it earlier than planned.

Do you actually need these 32-bit binaries?

Markus Mützel <mmuetzel>
Group administrator
Thu 17 Aug 2023 08:49:47 PM UTC, original submission:  

octave-8.3.0-w32 is not able to save figure to any PDF, PS or EPS format, following is the error:


octave:1> x = 0:0.1:5;
octave:2> y = sin(x);
octave:3> f = figure;
octave:4> plot(x, y);
octave:5> print(f, "sin.pdf", "-dpdf");
Magick: caught exception 0xC0000005 "Access violation"...Failed to parse XML contents
unexpected end of file
D:\Bosch\octave-8.3.0-w32\mingw32\bin>Error: /undefinedfilename in (C:\\Users\\Livius\\AppData\\Local\\Temp\\oct-DWzRe1)
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
Dictionary stack:
   --dict:733/1123(ro)(G)--   --dict:0/20(G)--   --dict:75/200(L)--
Current allocation mode is local
Last OS error: No such file or directory
GPL Ghostscript 9.50: Unrecoverable error, exit code 1


PDF print() works well in octave-8.3.0-w64, it is not working only in octave-8.3.0-w32.

Benjamin Szőke <livius>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #55056:  bug.m added by livius (84B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mouse (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by livius (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2023-10-26 mmuetzel StatusNeed Info Wont Fix
        Open/ClosedOpen Closed
    2023-08-18 mmuetzel StatusNone Need Info
    2023-08-17 livius Attached File- Added bug.m, #55056

    Back to the top

    Powered by Savane 3.13-c373.
    Corresponding source code