bugGNU Octave - Bugs: bug #64200, Command line editing not working...

 
 

bug #64200: Command line editing not working in Mac GUI

Submitter:  None
Submitted:  Tue 16 May 2023 05:30:27 PM UTC
   
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  None Assigned to:  None
Originator Name:  Ed Baranoski Originator Email:  -email is unavailable-
Open/Closed:  * Open Release:  * stable
Operating System:  * Mac OS Fixed Release:  None
Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Tue 16 May 2023 05:30:27 PM UTC, original submission:  

I re-installed Octave to version 8.2.0 using Homebrew on a Mac Laptop running Mac OS Ventura 13.3.1.  The command line editing works fine when running the CLI, but it does not work when running the GUI either with either 'octave -gui' or 'octave --line-editing --gui'.  The emacs command work fine in the Editor window but not in the Command Window.  I have 'set editing-mode emacs' in the .inputrc file.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by None (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    No changes have been made to this item

    Back to the top

    Powered by Savane 3.13-04b1.
    Corresponding source code