bugGNU Octave - Bugs: bug #63941, [octave forge] (parallel) 4.0.1...

 
 

bug #63941: [octave forge] (parallel) 4.0.1 fails to install on Octave 8.1 on M1 Mac due to missing 'verror'

Submitter:  Jan Drewes <jdrewes>
Submitted:  Sat 18 Mar 2023 03:03:23 AM UTC
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Installation Failure
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * 8.1.0 Operating System:  * Mac OS
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Mon 20 Mar 2023 07:46:20 AM UTC, comment #2: 

Closing as duplicate of bug #63922 which already has an attachment that fixes this issue.

Markus M├╝tzel <mmuetzel>
Project Member
Sat 18 Mar 2023 07:06:18 AM UTC, comment #1: 
Anonymous
Sat 18 Mar 2023 03:03:23 AM UTC, original submission:  

Install of parallel toolbox (4.0.1 from Forge) fails in Octave 8.1 on Macbook Pro M1, Ventura, installed from homebrew.

I can try to provide useful information, please let me know.


GNU Octave, version 8.1.0
Copyright (C) 1993-2023 The Octave Project Developers.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type 'warranty'.

Octave was configured for "aarch64-apple-darwin22.3.0".

Additional information about Octave is available at https://www.octave.org.

Please contribute if you find this software useful.
For more information, visit https://www.octave.org/get-involved.html

Read https://www.octave.org/bugs.html to learn how to submit bug reports.
For information about changes from previous versions, type 'news'.

>> pkg list
Package Name  | Version | Installation directory
--------------+---------+-----------------------
       image  |  2.14.0 | /Users/jan/.local/share/octave/api-v58/packages/image-2.14.0
          io  |   2.6.4 | /Users/jan/.local/share/octave/api-v58/packages/io-2.6.4
  statistics  |   1.5.4 | /Users/jan/.local/share/octave/api-v58/packages/statistics-1.5.4
      struct  |  1.0.18 | /Users/jan/.local/share/octave/api-v58/packages/struct-1.0.18
>> pkg install -forge parallel
configure: WARNING: TLS disabled since gnutls/gnutls.h not found or not compilable
configure: WARNING: No working fork(), no uname(), or no error.h found. On such platforms, notably Windows and macOS, the remote Octave server will not be built. The functions for accessing a remote Octave server are not affected by this and may still be built, as well as the functions for local parallel execution.
network_set.cc:79:3: error: no matching function for call to 'verror'
  CHECK_ERROR (key = args(1).string_value (), retval,
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
network_set.cc:86:7: error: no matching function for call to 'verror'
      CHECK_ERROR (arg = args(2).int_value (), retval,
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
reval.cc:61:3: error: no matching function for call to 'verror'
  CHECK_ERROR (cm = val.char_matrix_value (), retval,
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
pconnect.cc:173:7: error: no matching function for call to 'verror'
      CHECK_ERROR (cm = args(0).char_matrix_value (), retval,
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
pconnect.cc:230:7: error: no matching function for call to 'verror'
      CHECK_ERROR (options = args(1).scalar_map_value (), retval,
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
pconnect.cc:241:11: error: no matching function for call to 'verror'
          CHECK_ERROR (use_gnutls = tmp.bool_value (), retval,
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
pconnect.cc:251:11: error: no matching function for call to 'verror'
          CHECK_ERROR (cpfile = tmp.string_value (), retval,
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
pconnect.cc:261:11: error: no matching function for call to 'verror'
          CHECK_ERROR (user = tmp.string_value (), retval,
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./error-helpers.h:67:9: note: expanded from macro 'CHECK_ERROR'
        verror (e, __VA_ARGS__); \
        ^~~~~~
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:433:1: note: candidate function not viable: 3rd argument
      ('const std::basic_string<char>::value_type *' (aka 'const char *')) would lose const qualifier
verror (octave::execution_exception&, const char *fmt, va_list args);
^
/opt/homebrew/Cellar/octave/8.1.0/include/octave-8.1.0/octave/error.h:425:27: note: candidate function not viable: requires 2
      arguments, but 3 were provided
extern OCTINTERP_API void verror (const char *fmt, va_list args);
                          ^
2 errors generated.
make: *** [network_set.o] Error 1
make: *** Waiting for unfinished jobs....
1 error generated.
make: *** [reval.o] Error 1
5 errors generated.
make: *** [pconnect.o] Error 1
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c pconnect.cc
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c select_sockets.cc
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c network_get_info.cc
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c network_set.cc
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c sclose.cc
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c reval.cc
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c precv.cc
CXX="clang++ -std=gnu++14" CXXFLAGS="-g -O2  -Wno-deprecated-declarations" /opt/homebrew/Cellar/octave/8.1.0/bin/mkoctfile-8.1.0 -c psend.cc

error: pkg: error running 'make' for the parallel package
error: called from
    configure_make at line 117 column 9
    install at line 202 column 7
    pkg at line 619 column 9
>>


Jan Drewes <jdrewes>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by jdrewes (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2023-03-20 mmuetzel StatusNone Duplicate
        Open/ClosedOpen Closed
        Summaryparallel 4.0.1 fails to install on Octave 8.1 on M1 Mac due to missing 'verror' [octave forge] (parallel) 4.0.1 fails to install on Octave 8.1 on M1 Mac due to missing 'verror'
        Dependencies- Depends on bugs #63922

    Back to the top

    Powered by Savane 3.11