bugGNU Octave - Bugs: bug #63926, line object buttondownfcn callback...

 
 

bug #63926: line object buttondownfcn callback does not work

Submitter:  jirim <jmac>
Submitted:  Tue 14 Mar 2023 04:52:18 PM UTC
   
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Invalid / Not an Octave Bug Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * 8.1.0 Operating System:  * Microsoft Windows
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

Thu 23 Mar 2023 03:27:35 PM UTC, comment #7: 

This seems to be an upstream issue with OpenGL on certain platforms, rather than an Octave bug.  Closing report.

Rik <rik5>
Group administrator
Wed 15 Mar 2023 09:19:03 PM UTC, comment #6: 

there may be some compatibility issues with the software OpenGL implementation and your GUI library.

As for the drawnow function, it seems that it did not have any impact on the issue. "drawnow" is a function in MATLAB that forces the graphics system to update the figure window. However, since the issue is related to the OpenGL implementation, it is unlikely that "drawnow" would have any effect on the problem.

If you are still experiencing issues with your graphics, you may want to consider using a different GPU driver or graphics library, or upgrading to Windows 11 if possible.

PRIYANSHU SHUKLA <priyanshu>
Wed 15 Mar 2023 02:49:29 PM UTC, comment #5: 

It's getting clear that the problem is related to OpenGL implementation. Here's my summary:

W10/Intel driver/System OpenGL => Not OK
W10/Intel driver/Software OpenGL => OK, but new line issue in GUI
W10/MS basic driver/System OpenGL => OK
W11/Intel driver/System OpenGL => OK (on same HW as above)

My conclusion is that W10 + the official GPU intel driver has a bug in OpenGL implementation. Interestingly, same HW on W11 + the intel driver works without any problem...

I tried drawnow, but no impact.

jirim <jmac>
Wed 15 Mar 2023 12:53:37 PM UTC, comment #4: 

The yaxis could be calling redraw. @OP: try drawnow instead of yaxis

Anonymous
Wed 15 Mar 2023 12:22:20 PM UTC, comment #3: 


>> on Win11 installation works fine with the system OpenGL.


Is that with the same computer and same graphics card? If not then I'd bet it is still the OpenGL implementation that is to blame, not the Windows version.

>> Meanwhile, I found out that forcing Y-axis limits to data limits fixes the issue with the system OpenGL selected.


I have no clue why this would be happening...

Pantxo Diribarne <pantxo>
Group Member
Wed 15 Mar 2023 08:27:44 AM UTC, comment #2: 

Thanks for a hint! Re-tested on Linux and it works ok.

My Win10 installation is with the system OpenGL. I re-installed with the software OpenGL and it seems to be working ok then. Just for curiosity, on Win11 installation works fine with the system OpenGL.

The software OpenGL is causing a problem reported in https://savannah.gnu.org/bugs/?50692.

Meanwhile, I found out that forcing Y-axis limits to data limits fixes the issue with the system OpenGL selected.


lh=plot([0 1],[0.1 2.1])
set(lh,'buttondownfcn','disp("line clicked")')
ylim([0.1 2.1])


jirim <jmac>
Wed 15 Mar 2023 07:17:50 AM UTC, comment #1: 

Works for me on linux. Did you choose to use your system provided OpenGL implementation or software MESA?

Pantxo Diribarne <pantxo>
Group Member
Tue 14 Mar 2023 04:52:18 PM UTC, original submission:  

Below is a simple test case to demonstrate the issue. It works ok in 7.3.0, but not anymore in 8.1.0:


lh=plot([0 1],[0.1 2.1])
set(lh,'buttondownfcn','disp("line clicked")')


jirim <jmac>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by priyanshu (Posted a comment)
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by jmac (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2023-03-23 rik5 StatusNeed Info Invalid / Not an Octave Bug
        Open/ClosedOpen Closed
    2023-03-15 pantxo CategoryPlotting Plotting with OpenGL
        Item GroupNone Regression
        StatusNone Need Info

    Back to the top

    Powered by Savane 3.13-758e.
    Corresponding source code