bugGNU Octave - Bugs: bug #62875, Plot window freezes on zoom

 
 

bug #62875: Plot window freezes on zoom

Submitter:  Chris Dugaw <wagudc>
Submitted:  Sun 07 Aug 2022 10:24:50 PM UTC
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Invalid Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * 7.2.0 Operating System:  * GNU/Linux
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Wed 17 Aug 2022 09:36:09 PM UTC, comment #3: 

This is a hardware-specific issue, rather than an Octave bug.  Closing report.

Rik <rik5>
Project Administrator
Mon 08 Aug 2022 04:03:17 AM UTC, comment #2: 

Invoking octave with LIBGL_ALWAYS_SOFTWARE=1 solves the issue.

In my case I use:

LIBGL_ALWAYS_SOFTWARE=1 flatpak run org.octave.Octave --gui

Chris Dugaw <wagudc>
Mon 08 Aug 2022 01:20:11 AM UTC, comment #1: 

Try to start octave as:


LIBGL_ALWAYS_SOFTWARE=1 octave

That should disable hardware acceleration.

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sun 07 Aug 2022 10:24:50 PM UTC, original submission:  

--------------------------------------------------------------Issue/Bug Description:
After creating a plot with a large quantity of data, interacting with the plot window results in either the entire GUI of the system being rendered unusable (mouse pointer can be moved but can't interact with any applications via mouse or keyboard), or a 'force quit' dialog being displaced and Octave crashing, or both (a force quit dialog is displayed but can't be interacted with)

Other users are seeing this behavior as well - https://www.reddit.com/r/pop_os/comments/wh36qi/pop_os_freezes_with_octave/

--------------------------------------------------------------
Steps to reproduce:

Launch Octave 7.2.0 on my computer (details to follow)
Run attached code: 'diagram.m'
Run script
In the plot window that opens, attempt to use the zoom in/zoom out/fit zoom/add text buttons

Notes: error does not occur if you use: graphics_toolkit("gnuplot")

I believe the issue is connected to the AMD processor/GPU on my computer. I installed the same OS inside a Gnome Boxes VM on the 
same computer and the error did not occur. The VM does not allow hardware video acceleration.

--------------------------------------------------------------
Linux Distribution (run cat /etc/os-release):

NAME="Pop!_OS"
VERSION="22.04 LTS"
ID=pop
ID_LIKE="ubuntu debian"
PRETTY_NAME="Pop!_OS 22.04 LTS"
VERSION_ID="22.04"
HOME_URL="https://pop.system76.com"
SUPPORT_URL="https://support.system76.com"
BUG_REPORT_URL="https://github.com/pop-os/pop/issues"
PRIVACY_POLICY_URL="https://system76.com/privacy"
VERSION_CODENAME=jammy
UBUNTU_CODENAME=jammy
LOGO=distributor-logo-pop-os

Kernel (uname -r):
5.18.10-76051810-generic

--------------------------------------------------------------
Hardware:

HP Dev One Laptop
Processor: AMD® Ryzen 7 pro 5850u with radeon graphics × 16
Graphics: AMD® Renoir
Ram: 16.0 GB

Chris Dugaw <wagudc>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #53543:  diagram.m added by wagudc (1KiB - text/x-objcsrc)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by wagudc (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2022-08-17 rik5 StatusNone Invalid
        Open/ClosedOpen Closed
    2022-08-07 wagudc Attached File- Added diagram.m, #53543

    Back to the top


    Powered by Savane 3.9