bugGNU Octave - Bugs: bug #62660, Cannot see a plot on qt graphics...

 
 

bug #62660: Cannot see a plot on qt graphics on 7.1.0 windows

Submitter:  None
Submitted:  Wed 22 Jun 2022 07:49:03 AM UTC
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  None Assigned to:  None
Originator Name:  Tatsuro MATSUOKA Originator Email:  -email is unavailable-
Open/Closed:  * Open Release:  * 7.1.0
Operating System:  * Microsoft Windows
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

( Jump to the original submission )

Thu 30 Jun 2022 08:47:12 AM UTC, comment #14: 

I forgot to mention.
For fltk graphics_toolkit, it works as expected.
And _opengl_info_ shows information.

octave:1> graphics_toolkit fltk
octave:2> __opengl_info__
   version: 3.1 Mesa 21.2.6
    vendor: Mesa/X.org
  renderer: llvmpipe (LLVM 12.0.1, 128 bits)
extensions:
  GL_ARB_multisample
  GL_EXT_abgr
  GL_EXT_bgra
  GL_EXT_blend_color
  GL_EXT_blend_minmax
  GL_EXT_blend_subtract
  GL_EXT_copy_texture
  GL_EXT_subtexture
  GL_EXT_texture_object
  GL_EXT_vertex_array
  GL_EXT_compiled_vertex_array
  GL_EXT_texture
  GL_EXT_texture3D
  GL_IBM_rasterpos_clip
  GL_ARB_point_parameters
  GL_EXT_draw_range_elements
  GL_EXT_packed_pixels
  GL_EXT_point_parameters
  GL_EXT_rescale_normal
  GL_EXT_separate_specular_color
  GL_EXT_texture_edge_clamp
  GL_SGIS_generate_mipmap
  GL_SGIS_texture_border_clamp
  GL_SGIS_texture_edge_clamp
  GL_SGIS_texture_lod
  GL_ARB_framebuffer_sRGB
  GL_ARB_multitexture
  GL_EXT_framebuffer_sRGB
  GL_IBM_multimode_draw_arrays
  GL_IBM_texture_mirrored_repeat
  GL_3DFX_texture_compression_FXT1
  GL_ARB_texture_cube_map
  GL_ARB_texture_env_add
  GL_ARB_transpose_matrix
  GL_EXT_blend_func_separate
  GL_EXT_fog_coord
  GL_EXT_multi_draw_arrays
  GL_EXT_secondary_color
  GL_EXT_texture_env_add
  GL_EXT_texture_lod_bias
  GL_INGR_blend_func_separate
  GL_NV_blend_square
  GL_NV_light_max_exponent
  GL_NV_texgen_reflection
  GL_NV_texture_env_combine4
  GL_S3_s3tc
  GL_SUN_multi_draw_arrays
  GL_ARB_texture_border_clamp
  GL_ARB_texture_compression
  GL_EXT_framebuffer_object
  GL_EXT_texture_compression_s3tc
  GL_EXT_texture_env_combine
  GL_EXT_texture_env_dot3
  GL_MESA_window_pos
  GL_NV_packed_depth_stencil
  GL_NV_texture_rectangle
  GL_ARB_depth_texture
  GL_ARB_occlusion_query
  GL_ARB_shadow
  GL_ARB_texture_env_combine
  GL_ARB_texture_env_crossbar
  GL_ARB_texture_env_dot3
  GL_ARB_texture_mirrored_repeat
  GL_ARB_window_pos
  GL_ATI_fragment_shader
  GL_EXT_stencil_two_side
  GL_EXT_texture_cube_map
  GL_NV_copy_depth_to_color
  GL_NV_depth_clamp
  GL_NV_fog_distance
  GL_NV_half_float
  GL_APPLE_packed_pixels
  GL_ARB_draw_buffers
  GL_ARB_fragment_program
  GL_ARB_fragment_shader
  GL_ARB_shader_objects
  GL_ARB_vertex_program
  GL_ARB_vertex_shader
  GL_ATI_draw_buffers
  GL_ATI_texture_env_combine3
  GL_ATI_texture_float
  GL_EXT_shadow_funcs
  GL_EXT_stencil_wrap
  GL_MESA_pack_invert
  GL_MESA_ycbcr_texture
  GL_NV_primitive_restart
  GL_ARB_depth_clamp
  GL_ARB_fragment_program_shadow
  GL_ARB_half_float_pixel
  GL_ARB_occlusion_query2
  GL_ARB_point_sprite
  GL_ARB_shading_language_100
  GL_ARB_sync
  GL_ARB_texture_non_power_of_two
  GL_ARB_vertex_buffer_object
  GL_ATI_blend_equation_separate
  GL_EXT_blend_equation_separate
  GL_OES_read_format
  GL_ARB_color_buffer_float
  GL_ARB_pixel_buffer_object
  GL_ARB_texture_compression_rgtc
  GL_ARB_texture_float
  GL_ARB_texture_rectangle
  GL_ATI_texture_compression_3dc
  GL_EXT_packed_float
  GL_EXT_pixel_buffer_object
  GL_EXT_texture_compression_dxt1
  GL_EXT_texture_compression_rgtc
  GL_EXT_texture_mirror_clamp
  GL_EXT_texture_rectangle
  GL_EXT_texture_sRGB
  GL_EXT_texture_shared_exponent
  GL_ARB_framebuffer_object
  GL_EXT_framebuffer_blit
  GL_EXT_framebuffer_multisample
  GL_EXT_packed_depth_stencil
  GL_ARB_vertex_array_object
  GL_ATI_separate_stencil
  GL_ATI_texture_mirror_once
  GL_EXT_draw_buffers2
  GL_EXT_draw_instanced
  GL_EXT_gpu_program_parameters
  GL_EXT_gpu_shader4
  GL_EXT_texture_array
  GL_EXT_texture_compression_latc
  GL_EXT_texture_integer
  GL_EXT_texture_sRGB_decode
  GL_EXT_timer_query
  GL_OES_EGL_image
  GL_EXT_texture_buffer_object
  GL_AMD_texture_texture4
  GL_ARB_copy_buffer
  GL_ARB_depth_buffer_float
  GL_ARB_draw_instanced
  GL_ARB_half_float_vertex
  GL_ARB_instanced_arrays
  GL_ARB_map_buffer_range
  GL_ARB_texture_buffer_object
  GL_ARB_texture_rg
  GL_ARB_texture_swizzle
  GL_ARB_vertex_array_bgra
  GL_EXT_texture_swizzle
  GL_EXT_vertex_array_bgra
  GL_NV_conditional_render
  GL_AMD_conservative_depth
  GL_AMD_draw_buffers_blend
  GL_AMD_seamless_cubemap_per_texture
  GL_AMD_shader_stencil_export
  GL_ARB_ES2_compatibility
  GL_ARB_blend_func_extended
  GL_ARB_compatibility
  GL_ARB_debug_output
  GL_ARB_draw_buffers_blend
  GL_ARB_draw_elements_base_vertex
  GL_ARB_explicit_attrib_location
  GL_ARB_fragment_coord_conventions
  GL_ARB_provoking_vertex
  GL_ARB_sample_shading
  GL_ARB_sampler_objects
  GL_ARB_seamless_cube_map
  GL_ARB_shader_stencil_export
  GL_ARB_shader_texture_lod
  GL_ARB_texture_buffer_object_rgb32
  GL_ARB_texture_cube_map_array
  GL_ARB_texture_gather
  GL_ARB_texture_multisample
  GL_ARB_texture_query_lod
  GL_ARB_texture_rgb10_a2ui
  GL_ARB_uniform_buffer_object
  GL_ARB_vertex_type_2_10_10_10_rev
  GL_EXT_provoking_vertex
  GL_EXT_texture_snorm
  GL_MESA_texture_signed_rgba
  GL_NV_copy_image
  GL_NV_texture_barrier
  GL_ARB_draw_indirect
  GL_ARB_get_program_binary
  GL_ARB_robustness
  GL_ARB_separate_shader_objects
  GL_ARB_shader_bit_encoding
  GL_ARB_shader_subroutine
  GL_ARB_texture_compression_bptc
  GL_ARB_timer_query
  GL_ARB_transform_feedback2
  GL_ARB_transform_feedback3
  GL_ARB_viewport_array
  GL_EXT_direct_state_access
  GL_AMD_multi_draw_indirect
  GL_ANGLE_texture_compression_dxt3
  GL_ANGLE_texture_compression_dxt5
  GL_ARB_base_instance
  GL_ARB_compressed_texture_pixel_storage
  GL_ARB_conservative_depth
  GL_ARB_internalformat_query
  GL_ARB_map_buffer_alignment
  GL_ARB_shader_atomic_counters
  GL_ARB_shader_image_load_store
  GL_ARB_shading_language_420pack
  GL_ARB_shading_language_packing
  GL_ARB_texture_storage
  GL_ARB_transform_feedback_instanced
  GL_EXT_framebuffer_multisample_blit_scaled
  GL_EXT_transform_feedback
  GL_AMD_query_buffer_object
  GL_AMD_shader_trinary_minmax
  GL_ARB_ES3_compatibility
  GL_ARB_arrays_of_arrays
  GL_ARB_clear_buffer_object
  GL_ARB_compute_shader
  GL_ARB_copy_image
  GL_ARB_explicit_uniform_location
  GL_ARB_fragment_layer_viewport
  GL_ARB_framebuffer_no_attachments
  GL_ARB_invalidate_subdata
  GL_ARB_multi_draw_indirect
  GL_ARB_program_interface_query
  GL_ARB_robust_buffer_access_behavior
  GL_ARB_shader_image_size
  GL_ARB_shader_storage_buffer_object
  GL_ARB_stencil_texturing
  GL_ARB_texture_buffer_range
  GL_ARB_texture_query_levels
  GL_ARB_texture_storage_multisample
  GL_ARB_texture_view
  GL_ARB_vertex_attrib_binding
  GL_KHR_debug
  GL_KHR_robustness
  GL_KHR_texture_compression_astc_ldr
  GL_ARB_buffer_storage
  GL_ARB_clear_texture
  GL_ARB_enhanced_layouts
  GL_ARB_indirect_parameters
  GL_ARB_internalformat_query2
  GL_ARB_multi_bind
  GL_ARB_query_buffer_object
  GL_ARB_seamless_cubemap_per_texture
  GL_ARB_shader_draw_parameters
  GL_ARB_shader_group_vote
  GL_ARB_shading_language_include
  GL_ARB_texture_mirror_clamp_to_edge
  GL_ARB_texture_stencil8
  GL_ARB_vertex_type_10f_11f_11f_rev
  GL_EXT_shader_integer_mix
  GL_ARB_clip_control
  GL_ARB_conditional_render_inverted
  GL_ARB_cull_distance
  GL_ARB_derivative_control
  GL_ARB_direct_state_access
  GL_ARB_get_texture_sub_image
  GL_ARB_pipeline_statistics_query
  GL_ARB_shader_texture_image_samples
  GL_ARB_texture_barrier
  GL_ARB_transform_feedback_overflow_query
  GL_EXT_polygon_offset_clamp
  GL_KHR_blend_equation_advanced
  GL_KHR_context_flush_control
  GL_KHR_robust_buffer_access_behavior
  GL_ARB_parallel_shader_compile
  GL_ARB_post_depth_coverage
  GL_ARB_shader_atomic_counter_ops
  GL_ARB_texture_filter_minmax
  GL_EXT_texture_filter_minmax
  GL_EXT_texture_sRGB_R8
  GL_KHR_no_error
  GL_KHR_texture_compression_astc_sliced_3d
  GL_ARB_gl_spirv
  GL_ARB_spirv_extensions
  GL_MESA_shader_integer_functions
  GL_ARB_polygon_offset_clamp
  GL_KHR_parallel_shader_compile
  GL_EXT_EGL_image_storage
  GL_EXT_shader_framebuffer_fetch_non_coherent
  GL_EXT_texture_shadow_lod
  GL_EXT_EGL_sync

Tatsuro MATSUOKA <tmacchant>
Thu 23 Jun 2022 09:56:11 PM UTC, comment #13: 

Markus

I downloaded octave-2022-06-22-00-11-default-w64.7z and installed it. (HG-ID 0cb39c399ed8)
The behaviors are the same as those in 7.1.0.

Tatsuro MATSUOKA <tmacchant>
Thu 23 Jun 2022 11:59:09 AM UTC, comment #12: 

One can try some other options:

https://docs.mesa3d.org/envvars.html

(e.g. MESA_NO_SSE)

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 23 Jun 2022 11:49:08 AM UTC, comment #11: 

I have a laptop with even older CPU (Intel Core2 Duo T9900)
and it works fine (Windows 7). It uses an AMD graphics.
I suspect the issue is with (low-level) intel  graphics driver.
Tatsuro, could you revert to the original opengl (MESA llvmpipe)
driver and do:

octave:1> setenv("MESA_DEBUG", "1")
octave:2> plot(1:10)

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 23 Jun 2022 07:59:33 AM UTC, comment #10: 

The main point of bundling mesa3D's llvmpipe with the Windows installer was to have a software OpenGL renderer that would hopefully work independent of the used hardware.

Just some points that we might want to check:
Maybe newer versions of llvmpipe use processor instructions that aren't implemented in your CPU?
Or maybe this is an incompatibility that was already resolved upstream in newer versions?
IIRC, jwe changed to more modern hardware that he uses to build the Windows installers around the time that Octave 7 was released. Maybe mesa3D's build system tests the available instructions on the build system and uses them if it thinks that they are available?

Did you have a chance to try with the nightly builds from the default branch of MXE Octave (see comment #7)? Those are built on different hardware, too.

Markus Mützel <mmuetzel>
Project Member
Thu 23 Jun 2022 05:05:45 AM UTC, comment #9: 

I have tried qt graphics_toolkit on another PC.

>> plot(1:10);

plot appeared as expected.

So errors depend on hardware environments.

On the PC

>> __opengl_info__
   version: 3.1 Mesa 21.2.6
    vendor: Mesa/X.org
  renderer: llvmpipe (LLVM 12.0.1, 256 bits)
extensions:
  GL_ARB_multisample
  GL_EXT_abgr
  GL_EXT_bgra
  GL_EXT_blend_color
  GL_EXT_blend_minmax
  GL_EXT_blend_subtract
  GL_EXT_copy_texture
  GL_EXT_subtexture
  GL_EXT_texture_object
  GL_EXT_vertex_array
  GL_EXT_compiled_vertex_array
  GL_EXT_texture
  GL_EXT_texture3D
  GL_IBM_rasterpos_clip
  GL_ARB_point_parameters
  GL_EXT_draw_range_elements
  GL_EXT_packed_pixels
  GL_EXT_point_parameters
  GL_EXT_rescale_normal
  GL_EXT_separate_specular_color
  GL_EXT_texture_edge_clamp
  GL_SGIS_generate_mipmap
  GL_SGIS_texture_border_clamp
  GL_SGIS_texture_edge_clamp
  GL_SGIS_texture_lod
  GL_ARB_framebuffer_sRGB
  GL_ARB_multitexture
  GL_EXT_framebuffer_sRGB
  GL_IBM_multimode_draw_arrays
  GL_IBM_texture_mirrored_repeat
  GL_3DFX_texture_compression_FXT1
  GL_ARB_texture_cube_map
  GL_ARB_texture_env_add
  GL_ARB_transpose_matrix
  GL_EXT_blend_func_separate
  GL_EXT_fog_coord
  GL_EXT_multi_draw_arrays
  GL_EXT_secondary_color
  GL_EXT_texture_env_add
  GL_EXT_texture_lod_bias
  GL_INGR_blend_func_separate
  GL_NV_blend_square
  GL_NV_light_max_exponent
  GL_NV_texgen_reflection
  GL_NV_texture_env_combine4
  GL_S3_s3tc
  GL_SUN_multi_draw_arrays
  GL_ARB_texture_border_clamp
  GL_ARB_texture_compression
  GL_EXT_framebuffer_object
  GL_EXT_texture_compression_s3tc
  GL_EXT_texture_env_combine
  GL_EXT_texture_env_dot3
  GL_MESA_window_pos
  GL_NV_packed_depth_stencil
  GL_NV_texture_rectangle
  GL_ARB_depth_texture
  GL_ARB_occlusion_query
  GL_ARB_shadow
  GL_ARB_texture_env_combine
  GL_ARB_texture_env_crossbar
  GL_ARB_texture_env_dot3
  GL_ARB_texture_mirrored_repeat
  GL_ARB_window_pos
  GL_ATI_fragment_shader
  GL_EXT_stencil_two_side
  GL_EXT_texture_cube_map
  GL_NV_copy_depth_to_color
  GL_NV_depth_clamp
  GL_NV_fog_distance
  GL_NV_half_float
  GL_APPLE_packed_pixels
  GL_ARB_draw_buffers
  GL_ARB_fragment_program
  GL_ARB_fragment_shader
  GL_ARB_shader_objects
  GL_ARB_vertex_program
  GL_ARB_vertex_shader
  GL_ATI_draw_buffers
  GL_ATI_texture_env_combine3
  GL_ATI_texture_float
  GL_EXT_shadow_funcs
  GL_EXT_stencil_wrap
  GL_MESA_pack_invert
  GL_MESA_ycbcr_texture
  GL_NV_primitive_restart
  GL_ARB_depth_clamp
  GL_ARB_fragment_program_shadow
  GL_ARB_half_float_pixel
  GL_ARB_occlusion_query2
  GL_ARB_point_sprite
  GL_ARB_shading_language_100
  GL_ARB_sync
  GL_ARB_texture_non_power_of_two
  GL_ARB_vertex_buffer_object
  GL_ATI_blend_equation_separate
  GL_EXT_blend_equation_separate
  GL_OES_read_format
  GL_ARB_color_buffer_float
  GL_ARB_pixel_buffer_object
  GL_ARB_texture_compression_rgtc
  GL_ARB_texture_float
  GL_ARB_texture_rectangle
  GL_ATI_texture_compression_3dc
  GL_EXT_packed_float
  GL_EXT_pixel_buffer_object
  GL_EXT_texture_compression_dxt1
  GL_EXT_texture_compression_rgtc
  GL_EXT_texture_mirror_clamp
  GL_EXT_texture_rectangle
  GL_EXT_texture_sRGB
  GL_EXT_texture_shared_exponent
  GL_ARB_framebuffer_object
  GL_EXT_framebuffer_blit
  GL_EXT_framebuffer_multisample
  GL_EXT_packed_depth_stencil
  GL_ARB_vertex_array_object
  GL_ATI_separate_stencil
  GL_ATI_texture_mirror_once
  GL_EXT_draw_buffers2
  GL_EXT_draw_instanced
  GL_EXT_gpu_program_parameters
  GL_EXT_gpu_shader4
  GL_EXT_texture_array
  GL_EXT_texture_compression_latc
  GL_EXT_texture_integer
  GL_EXT_texture_sRGB_decode
  GL_EXT_timer_query
  GL_OES_EGL_image
  GL_EXT_texture_buffer_object
  GL_AMD_texture_texture4
  GL_ARB_copy_buffer
  GL_ARB_depth_buffer_float
  GL_ARB_draw_instanced
  GL_ARB_half_float_vertex
  GL_ARB_instanced_arrays
  GL_ARB_map_buffer_range
  GL_ARB_texture_buffer_object
  GL_ARB_texture_rg
  GL_ARB_texture_swizzle
  GL_ARB_vertex_array_bgra
  GL_EXT_texture_swizzle
  GL_EXT_vertex_array_bgra
  GL_NV_conditional_render
  GL_AMD_conservative_depth
  GL_AMD_draw_buffers_blend
  GL_AMD_seamless_cubemap_per_texture
  GL_AMD_shader_stencil_export
  GL_ARB_ES2_compatibility
  GL_ARB_blend_func_extended
  GL_ARB_compatibility
  GL_ARB_debug_output
  GL_ARB_draw_buffers_blend
  GL_ARB_draw_elements_base_vertex
  GL_ARB_explicit_attrib_location
  GL_ARB_fragment_coord_conventions
  GL_ARB_provoking_vertex
  GL_ARB_sample_shading
  GL_ARB_sampler_objects
  GL_ARB_seamless_cube_map
  GL_ARB_shader_stencil_export
  GL_ARB_shader_texture_lod
  GL_ARB_texture_buffer_object_rgb32
  GL_ARB_texture_cube_map_array
  GL_ARB_texture_gather
  GL_ARB_texture_multisample
  GL_ARB_texture_query_lod
  GL_ARB_texture_rgb10_a2ui
  GL_ARB_uniform_buffer_object
  GL_ARB_vertex_type_2_10_10_10_rev
  GL_EXT_provoking_vertex
  GL_EXT_texture_snorm
  GL_MESA_texture_signed_rgba
  GL_NV_copy_image
  GL_NV_texture_barrier
  GL_ARB_draw_indirect
  GL_ARB_get_program_binary
  GL_ARB_robustness
  GL_ARB_separate_shader_objects
  GL_ARB_shader_bit_encoding
  GL_ARB_shader_subroutine
  GL_ARB_texture_compression_bptc
  GL_ARB_timer_query
  GL_ARB_transform_feedback2
  GL_ARB_transform_feedback3
  GL_ARB_viewport_array
  GL_EXT_direct_state_access
  GL_AMD_multi_draw_indirect
  GL_ANGLE_texture_compression_dxt3
  GL_ANGLE_texture_compression_dxt5
  GL_ARB_base_instance
  GL_ARB_compressed_texture_pixel_storage
  GL_ARB_conservative_depth
  GL_ARB_internalformat_query
  GL_ARB_map_buffer_alignment
  GL_ARB_shader_atomic_counters
  GL_ARB_shader_image_load_store
  GL_ARB_shading_language_420pack
  GL_ARB_shading_language_packing
  GL_ARB_texture_storage
  GL_ARB_transform_feedback_instanced
  GL_EXT_framebuffer_multisample_blit_scaled
  GL_EXT_transform_feedback
  GL_AMD_query_buffer_object
  GL_AMD_shader_trinary_minmax
  GL_ARB_ES3_compatibility
  GL_ARB_arrays_of_arrays
  GL_ARB_clear_buffer_object
  GL_ARB_compute_shader
  GL_ARB_copy_image
  GL_ARB_explicit_uniform_location
  GL_ARB_fragment_layer_viewport
  GL_ARB_framebuffer_no_attachments
  GL_ARB_invalidate_subdata
  GL_ARB_multi_draw_indirect
  GL_ARB_program_interface_query
  GL_ARB_robust_buffer_access_behavior
  GL_ARB_shader_image_size
  GL_ARB_shader_storage_buffer_object
  GL_ARB_stencil_texturing
  GL_ARB_texture_buffer_range
  GL_ARB_texture_query_levels
  GL_ARB_texture_storage_multisample
  GL_ARB_texture_view
  GL_ARB_vertex_attrib_binding
  GL_KHR_debug
  GL_KHR_robustness
  GL_KHR_texture_compression_astc_ldr
  GL_ARB_buffer_storage
  GL_ARB_clear_texture
  GL_ARB_enhanced_layouts
  GL_ARB_indirect_parameters
  GL_ARB_internalformat_query2
  GL_ARB_multi_bind
  GL_ARB_query_buffer_object
  GL_ARB_seamless_cubemap_per_texture
  GL_ARB_shader_draw_parameters
  GL_ARB_shader_group_vote
  GL_ARB_shading_language_include
  GL_ARB_texture_mirror_clamp_to_edge
  GL_ARB_texture_stencil8
  GL_ARB_vertex_type_10f_11f_11f_rev
  GL_EXT_shader_integer_mix
  GL_ARB_clip_control
  GL_ARB_conditional_render_inverted
  GL_ARB_cull_distance
  GL_ARB_derivative_control
  GL_ARB_direct_state_access
  GL_ARB_get_texture_sub_image
  GL_ARB_pipeline_statistics_query
  GL_ARB_shader_texture_image_samples
  GL_ARB_texture_barrier
  GL_ARB_transform_feedback_overflow_query
  GL_EXT_polygon_offset_clamp
  GL_KHR_blend_equation_advanced
  GL_KHR_context_flush_control
  GL_KHR_robust_buffer_access_behavior
  GL_ARB_parallel_shader_compile
  GL_ARB_post_depth_coverage
  GL_ARB_shader_atomic_counter_ops
  GL_ARB_texture_filter_minmax
  GL_EXT_texture_filter_minmax
  GL_EXT_texture_sRGB_R8
  GL_KHR_no_error
  GL_KHR_texture_compression_astc_sliced_3d
  GL_ARB_gl_spirv
  GL_ARB_spirv_extensions
  GL_MESA_shader_integer_functions
  GL_ARB_polygon_offset_clamp
  GL_KHR_parallel_shader_compile
  GL_EXT_EGL_image_storage
  GL_EXT_shader_framebuffer_fetch_non_coherent
  GL_EXT_texture_shadow_lod
  GL_EXT_EGL_sync

Tatsuro MATSUOKA <tmacchant>
Wed 22 Jun 2022 11:37:23 PM UTC, comment #8: 

Markus> As a test, could you try and rename the `opengl32.dll` installed with Octave? .....

I renamed opengl32.dll in mingw64/bin to other name.

octave:1> __opengl_info__
   version: 2.1.0 - Build 8.15.10.2900
    vendor: Intel
  renderer: Intel(R) HD Graphics
extensions:
  GL_EXT_blend_minmax
...

However, behavior of qt graphics_toolkit is the same as before.

Tatsuro MATSUOKA <tmacchant>
Wed 22 Jun 2022 03:45:26 PM UTC, comment #7: 

The nightly builds from the default branch of MXE Octave bundle a newer version of Mesa3D than the one in the "official" installer.

You can download nightly builds from Kai's buildbot server here:
https://buildbot.octave.space/#/download

Make sure to chose one that has "-default-" in its name.

Does that version behave differently?

Markus Mützel <mmuetzel>
Project Member
Wed 22 Jun 2022 11:46:55 AM UTC, comment #6: 

> Is this still an issue with the release candidate for Octave 7.2?
> You can download Windows installers for the release candidate from here:
> https://alpha.gnu.org/gnu/octave/?C=M;O=D


I downloaded octave-7.1.90-w64.7z and installed it.

graphics_toolkit qt;
plot(1:10);

The results are the same as those on 7.1.0.

And _opengl_info_ result :

>> __opengl_info__
warning: __opengl_info__: can not obtain OpenGL information
warning: called from
    __opengl_info__ at line 65 column 5

Tatsuro MATSUOKA <tmacchant>
Wed 22 Jun 2022 11:03:41 AM UTC, comment #5: 

As a test, could you try and rename the `opengl32.dll` installed with Octave? By default, that library is installed at `C:\Program Files\GNU Octave\Octave-7.1.0\mingw64\bin\opengl32.dll`. After renaming it to something different, Octave should be trying to load the OpenGL drivers installed on your system.

Does that make a difference? What does `__opengl_info__` return after you renamed that file?

Markus Mützel <mmuetzel>
Project Member
Wed 22 Jun 2022 10:17:48 AM UTC, comment #4: 

> Which Windows is this?


Windows 10 Home 21H2

My PC at home is very old.
 CPU: Intel(R) Core(TM) i5 CPU       M 430  @ 2.27GHz
 GPU: Intel(R) HD Graphics

Tatsuro MATSUOKA <tmacchant>
Wed 22 Jun 2022 10:10:32 AM UTC, comment #3: 

Which Windows is this?

Dmitri A. Sergatskov <dasergatskov>
Wed 22 Jun 2022 09:59:11 AM UTC, comment #2: 

For 7.1.0

>> __opengl_info__
warning: __opengl_info__: can not obtain OpenGL information
warning: called from
    __opengl_info__ at line 65 column 5

For 6.4.0

>> __opengl_info__
   version: 3.1 Mesa 20.1.10
    vendor: VMware, Inc.
  renderer: llvmpipe (LLVM 7.1.0, 128 bits)
extensions:
  GL_ARB_multisample
  GL_EXT_abgr
  GL_EXT_bgra
  GL_EXT_blend_color
  GL_EXT_blend_minmax
  GL_EXT_blend_subtract
  GL_EXT_copy_texture
  GL_EXT_subtexture
  GL_EXT_texture_object
  GL_EXT_vertex_array
  GL_EXT_compiled_vertex_array
  GL_EXT_texture
  GL_EXT_texture3D
  GL_IBM_rasterpos_clip
  GL_ARB_point_parameters
  GL_EXT_draw_range_elements
  GL_EXT_packed_pixels
  GL_EXT_point_parameters
  GL_EXT_rescale_normal
  GL_EXT_separate_specular_color
  GL_EXT_texture_edge_clamp
  GL_SGIS_generate_mipmap
  GL_SGIS_texture_border_clamp
  GL_SGIS_texture_edge_clamp
  GL_SGIS_texture_lod
  GL_ARB_framebuffer_sRGB
  GL_ARB_multitexture
  GL_EXT_framebuffer_sRGB
  GL_IBM_multimode_draw_arrays
  GL_IBM_texture_mirrored_repeat
  GL_ARB_texture_cube_map
  GL_ARB_texture_env_add
  GL_ARB_transpose_matrix
  GL_EXT_blend_func_separate
  GL_EXT_fog_coord
  GL_EXT_multi_draw_arrays
  GL_EXT_secondary_color
  GL_EXT_texture_env_add
  GL_EXT_texture_lod_bias
  GL_INGR_blend_func_separate
  GL_NV_blend_square
  GL_NV_light_max_exponent
  GL_NV_texgen_reflection
  GL_NV_texture_env_combine4
  GL_S3_s3tc
  GL_SUN_multi_draw_arrays
  GL_ARB_texture_border_clamp
  GL_ARB_texture_compression
  GL_EXT_framebuffer_object
  GL_EXT_texture_compression_s3tc
  GL_EXT_texture_env_combine
  GL_EXT_texture_env_dot3
  GL_MESA_window_pos
  GL_NV_packed_depth_stencil
  GL_NV_texture_rectangle
  GL_ARB_depth_texture
  GL_ARB_occlusion_query
  GL_ARB_shadow
  GL_ARB_texture_env_combine
  GL_ARB_texture_env_crossbar
  GL_ARB_texture_env_dot3
  GL_ARB_texture_mirrored_repeat
  GL_ARB_window_pos
  GL_ATI_fragment_shader
  GL_EXT_stencil_two_side
  GL_EXT_texture_cube_map
  GL_NV_depth_clamp
  GL_NV_fog_distance
  GL_APPLE_packed_pixels
  GL_ARB_draw_buffers
  GL_ARB_fragment_program
  GL_ARB_fragment_shader
  GL_ARB_shader_objects
  GL_ARB_vertex_program
  GL_ARB_vertex_shader
  GL_ATI_draw_buffers
  GL_ATI_texture_env_combine3
  GL_ATI_texture_float
  GL_EXT_shadow_funcs
  GL_EXT_stencil_wrap
  GL_MESA_pack_invert
  GL_MESA_ycbcr_texture
  GL_NV_primitive_restart
  GL_ARB_depth_clamp
  GL_ARB_fragment_program_shadow
  GL_ARB_half_float_pixel
  GL_ARB_occlusion_query2
  GL_ARB_point_sprite
  GL_ARB_shading_language_100
  GL_ARB_sync
  GL_ARB_texture_non_power_of_two
  GL_ARB_vertex_buffer_object
  GL_ATI_blend_equation_separate
  GL_EXT_blend_equation_separate
  GL_OES_read_format
  GL_ARB_color_buffer_float
  GL_ARB_pixel_buffer_object
  GL_ARB_texture_compression_rgtc
  GL_ARB_texture_float
  GL_ARB_texture_rectangle
  GL_ATI_texture_compression_3dc
  GL_EXT_packed_float
  GL_EXT_pixel_buffer_object
  GL_EXT_texture_compression_dxt1
  GL_EXT_texture_compression_rgtc
  GL_EXT_texture_mirror_clamp
  GL_EXT_texture_rectangle
  GL_EXT_texture_sRGB
  GL_EXT_texture_shared_exponent
  GL_ARB_framebuffer_object
  GL_EXT_framebuffer_blit
  GL_EXT_framebuffer_multisample
  GL_EXT_packed_depth_stencil
  GL_ARB_vertex_array_object
  GL_ATI_separate_stencil
  GL_ATI_texture_mirror_once
  GL_EXT_draw_buffers2
  GL_EXT_draw_instanced
  GL_EXT_gpu_program_parameters
  GL_EXT_gpu_shader4
  GL_EXT_texture_array
  GL_EXT_texture_compression_latc
  GL_EXT_texture_integer
  GL_EXT_texture_sRGB_decode
  GL_EXT_timer_query
  GL_OES_EGL_image
  GL_EXT_texture_buffer_object
  GL_AMD_texture_texture4
  GL_ARB_copy_buffer
  GL_ARB_depth_buffer_float
  GL_ARB_draw_instanced
  GL_ARB_half_float_vertex
  GL_ARB_instanced_arrays
  GL_ARB_map_buffer_range
  GL_ARB_texture_buffer_object
  GL_ARB_texture_rg
  GL_ARB_texture_swizzle
  GL_ARB_vertex_array_bgra
  GL_EXT_texture_swizzle
  GL_EXT_vertex_array_bgra
  GL_NV_conditional_render
  GL_AMD_conservative_depth
  GL_AMD_draw_buffers_blend
  GL_AMD_seamless_cubemap_per_texture
  GL_AMD_shader_stencil_export
  GL_ARB_ES2_compatibility
  GL_ARB_blend_func_extended
  GL_ARB_compatibility
  GL_ARB_debug_output
  GL_ARB_draw_buffers_blend
  GL_ARB_draw_elements_base_vertex
  GL_ARB_explicit_attrib_location
  GL_ARB_fragment_coord_conventions
  GL_ARB_provoking_vertex
  GL_ARB_sampler_objects
  GL_ARB_seamless_cube_map
  GL_ARB_shader_stencil_export
  GL_ARB_shader_texture_lod
  GL_ARB_texture_buffer_object_rgb32
  GL_ARB_texture_cube_map_array
  GL_ARB_texture_gather
  GL_ARB_texture_multisample
  GL_ARB_texture_query_lod
  GL_ARB_texture_rgb10_a2ui
  GL_ARB_uniform_buffer_object
  GL_ARB_vertex_type_2_10_10_10_rev
  GL_EXT_provoking_vertex
  GL_EXT_texture_snorm
  GL_MESA_texture_signed_rgba
  GL_NV_copy_image
  GL_ARB_draw_indirect
  GL_ARB_get_program_binary
  GL_ARB_robustness
  GL_ARB_separate_shader_objects
  GL_ARB_shader_bit_encoding
  GL_ARB_shader_subroutine
  GL_ARB_texture_compression_bptc
  GL_ARB_timer_query
  GL_ARB_transform_feedback2
  GL_ARB_transform_feedback3
  GL_ARB_viewport_array
  GL_EXT_direct_state_access
  GL_AMD_multi_draw_indirect
  GL_ANGLE_texture_compression_dxt3
  GL_ANGLE_texture_compression_dxt5
  GL_ARB_base_instance
  GL_ARB_compressed_texture_pixel_storage
  GL_ARB_conservative_depth
  GL_ARB_internalformat_query
  GL_ARB_map_buffer_alignment
  GL_ARB_shader_atomic_counters
  GL_ARB_shader_image_load_store
  GL_ARB_shading_language_420pack
  GL_ARB_shading_language_packing
  GL_ARB_texture_storage
  GL_ARB_transform_feedback_instanced
  GL_EXT_framebuffer_multisample_blit_scaled
  GL_EXT_transform_feedback
  GL_AMD_query_buffer_object
  GL_AMD_shader_trinary_minmax
  GL_ARB_ES3_compatibility
  GL_ARB_arrays_of_arrays
  GL_ARB_clear_buffer_object
  GL_ARB_copy_image
  GL_ARB_explicit_uniform_location
  GL_ARB_fragment_layer_viewport
  GL_ARB_framebuffer_no_attachments
  GL_ARB_invalidate_subdata
  GL_ARB_multi_draw_indirect
  GL_ARB_program_interface_query
  GL_ARB_shader_image_size
  GL_ARB_shader_storage_buffer_object
  GL_ARB_stencil_texturing
  GL_ARB_texture_buffer_range
  GL_ARB_texture_query_levels
  GL_ARB_texture_storage_multisample
  GL_ARB_texture_view
  GL_ARB_vertex_attrib_binding
  GL_KHR_debug
  GL_KHR_texture_compression_astc_ldr
  GL_ARB_buffer_storage
  GL_ARB_clear_texture
  GL_ARB_enhanced_layouts
  GL_ARB_indirect_parameters
  GL_ARB_internalformat_query2
  GL_ARB_multi_bind
  GL_ARB_query_buffer_object
  GL_ARB_seamless_cubemap_per_texture
  GL_ARB_shader_draw_parameters
  GL_ARB_shader_group_vote
  GL_ARB_shading_language_include
  GL_ARB_texture_mirror_clamp_to_edge
  GL_ARB_texture_stencil8
  GL_ARB_vertex_type_10f_11f_11f_rev
  GL_EXT_shader_integer_mix
  GL_ARB_clip_control
  GL_ARB_conditional_render_inverted
  GL_ARB_cull_distance
  GL_ARB_derivative_control
  GL_ARB_direct_state_access
  GL_ARB_get_texture_sub_image
  GL_ARB_pipeline_statistics_query
  GL_ARB_transform_feedback_overflow_query
  GL_EXT_polygon_offset_clamp
  GL_KHR_context_flush_control
  GL_ARB_parallel_shader_compile
  GL_ARB_shader_atomic_counter_ops
  GL_KHR_no_error
  GL_KHR_texture_compression_astc_sliced_3d
  GL_MESA_shader_integer_functions
  GL_ARB_polygon_offset_clamp
  GL_KHR_parallel_shader_compile
  GL_EXT_EGL_image_storage
  GL_EXT_texture_sRGB_R8
  GL_EXT_EGL_sync

Tatsuro MATSUOKA <tmacchant>
Wed 22 Jun 2022 09:27:33 AM UTC, comment #1: 

Works for me on Windows 11 with Octave 7.1.0.

The version of Mesa3D was updated for Octave 7. Maybe, the newer version has an issue with your graphics card or DPI setting or ...?

What does `__opengl_info__` return for you?

Is this still an issue with the release candidate for Octave 7.2? You can download Windows installers for the release candidate from here:
https://alpha.gnu.org/gnu/octave/?C=M;O=D

Markus Mützel <mmuetzel>
Project Member
Wed 22 Jun 2022 07:49:03 AM UTC, original submission:  

I cannot see a plot on qt graphics on 7.1.0 on windows.
But I can see a plot on qt graphics on 6.4.0 on windows.

How to reproduce:

graphics_toolkit qt;
plot(1:10);

Perhaps this is environmental-dependent.
Screenshots of 7.1.0 and 6.4.0 are attached.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #53331:  Figure1_6.4.0_qt.png added by tmacchant (18KiB - image/png)

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by tmacchant (Updated the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2022-06-22 mmuetzel CategoryNone Plotting with OpenGL
        Item GroupNone Incorrect Result
    2022-06-22 mmuetzel Dependencies- bugs #62661 is dependent
    2022-06-22 tmacchant Attached File- Added Figure1_6.4.0_qt.png, #53331
        Attached File- Added Figure1_7.1.0_qt.png, #53332

    Back to the top


    Powered by Savane 3.9