bugGNU Octave - Bugs: bug #62556, a +=1 generates an error on 7.1.0

 
 

bug #62556: a +=1 generates an error on 7.1.0

Submitter:  David Contreras <dvd101>
Submitted:  Wed 01 Jun 2022 06:16:27 PM UTC
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error or Warning
Status:  Duplicate Assigned to:  None
Originator Name:  David Open/Closed:  * Closed
Release:  * 7.1.0 Operating System:  * Any
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Fri 03 Jun 2022 05:24:00 PM UTC, comment #3: 

Thank you all, I wasn't aware of that syntax of command style function call, which I will look into. Sorry for the confusion on my end and thank you for the clarification.

comentario nÂș2:

> See also bug #60882 where the changes in parsing command-style functions were discussed.

Anonymous
Thu 02 Jun 2022 12:41:30 AM UTC, comment #2: 

See also bug #60882 where the changes in parsing command-style functions were discussed.

John W. Eaton <jwe>
Project Administrator
Wed 01 Jun 2022 06:49:39 PM UTC, comment #1: 

Thank you for reporting. This is a duplicate of bug #62552 submitted yesterday based on a Discourse report. Closing as duplicate. Please continue any discussion there.

Arun Giridhar <arungiridhar>
Project Member
Wed 01 Jun 2022 06:16:27 PM UTC, original submission:  

On 7.1.0 this code generates an error

a = 1;
a +=1

error: a used as variable and later as function

The issue is found where there is a space before "+=" and there is no space after.

All these expressions work fine

a += 1
a+=1
a+= 1

The same happens with other operands

a +=1

error: a used as variable and later as function

a -=1

error: a used as variable and later as function

a *=1

error: a used as variable and later as function

a /=1

error: a used as variable and later as function

I did check for 6.4.0 and it works fine on that version

I'm very thankful for this open source software, I hope this bug report is useful.

David Contreras <dvd101>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by arungiridhar (Posted a comment)
  • -email is unavailable- added by dvd101 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2022-06-01 arungiridhar CategoryNone Interpreter
        StatusNone Duplicate
        Open/ClosedOpen Closed
        Operating SystemMicrosoft Windows Any

    Back to the top


    Powered by Savane 3.9