bugGNU Octave - Bugs: bug #61474, error message from saving ofig the...

 
 

bug #61474: error message from saving ofig the second times

Submitted by:  Liang Tang <lt1234>
Submitted on:  Sat 13 Nov 2021 05:55:24 PM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error or Warning
Status:  Wont Fix Assigned to:  None
Originator Name:  lt1234 Open/Closed:  Closed
Release:  6.3.0 Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 16 Nov 2021 04:16:36 AM UTC, comment #5: 

See bug #61491 for the new issue report on 'appdata' not being saved.

Rik <rik5>
Project Administrator
Tue 16 Nov 2021 03:41:11 AM UTC, comment #4: 

The error message isn't worth fixing in my opinion as a new release of Octave which fixes this will be out in 2 months.

I'm going to open a new bug report for the second issue.

Rik <rik5>
Project Administrator
Sun 14 Nov 2021 05:32:59 PM UTC, comment #3: 

There is another item that I can pull a report.  It is also figure related and takes small effort to verify.  Thanks. 

The appdata is not saved/reloaded, while userdata is saved and reloaded. 

fid=figure; plot([0,1], [0,1]); setappdata(fid, 'a',1);
getappdata(gcf, 'a')
ans = 1

%%% manuall save the figure with default, untitled.ofig. 

close all;clear all; hgload('untitled.ofig');
getappdata(gcf, 'a')
ans = [](0x0)

Liang Tang <lt1234>
Sun 14 Nov 2021 04:14:09 AM UTC, comment #2: 

I can reproduce on version 6.4, but not on the development branch.  Is it worth trying to find the cause of this when the development branch is going to be released soon as 7.1 anyways?

Rik <rik5>
Project Administrator
Sat 13 Nov 2021 07:16:03 PM UTC, comment #1: 

I can reproduce this on linux and with 6.4.0

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Sat 13 Nov 2021 05:55:24 PM UTC, original submission:  

I put this item into community help and got flagged as "spam". No one can see the post as the result.  Therefore I am submitting w/o a second opinion.  Thanks. 

I got an error message by interactively save a same figure twice:  

(1) figure; plot([0 1], [0 1]);           % pick save from file menu and accept default.  Repeat save.
(2) Save the ofig by manually picking  save from the figure File menu and accept default.  untitled.ofig is saved.  % make change to the existing plot did not seem to affect if the error message would show or not
(3) Repeat (2).  Save by picking  save from the figure File menu.  This error message shows in the command window right after. 

>> error: print: unknown device ofig

error: called from
    _print_parse_opts_ at line 420 column 5
    print at line 415 column 8
    saveas at line 115 column 3
    _add_default_menu_>save_cb at line 194 column 7

Liang Tang <lt1234>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by lt1234 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-11-16 rik5 Open/ClosedOpen => Closed
    2021-11-16 rik5 StatusNone => Wont Fix
        Operating SystemMicrosoft Windows => Any

    Back to the top


    Powered by Savane 3.7