bugGNU Octave - Bugs: bug #61385, Correct error message in...

 
 

bug #61385: Correct error message in configure.ac

Submitter:  Petter Tomner <petter>
Submitted:  Mon 25 Oct 2021 08:44:12 PM UTC
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error or Warning
Status:  Fixed Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Tue 26 Oct 2021 07:10:44 AM UTC, comment #1: 

Thanks for reporting this typo and providing a fix.
I pushed your patch to the stable branch of Octave here:
http://hg.savannah.gnu.org/hgweb/octave/rev/aaac4d16af9e

Closing as fixed.

Markus M├╝tzel <mmuetzel>
Project Member
Mon 25 Oct 2021 08:44:12 PM UTC, original submission:  

Hi!

I was trying to build Octave and ./configure told me to "--disable-cxsparse". Who needs sparse matrixes anyways I thought, but the flag didn't do anything.

The proper error msg should have been "--without-cxsparse", see patch.

I don't know if the flags are version dependent in anyway on the build chain.

Regards,

Petter Tomner <petter>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #52153:  errmsgcorrect.patch added by petter (967B - text/x-patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by petter (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-10-26 mmuetzel StatusNone Fixed
        Open/ClosedOpen Closed
        Operating SystemGNU/Linux Any
    2021-10-25 petter Attached File- Added errmsgcorrect.patch, #52153

    Back to the top


    Powered by Savane 3.9