bugGNU Octave - Bugs: bug #60621, unclear error message in case of...

 
 

bug #60621: unclear error message in case of missing final semicolon in 'plot' command argument

Submitted by:  None
Submitted on:  Mon 17 May 2021 11:11:40 AM UTC  
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  None Assigned to:  None
Originator Name:  Sergei Steshenko Originator Email:  -email is unavailable-
Open/Closed:  Open Release:  4.2.2
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 17 May 2021 11:11:40 AM UTC, original submission:  

Please see the following screen session:

"
octave:4> plot(1:2, 1:2, "-;y")
error: plot: properties must appear followed by a value
error: called from
    _plt_ at line 96 column 15
    plot at line 223 column 10
octave:4>
".

The problem is missing semicolon after 'y', i.e. the proper command should be

plot(1:2, 1:2, "-;y;")
.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.6