bugGNU Octave - Bugs: bug #60585, Wrong EOL in new files on GNU/Linux

 
 

bug #60585: Wrong EOL in new files on GNU/Linux

Submitted by:  None
Submitted on:  Tue 11 May 2021 05:19:51 PM UTC  
 
Category:  None Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Fixed Assigned to:  Torsten Lilge <ttl>
Originator Name:  Singon Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  6.2.0
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 17 May 2021 10:30:05 PM UTC, comment #4: 

No response, assuming changeset has fixed this.  Closing report.

Rik <rik5>
Project Administrator
Tue 11 May 2021 08:44:28 PM UTC, comment #3: 

I have cset http://hg.savannah.gnu.org/hgweb/octave/rev/1583728a5819 to stable, which should fix the issue.

Torsten Lilge <ttl>
Project MemberIn charge of this item.
Tue 11 May 2021 08:25:43 PM UTC, comment #2: 

The desired eol is not read from the settings. I am wondering when this was (accidentally) removed. Patch will follow.

Torsten Lilge <ttl>
Project MemberIn charge of this item.
Tue 11 May 2021 05:33:36 PM UTC, comment #1: 

Thanks for the report; I can confirm the bug. The "save as" action seems to save with CRLF while ignoring the desired EOL mode.

Torsten Lilge <ttl>
Project MemberIn charge of this item.
Tue 11 May 2021 05:19:51 PM UTC, original submission:  

Octave GUI creates new files with CRLF line endings, even when running on GNU/Linux. The setting under Preferences > Editor > Default EOL mode seems to be ignored.

I remember seeing this issue in previous Octave versions as well, since maybe a year ago.
I have tried setting the EOL mode to all three values, but did not notice any change in Octave's behaviour.

Steps to reproduce:

  1. In the Octave GUI, create a new file.
  2. Enter any multiline text.
  3. Save the file.
  4. The file is saved with CRLF line endings instead of the expected LF.

I am running Manjaro Linux 21.0.4, the Octave version is 6.2.0-1 installed from the community repository.

Can anybody confirm this issue?

Thanks in advance.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-05-17 rik5 StatusReady For Test => Fixed
        Open/ClosedOpen => Closed
    2021-05-11 ttl StatusNone => Ready For Test
    2021-05-11 ttl Assigned toNone => ttl

    Back to the top


    Powered by Savane 3.7