bugGNU Octave - Bugs: bug #60310, GUI not showing

 
 

bug #60310: GUI not showing

Submitted by:  None
Submitted on:  Tue 30 Mar 2021 05:28:28 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Installation Failure
Status:  Need Info Assigned to:  None
Originator Name:  Sascha Becker Originator Email:  -email is unavailable-
Open/Closed:  Open Release:  6.2.0
Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 07 Apr 2021 12:40:30 PM UTC, comment #34: 

5.2.0 is from PortableApps (no installation)
6.2.0  is a ZIP file from gnu.org (no installation)

But i have also tried the installaer versin of 6.2.0.

Nightbuild 6.2.1 is a ZIP-File (no installation)

I allways started "post-install.bat"

Anonymous
Tue 06 Apr 2021 07:47:02 PM UTC, comment #33: 

Did you install 6.2.0 and 5.2.0 side by side?

Maybe related (just a hunch!):
If I install Octave-7.0.0 (dev version) on a box that has 5.2.0 or 6.2.0 installed, the desktop shortcuts for 7.0.0 refer to the 5.2.0 or 6.2.0 installation. Apparently the installer screws up when creating the shortcut paths, in combination with the wscript (Windows Scripting Host) stuff.
So it may be worthwhile to check if the paths in the shortcuts point to the proper Octave installation.

Philip Nienhuis <philipnienhuis>
Project Member
Tue 06 Apr 2021 09:07:19 AM UTC, comment #32: 

It's difficult to deduce what might be the issue and what resolved it for you with the 6.2.1 nightly. (And I'm running out of ideas how to further track this down with just copying libraries around.)

It's probably best to wait for the first release candidate of Octave 6.3 by jwe (no idea when this will happen) and check if that'll work.
If I remember, I'll add a comment when that will be available.

Markus Mützel <mmuetzel>
Project Member
Tue 06 Apr 2021 08:55:06 AM UTC, comment #31: 

(1)
Its not enough to copy only the icu files. I need to copy the "qt package (files and folder)" and the icu files from 5.2.0 to run 6.2.0.

(2)
See the MsgBox  attachment (in german) if i only copy the qt package from 5.2.0 to 6.2.0.

(3)
If i only replace the icu files the octave-gui.exe can be found in the task manager but no window is created. I then need to kill the process in the task manager it does not end on its own.


Anonymous
Mon 05 Apr 2021 04:03:44 PM UTC, comment #30: 

Thanks for testing.

The files in the system32 directory are probably unrelated.

I don't know if you tried that yet: Is it enough to copy the ICU files from Octave 5.2.0 to Octave 6.2.0? Or do you also need to copy the Qt files (binaries and plugins come as one "package". Afaict, they cannot be mixed in general)?

In case there'll be an Octave 6.3.0 and it is not something in Octave itself that fixed it for you, but it is one of the other packages (Qt or ICU or both?), it is likely that that version won't work for you either.
By default, the "official" installer for 6.3.0 will package the same versions of packages like Octave 6.2.0. The nightly build that worked for you has newer versions that - by default - will be part of an Octave 7 installer (maybe due next year?).

Markus Mützel <mmuetzel>
Project Member
Mon 05 Apr 2021 03:14:26 PM UTC, comment #29: 

(1)
Copying from 6.2.1 to 6.2.0 does not work.
Not if i only copy the qt*.* files, not if i only copy the icu*.* files and not if i copy them both plus the qt5 folder.

(2)
In my system32 directory i found two files icuuc.dll and icuin.dll but octave 6.2.0 does not run if i copy those two files from 5.2.0 to the original 6.2.0. So i dont't think that they are part of the problem. But i have no idea tho which program they belong or they are par of windows.

(3)
I am pleased with nightbuild 6.2.1 running on my system but if you think it makes sense to find the problem with 6.2.0 i will go on looking for it.

Anonymous
Mon 05 Apr 2021 11:04:56 AM UTC, comment #28: 

I'm not sure if this will even work. But as a step towards finding out whether it really is the Qt version that makes the difference (not something that has changed in Octave itself since version 6.2.0), could you please try copying the qt5 files  (and ICU?) from the nightly build to the Octave 6.2.0 installation?

Does that allow you to successfully start that version?

Could you please also try copying only the `icu*.*` files (not the Qt files) to the affected version 6.2.0. IIUC, the version packaged with release 6.2.0 is version 67.1. The version with release 5.2.0 was version 65.1. The version packaged with the nightly is probably version 68.2.

Markus Mützel <mmuetzel>
Project Member
Sun 04 Apr 2021 10:10:43 AM UTC, comment #27: 

The anti virus program (Avira) and the firewall have been checked by me right at the beginning.

Anonymous
Sat 03 Apr 2021 03:26:10 PM UTC, comment #26: 

Probably not the right trace, but just to throw in another unpredictable MS Windows source of problems: is any "anti virus" software with quarantined DLLs involved?

Kai Torben Ohlhus <siko1056>
Project Member
Fri 02 Apr 2021 07:41:54 PM UTC, comment #25: 

Nightbuild 6.2.1 works for me without patching.

Anonymous
Fri 02 Apr 2021 06:46:41 PM UTC, comment #24: 

Could you check with a nightly build from Kai's buildbots? I believe they are built against Qt 5.15.2:
https://buildbot.octave.space/#/download

Markus Mützel <mmuetzel>
Project Member
Fri 02 Apr 2021 05:40:03 PM UTC, comment #23: 

I started with fresh installation. It is enough to copy all the qt5*.* files, the icu*.* files to bin and the qt5 folder to mingw64. Then octave can be started with octave.vbs.

Anonymous
Fri 02 Apr 2021 04:49:46 PM UTC, comment #22: 

So, IIUC it was not the different Qt version that allowed you to run Octave correctly. It might have been one (or more) of the approx. 400 additional files that made the difference.
It might help narrowing down which it was.

Markus Mützel <mmuetzel>
Project Member
Fri 02 Apr 2021 04:44:00 PM UTC, comment #21: 

I first copied only the qt5*.* files then octave complains about icu*.dll files at start (msgbox). I copied all icu*.dll and then octave does not complain but it does not run. After this i copied aprox. 400 additional files from the bin directory of 5.2.0 (the rest). Octave complained about qt5 addins which i had seen in the qt5 folder so i copied it from the old 5.2.0 installation and octave 6.2.0 runs.

Anonymous
Fri 02 Apr 2021 04:18:35 PM UTC, comment #20: 

It's still strange that the old configuration worked for some users but not for others on the same hardware (on the same Windows installation even).

It might be interesting to know which package is broken for the affected user. Could you try with only replacing the Qt binaries but keeping all others?

Markus Mützel <mmuetzel>
Project Member
Fri 02 Apr 2021 04:09:43 PM UTC, comment #19: 

Oh now i did something very very very dirty. I think i belong to hell.
I recognized that qt version of octave 6.2.0 is 5.14.2. and qt version of octave 5.2.0 is 5.14.0. I copied all the files from 5.2.0\mingw64\bin to 6.2.0\mingw64\bin without copying the old octave*.* files. Then i copied the folder 5.2.0\qt5 to 6.2.0\qt5. Lets say i use the old runtime system and the new octave program.

Now i am able to start octave 6.2.0. on my account. I did some symbolic tests and ploting and it works so far.

Anonymous
Fri 02 Apr 2021 12:49:32 PM UTC, comment #18: 

Yes i ran post-install.bat.

Anonymous
Fri 02 Apr 2021 11:14:03 AM UTC, comment #17: 

Did you run post-install.bat after unpacking the tarball ?

John Donoghue <lostbard>
Project Member
Thu 01 Apr 2021 09:21:27 PM UTC, comment #16: 

I added strace.txt below. But strace.exe did not finish i had to stop it after 5 mins.

(file #51174)

Anonymous
Thu 01 Apr 2021 08:59:14 PM UTC, comment #15: 

Ypu can also try

..\..\usr\bin\strace.exe octave-gui.exe --gui

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 01 Apr 2021 08:56:12 PM UTC, comment #14: 

There should be a (command line) program strace.exe in Octave-6.2.0\usr\bin.

Can you try (from mingw64\bin):

..\..\usr\bin\strace.exe qtdiag.exe

and post the output you would get?

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 01 Apr 2021 08:32:23 PM UTC, comment #13: 

I can't find a difference in the PATH environment variable of the two acounts. Any ideas how to find this?

Anonymous
Thu 01 Apr 2021 05:52:47 PM UTC, comment #12: 

Does the affected user have any libraries on the path that might be conflicting? (Another Qt installation?)

Markus Mützel <mmuetzel>
Project Member
Thu 01 Apr 2021 05:17:09 PM UTC, comment #11: 

There is a commandline tool called qtdiag.exe near the octave executable. It can be started for the user Test but it "hangs" directly for me (no output and it does not come back).

Regards

Sascha

Anonymous
Thu 01 Apr 2021 04:32:33 PM UTC, comment #10: 

runas /user:Test "C:\Octave\octave-6.2.0-w64\mingw64\bin\octave-gui.exe --gui"

This works on my account.

Anonymous
Thu 01 Apr 2021 04:24:33 PM UTC, comment #9: 

Four normal letters for me. Her first name. Nothing special.

I created a new user called Test and started octave_firsttime.vbs. I saw the dialog with the question where to place the octave-gui.ini file.

I am sure if have never seen this dialog on my account.

Anonymous
Thu 01 Apr 2021 04:03:31 PM UTC, comment #8: 

What is your and your wife's Windows user names? Does any of them contain non-ASCII characters or spaces?
Anything else you can think of that is different between your and your wife's account?

Markus Mützel <mmuetzel>
Project Member
Thu 01 Apr 2021 02:35:32 PM UTC, comment #7: 

Yes octave-gui.exe ist in the process tab. I used AutoIt to get the window handle and called _WinAPI_ShowWindow but only the black comandline window showed up. No gui window. For me it looks like octave-gui.exe is stuck before window creation.

Anonymous
Wed 31 Mar 2021 07:56:11 PM UTC, comment #6: 

Does Octave appear in the Task Manager's Processes tab?

Philip Nienhuis <philipnienhuis>
Project Member
Wed 31 Mar 2021 07:38:58 PM UTC, comment #5: 

The octave window can not be seen in the window list of "Alt-Tab" and it can not be moved to the visible area with "Alt-Space".

Anonymous
Wed 31 Mar 2021 07:22:27 PM UTC, comment #4: 

@Dimitri, yes possible but the very first start (no ini file yet) should be on the main screen.

Torsten Lilge <ttl>
Project Member
Wed 31 Mar 2021 06:49:12 PM UTC, comment #3: 

We have seen reports of octave starting off-screen. If that is the case you can use dome windows hot-keys to move it.

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Wed 31 Mar 2021 06:40:37 PM UTC, comment #2: 

There was no ...\AppData\roaming\octave\octave-gui.ini for me. I logged in with the user of my wife and i was able to start octave on her account. Strange. I logged in with my account and could not start octave. I removed nearly everything with the string "octave" from the registy and removed every file with the name "*octave*.*" from my user dir. It does not start for my user and it did not start with admin rights.
I even copied ...\AppData\roaming\octave\octave-gui.ini into my user dir. It won't run for me. 

Do you know any places with persistent information for octave?

Regards

Sascha

Anonymous
Wed 31 Mar 2021 12:34:43 PM UTC, comment #1: 

Thanks for the report. The configuration file for the 6.x.y versions of Octave is located at

AddData\roaming\octave\octave-gui.ini

Could you pleas try to delete this before starting Octave?

Torsten Lilge <ttl>
Project Member
Tue 30 Mar 2021 05:28:28 PM UTC, original submission:  

I downloaded octave-6.2.0-w64.zip from gnu.org and unpacked it to c:\octave\. When i try to start it with octave.vbs nothing (visual) happens. In the task-manager i can see octave-gui.exe --gui running but no windows are shown. I tried to start the app from the commandline. Same result. I removed the ~/./config folder. Same result. The only way to run a older version ist using the 5.2 version from portableapps. This works. Using the 6.2 installer does not work for me. Installing it with chocolatey does not work.
I am using Windos 10 x64 with latest updates.

Regards

Sascha

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #51174:  strace.txt added by None (15KiB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-04-06 None Attached File- => Added 2021-04-06@10_49_39-octave-gui.exe@-@Systemfehler.png, #51198
    2021-04-01 None Attached File- => Added strace.txt, #51174
    2021-04-01 mmuetzel StatusNone => Need Info

    Back to the top


    Powered by Savane 3.6