bugGNU Octave - Bugs: bug #60127, pkg: DESCIPTION...

 
 

bug #60127: pkg: DESCIPTION "Depends" keyword should support != and ~= operators

Submitted by:  Ernst Reissner <ernstreissner>
Submitted on:  Fri 26 Feb 2021 03:33:05 PM UTC  
 
Category:  Interpreter Severity:  1 - Wish
Priority:  3 - Low Item Group:  Feature Request
Status:  Postponed Assigned to:  None
Originator Name:  Reissner Open/Closed:  Open
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Thu 11 Mar 2021 03:30:17 PM UTC, comment #7: 

Sorry got distracted.
Next guess: this weekend (12-14 Mar).

Philip Nienhuis <philipnienhuis>
Project Member
Tue 02 Mar 2021 07:44:14 PM UTC, comment #6: 

I already got it working to some extent. Hopefully tomorrow I'll be able to supply a patch.

Philip Nienhuis <philipnienhuis>
Project Member
Mon 01 Mar 2021 02:00:20 AM UTC, comment #5: 

@Ernst: The priority is not raised to "low".  To my experience, this "Priority" has marginal effect on the speed of working on items.  There are also "7 high priority" bugs which haven't been resolved for years (e.g. bug #46849) 😇  What seems to me as "best strategy" is to make your bug precise and small in scope, interesting for others, and to be helpful and cooperative (provide an own patch, as you suggested).

Can you alongside with your patch provide a minimal demo package to try out the patch?

@Philip: You are right, it seems to boil down to your suggestions of comment #3 https://hg.savannah.gnu.org/hgweb/octave/file/b03104e38964/scripts/pkg/private/get_description.m#l107

Kai Torben Ohlhus <siko1056>
Project Member
Sun 28 Feb 2021 10:30:47 PM UTC, comment #4: 

you are right.
Easy to do.
I would contribute a patch if that helps to fix fast.

Ernst Reissner <ernstreissner>
Sun 28 Feb 2021 10:16:07 PM UTC, comment #3: 

Looks like it's merely a matter of amending the regexp on L.107 and  adding the operators in L.121 of pkg.m's private function get_description.m.
AFAICS all the other required code is in place - compare_versions.m (called in get_unsatisfied_dependencies.m) already supports those operators.

Fixing the regexp is probably the hardest part.

Philip Nienhuis <philipnienhuis>
Project Member
Sun 28 Feb 2021 12:31:32 PM UTC, comment #2: 

Yes, you are right, it is a feature request.
Please dont put priority to later,
because it is important in particular for java implementations,
as octave developers frequently break my code
and so there are lots of gaps in the version working properly.
This is the use case of ~= operator.

On the other hand, it is easy to provide as version comparison
is done with `compare_versions` which already supports ==, != and ~=.
This means it is little effort to implement.

So summarizing, it is little effort and much help.
Please consider not downvoting priority.

Ernst Reissner <ernstreissner>
Sat 27 Feb 2021 05:27:46 AM UTC, comment #1: 

Thank you for the hint.  According to the documentation

https://octave.org/doc/v6.2.0/The-DESCRIPTION-File.html

these operators are not supported yet and it is a feature request.

Kai Torben Ohlhus <siko1056>
Project Member
Fri 26 Feb 2021 03:33:05 PM UTC, original submission:  

As my package works for 5.2.0 and again for 6.2.0
but not for 6.1.0 because of a bug in octave,
I want to write in the DESCRIPTION file
the dependency
Depends:     octave (>= ${versionOctaveMin}), octave (<= ${versionOctaveMax}), octave (~= 6.1.0)
maybe with !=.

That way one can specify an interval with gaps.
Unfortunately this seems not possible : "Invalid call to strtrim."

Ernst Reissner <ernstreissner>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by ernstreissner (Submitted the item)
  • -email is unavailable- added by ernstreissner
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-03-01 siko1056 Priority1 - Later => 3 - Low
    2021-02-27 siko1056 Severity3 - Normal => 1 - Wish
        Priority5 - Normal => 1 - Later
        Item GroupInstallation Failure => Feature Request
        StatusNone => Postponed
        Release6.2.0 => dev
        SummaryDESCIPTION Depends: != and ~= missing => pkg: DESCIPTION "Depends" keyword should support != and ~= operators
    2021-02-26 ernstreissner Carbon-Copy- => Added rei3ner@arcor.de

    Back to the top


    Powered by Savane 3.6