bugGNU Octave - Bugs: bug #60115, Blank Contents and Function Index...

 
 

bug #60115: Blank Contents and Function Index in GUI documentation pane

Submitted by:  Atri Bhattacharya <badshah400>
Submitted on:  Thu 25 Feb 2021 12:51:42 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Documentation
Status:  Need Info Assigned to:  None
Originator Name:  Open/Closed:  Open
Release:  6.2.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 10 Mar 2021 06:33:00 AM UTC, comment #8: 

The tests from the previous comments indicate a correct configuration of the help files and the build system and there is no resolution so far. I cannot see a systematic cause for the issue and it is not reproducible on other systems.

Torsten Lilge <ttl>
Project Member
Tue 09 Mar 2021 04:19:07 PM UTC, comment #7: 

Was there a resolution to this bug?  Is this just mysteriously about the behavior of one particular system?

Rik <rik5>
Project Administrator
Wed 03 Mar 2021 09:05:55 PM UTC, comment #6: 

comment #5:

>
> Do you have the qt-assistant installed as a separate tool? If yes, can you add the file octave_interpreter.qch via the menu "Edit", "Preferneces", tab "Documentation" and see if contents and index are okay there?


Installed assistant and added the octave_interpreter.qch as you advised, and the octave documentation shows up in assistant just fine.

Atri Bhattacharya <badshah400>
Wed 03 Mar 2021 07:51:32 PM UTC, comment #5: 

No, it looks like the configuration is okay. At least, the new help system API in Qt 15 was detected. Moreover if you would have configured the build without docs, you would not be able to see any documentation text at all.

Do you have the qt-assistant installed as a separate tool? If yes, can you add the file octave_interpreter.qch via the menu "Edit", "Preferneces", tab "Documentation" and see if contents and index are okay there?

Btw: The file octave_interpreter.qch on my system is in /usr/local/share/octave/...

Torsten Lilge <ttl>
Project Member
Wed 03 Mar 2021 07:15:55 PM UTC, comment #4: 

Is this may be due to something I may have configured incorrectly during the build? Thanks.

Atri Bhattacharya <badshah400>
Thu 25 Feb 2021 09:56:47 PM UTC, comment #3: 

comment #2:

> Thanks for the report. You are describing the same issues as in bug #59375. However, this bug was fixed just before the 6.1.0 release. Are you seeing this line in your config.log?
>

> #define HAVE_NEW_QHELPINDEXWIDGET_API 1


Yes, indeed that shows up:

# grep -C3 HAVE_NEW_QHELPINDEXWIDGET_API config.log
#define HAVE_QHEADERVIEW_SETSECTIONSCLICKABLE 1
#define HAVE_QHEADERVIEW_SETSECTIONSMOVABLE 1
#define HAVE_QHELPSEARCHQUERYWIDGET_SEARCHINPUT 1
#define HAVE_NEW_QHELPINDEXWIDGET_API 1
#define HAVE_QINSTALLMESSAGEHANDLER 1
#define HAVE_QLINEEDIT_SETPLACEHOLDERTEXT 1
#define HAVE_QLIST_ITERATOR_CONSTRUCTOR 1

Atri Bhattacharya <badshah400>
Thu 25 Feb 2021 06:13:00 PM UTC, comment #2: 

Thanks for the report. You are describing the same issues as in bug #59375. However, this bug was fixed just before the 6.1.0 release. Are you seeing this line in your config.log?

#define HAVE_NEW_QHELPINDEXWIDGET_API 1

Torsten Lilge <ttl>
Project Member
Thu 25 Feb 2021 12:58:19 PM UTC, comment #1: 

If it helps, these are the dependencies against which we build octave:

  • GCC 10.2.1
  • Qt5 5.15.2
  • qscintilla_qt5 2.11.6

We use link-time-optimization when building.

Atri Bhattacharya <badshah400>
Thu 25 Feb 2021 12:51:42 PM UTC, original submission:  

Octave version(s): 6.1.0 and 6.2.0
OS: openSUSE Tumbleweed
Package origin: From distro, specfile here.

Since version 6.1.0 the Contents and Function Index panes in the GUI documentation appears completely blank. However, searching for a function still brings up results which can be read in the documentation viewing pane. Typing  help plot in the command window also displays the help text fine.

The documentation files seem to be all installed locally (same as in version 5.x).

> ls /usr/share/octave/6.2.0/doc/
octave_interpreter.qch  octave_interpreter.qhc

Atri Bhattacharya <badshah400>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #50927:  build.log.gz added by badshah400 (128KiB - application/gzip - Full config.log)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by badshah400 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-03-09 rik5 StatusNone => Need Info
        Release6.1.0 => 6.2.0
    2021-02-25 badshah400 Attached File- => Added build.log.gz, #50927

    Back to the top


    Powered by Savane 3.6