bugGNU Octave - Bugs: bug #59035, [octave forge] (website) Viewing...

 
 

bug #59035: [octave forge] (website) Viewing pushed patches using https now requires a username & password

Submitted by:  None
Submitted on:  Fri 28 Aug 2020 10:26:49 PM UTC  
 
Category:  Octave Forge website Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Wont Fix Assigned to:  Octave Forge <octave-forge>
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  other
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 01 Sep 2020 10:16:41 AM UTC, comment #7: 

Kai,

Thank you for looking into this.
I now have a better understanding of what happened.

Anonymous
Tue 01 Sep 2020 06:08:25 AM UTC, comment #6: 

@OP: Maybe HTTPS Everywhere did not replace the protocol previously.  In general everything "works as expected".  It is documented here:

https://sourceforge.net/p/forge/documentation/Mercurial/#developer-access-readwrite

If you mind this HTTP/HTTPS inconsistency, please file a bug report at SourceForge

https://sourceforge.net/p/forge/feature-requests/

and sorry for the inconvenience.

Using the SourceForge website and browsing the commits, the HTTPS URL to watch the patch inside their own web interface is

https://sourceforge.net/p/octave/image/ci/a3540099c0adc51e1bcc18d1d95c8b7bcc157ef2/

Closing this item.  There is nothing we can do.

Kai Torben Ohlhus <siko1056>
Project Member
Tue 01 Sep 2020 05:34:42 AM UTC, comment #5: 

Thanks everyone for your responses

Browser:
I use GNU Ice Cat

Yes HTTPS Everywhere is installed, however this has not been an issue before.

I tested with forcing a http and there is no username/password window.

Anonymous
Mon 31 Aug 2020 03:23:56 PM UTC, comment #4: 

@OP: Do you use a browser addon or other software that automatically redirects http to https? "HTTPS Everywhere" comes to mind.
Which browser do you use?

Markus M├╝tzel <mmuetzel>
Project Member
Sun 30 Aug 2020 09:46:21 AM UTC, comment #3: 

Yep I see that too, but the OP explicitly mentioned an http:// URL.

Philip Nienhuis <philipnienhuis>
Project Member
Sun 30 Aug 2020 03:54:12 AM UTC, comment #2: 

Confirmed when using HTTPS not HTTP

https://hg.code.sf.net/p/octave/image/rev/a3540099c0ad

Maybe a config error?

Kai Torben Ohlhus <siko1056>
Project Member
Sat 29 Aug 2020 11:48:25 AM UTC, comment #1: 

I can't confirm this issue. The link does open for me right away.

To be sure my password manager doesn't interfere I've tried several browsers (in only one of them I have passwords remembered).

Savannah had several issues the last months. So maybe just wait a little and try again later.

BTW strictly speaking this isn't (looks like) an Octave bug. Maybe first ask around in the maintainers ML.

Philip Nienhuis <philipnienhuis>
Project Member
Fri 28 Aug 2020 10:26:49 PM UTC, original submission:  

I was trying to view the push of an image patch
https://savannah.gnu.org/patch/index.php?9849

When clicking the link (*Source Forge*)
http://hg.code.sf.net/p/octave/image/rev/a3540099c0ad

I receive a username/password window.

Previously this was not the case and it looked similar to
what is seen for the main octave program (*Savannah*)
https://hg.savannah.gnu.org/hgweb/octave/

Note this is only for the push link
Going to
https://sourceforge.net/p/octave/image/ci/default/tree/

Still is possible

I tried other packages (Communications, Signal, etc.) starting with http://hg.code.sf.net/p/octave/

And received the same prompt.
Attached is a screen capture of the Authentication Required window.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #49722:  Pass_Screen.png added by None (15KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by siko1056 (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-09-01 siko1056 StatusConfirmed => Wont Fix
        Open/ClosedOpen => Closed
    2020-08-30 siko1056 StatusNone => Confirmed
        Assigned toNone => octave-forge
        Summary[Octave Forge](website) Viewing pushed patches now requires a username & password => [octave forge] (website) Viewing pushed patches using https now requires a username & password
    2020-08-28 None Attached File- => Added Pass_Screen.png, #49722

    Back to the top


    Powered by Savane 3.5