bugGNU Octave - Bugs: bug #58454, GUI cannot save files or exit if...

 
 

bug #58454: GUI cannot save files or exit if 'Command window' is computing or paused

Submitter:  Daniel Molina García <dmolina>
Submitted:  Wed 27 May 2020 03:49:41 PM UTC
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Thu 28 May 2020 12:46:14 AM UTC, comment #2: 

@Philip, thank you for the hint.  Everything discussed and mentioned here and more can be found in bug #44485.

Closing as duplicate of bug #44485.

Kai Torben Ohlhus <siko1056>
Project Member
Wed 27 May 2020 05:34:31 PM UTC, comment #1: 

This looks like a duplicate from ? 2015 ? that Dan Sebald and me have been working on; however for Windows (can't find it ATM).
That was gracefully exiting Octave's GUI while core Octave was internally busy.

Philip Nienhuis <philipnienhuis>
Project Member
Wed 27 May 2020 03:49:41 PM UTC, original submission:  

Octave GUI waits until 'Command window' finishes before performing some actions indicated by the user meanwhile. In particular, "saving a file in 'Editor'" or "exiting the Octave GUI".

How to reproduce it:

1.Type

>> pause

or something computationally expensive which will not finish before you ask the action to the GUI.

>> for i = 1:1e8; a=i; endfor

2. Ask the GUI to exit or save a file.

When the command finishes (for example by pressing Ctrl+C), all previously indicated actions are then correctly performed.

I think it is an undesired behavior. First times I faced it I didn't understand why the GUI was not responding. If it is intended, I think it would be helpful a dialog informing about why Octave GUI isn't doing what I intend. Then I could act consequently.

I describe an use case to show why it was confusing to me:

I have an Cctave program with some "pause" commands to check some intermediate results. I notice that results are wrong so I modify the file and try to save it without caring about finishing execution of paused octave program, Saving is not responding and I cannot realize why. I think Octave has some problems so I try to exit and launch Octave GUI again, but exiting does not work. I don't know how to proceed then.

Daniel Molina García <dmolina>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by dmolina (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-05-28 siko1056 StatusNone Duplicate
        Open/ClosedOpen Closed
    2020-05-28 siko1056 Dependencies- Depends on bugs #44485

    Back to the top


    Powered by Savane 3.9