bugGNU Octave - Bugs: bug #57818, [octave forge] (fits) build...

 
 

bug #57818: [octave forge] (fits) build failure on macOS under 4.4.1 and 5.2.0 - undefined "D_NINT"

Submitted by:  Andrew Janke <apjanke>
Submitted on:  Sat 15 Feb 2020 03:43:45 AM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  5.2.0 Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 16 Feb 2020 10:59:05 AM UTC, comment #4: 

There's no urgency on this: I don't need to use fits immediately. I'm just doing a project where I go through Forge and make sure all the packages run & test under macOS and Octave.app. I'll wait for the release. Thanks!

Andrew Janke <apjanke>
Sun 16 Feb 2020 10:52:13 AM UTC, comment #3: 

Already posted on that one D_INT is depracated. It was supposed to be fixed. If you urgently need to use it, and look for a work around (this is not a fix and I am only a regular user of this package) replace the few occurences of D_INT by round. and install the modified package.

Emmanuel Brandt <emmanuelbrandt>
Sat 15 Feb 2020 08:23:48 PM UTC, comment #2: 

It looks to me like this has been addressed in the repo. Closing as a duplicate of bug #55374.

Mike Miller <mtmiller>
Project Administrator
Sat 15 Feb 2020 04:25:41 AM UTC, comment #1: 

Oops; a bad "verbatim" tag lost the rest of my post.

Here's the error:

octave:10> pkg install -forge fits
read_fits_image.cc:197:10: error: use of undeclared identifier 'D_NINT'
    if( (D_NINT( val ) !=  val) || (val < 0) )
         ^
save_fits_image_multi_ext.cc:81:12: error: use of undeclared identifier 'D_NINT'
      if( (D_NINT( val ) ==  val) )
           ^
save_fits_image.cc:84:12: error: use of undeclared identifier 'D_NINT'
      if( (D_NINT( val ) ==  val) )
           ^
1 error generated.
make: *** [read_fits_image.oct] Error 1
make: *** Waiting for unfinished jobs....
1 error generated.
make: *** [save_fits_image.oct] Error 1
1 error generated.
make: *** [save_fits_image_multi_ext.oct] Error 1
mkoctfile --verbose -Wall -I/usr/local/Cellar/cfitsio/3.470/include -L/usr/local/Cellar/cfitsio/3.470/lib -lcfitsio -lpthread read_fits_image.cc
clang++ -std=gnu++11 -c -I/usr/local/opt/qt/include -fPIC -I/usr/local/Cellar/octave/5.2.0/include/octave-5.2.0/octave/.. -I/usr/local/Cellar/octave/5.2.0/include/octave-5.2.0/octave -I/usr/local/Cellar/octave/5.2.0/include  -D_THREAD_SAFE -pthread -I/Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.2.jdk/Contents/Home/include -I/Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.2.jdk/Contents/Home/include/darwin  -Wall  -I/usr/local/Cellar/cfitsio/3.470/include  read_fits_image.cc -o /var/folders/_4/9mx5ryp52bb_z6drbcbrhwl40000gn/T//oct-qbCkza.o
mkoctfile --verbose -Wall -I/usr/local/Cellar/cfitsio/3.470/include -L/usr/local/Cellar/cfitsio/3.470/lib -lcfitsio -lpthread save_fits_image.cc
clang++ -std=gnu++11 -c -I/usr/local/opt/qt/include -fPIC -I/usr/local/Cellar/octave/5.2.0/include/octave-5.2.0/octave/.. -I/usr/local/Cellar/octave/5.2.0/include/octave-5.2.0/octave -I/usr/local/Cellar/octave/5.2.0/include  -D_THREAD_SAFE -pthread -I/Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.2.jdk/Contents/Home/include -I/Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.2.jdk/Contents/Home/include/darwin  -Wall  -I/usr/local/Cellar/cfitsio/3.470/include  save_fits_image.cc -o /var/folders/_4/9mx5ryp52bb_z6drbcbrhwl40000gn/T//oct-jrOWtA.o
mkoctfile --verbose -Wall -I/usr/local/Cellar/cfitsio/3.470/include -L/usr/local/Cellar/cfitsio/3.470/lib -lcfitsio -lpthread save_fits_image_multi_ext.cc
clang++ -std=gnu++11 -c -I/usr/local/opt/qt/include -fPIC -I/usr/local/Cellar/octave/5.2.0/include/octave-5.2.0/octave/.. -I/usr/local/Cellar/octave/5.2.0/include/octave-5.2.0/octave -I/usr/local/Cellar/octave/5.2.0/include  -D_THREAD_SAFE -pthread -I/Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.2.jdk/Contents/Home/include -I/Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.2.jdk/Contents/Home/include/darwin  -Wall  -I/usr/local/Cellar/cfitsio/3.470/include  save_fits_image_multi_ext.cc -o /var/folders/_4/9mx5ryp52bb_z6drbcbrhwl40000gn/T//oct-3donB3.o

pkg: error running `make' for the fits package.
error: called from
    configure_make at line 99 column 9
    install at line 190 column 7
    pkg at line 441 column 9
octave:10>

I have cfitsio 3.470 installed on this machine.

Andrew Janke <apjanke>
Sat 15 Feb 2020 03:43:45 AM UTC, original submission:  

On macOS 10.14, with Octave 4.4.1 or 5.2.0, when trying to install Forge package fits 1.0.7, I'm getting a build failure due to an undefined "D_NINT" identifier:

Andrew Janke <apjanke>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by emmanuelbrandt (Posted a comment)
  • -email is unavailable- added by apjanke (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-02-15 mtmiller StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Summary[fits] Build failure on macOS under 4.4.1 and 5.2.0 - undefined "D_NINT" => [octave forge] (fits) build failure on macOS under 4.4.1 and 5.2.0 - undefined "D_NINT"
        Dependencies- => Depends on bugs #55374

    Back to the top


    Powered by Savane 3.5