bugGNU Octave - Bugs: bug #57798, Insufficient instructions for...

 
 

bug #57798: Insufficient instructions for build for linux

Submitted by:  Emmanuel Brandt <emmanuelbrandt>
Submitted on:  Wed 12 Feb 2020 10:21:26 AM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Documentation
Status:  Works For Me Assigned to:  None
Originator Name:  Emmanuel Brandt Open/Closed:  Closed
Release:  5.2.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Mon 17 Feb 2020 04:01:24 PM UTC, comment #14: 

@Juan Pablo: once installed the issue on pkg installation is solved. Thank you.
We can close this issue. :)

Emmanuel Brandt <emmanuelbrandt>
Sun 16 Feb 2020 08:03:17 PM UTC, comment #13: 

You can install octave anywhere, even you can have several version installed.
You do this by passing a folder to the configure script

./configure prefix=/opt

will make "make install" install octave in the /opt folder.
At that point everything should run smoothly.
However I would recommend to change the prefix option of pkg as well, when installing using testing versions of octave. Because it might be that pkg form the new octave breaks installations for older octaves.

Juan Pablo Carbajal <juanpi>
Project Member
Sat 15 Feb 2020 08:06:55 PM UTC, comment #12: 

Build 5.0.2 from the ./build directory as instructeur in the wiki.
Not installed yet launching octave
./run-octave --gui
I will try to install test and report back

Emmanuel Brandt <emmanuelbrandt>
Sat 15 Feb 2020 02:04:04 PM UTC, comment #11: 

Are you running octave from the build directory using make run (or run-octave), or running the installed octave ?

If running from the built octave sources folder, I believe you can not install package from there, you have to installed Octave using make install, and then run the installed binary.

A quick look at the comments, and I didnt see where you explictly said what version of Octave you are trying to build.

My guess though is that is is not 4.2.2 ? So the mkoctfile you are seeing via command line is not the one a different version of Octave would be trying to use.

Possible issue could be the same as I menioned in the first part of the comment - you need to install octave and run the installed executable.

John Donoghue <lostbard>
Project Member
Sat 15 Feb 2020 12:32:31 PM UTC, comment #10: 

As a complement on testing built
Missing documentation (empty tab)

And

>> pkg install struct-1.0.16.tar.gz
pkg: unable to find the mkoctfile command, Octave installation is incomplete
error: called from
    __gripe_missing_component__ at line 53 column 3
    configure_make at line 44 column 7
    install at line 190 column 7
    pkg at line 441 column 9
>>

However mkoctfile is installed on the test system

$ mkoctfile --version
mkoctfile, version 4.2.2

Emmanuel Brandt <emmanuelbrandt>
Sat 15 Feb 2020 11:20:41 AM UTC, comment #9: 

To complement on my previous post.
Build on Ubuntu 18.10

same problem on some packages

Emmanuel Brandt <emmanuelbrandt>
Sat 15 Feb 2020 10:44:15 AM UTC, comment #8: 

Testing build from source on Ubuntu 19.10 system using dep from https://wiki.octave.org/wiki/index.php?title=Octave_for_Debian_systems&mobileaction=toggle_view_desktop#The_right_way

Only one complain: Unable to locate package texlive-libxft-dev
However: libxft-de exist

these additional packages were installed

sudo apt-get install octave-control octave-image octave-io octave-optim octave-signal octave-statistics

Lots of other packages added

The following additional packages will be installed:
  ant ant-optional libactivation-java libaopalliance-java libapache-poi-java libargs4j-java
  libasm-java libatinject-jsr330-api-java libcdi-api-java libcglib-java libcodemodel-java
  libcommons-cli-java libcommons-codec-java libcommons-collections4-java
  libcommons-compress-java libcommons-io-java libcommons-lang3-java libcommons-math3-java
  libcurvesapi-java libdom4j-java libdtd-parser-java libfastinfoset-java
  libgeronimo-annotation-1.3-spec-java libgeronimo-interceptor-3.0-spec-java libguava-java
  libguice-java libhawtjni-runtime-java libhttpclient-java libhttpcore-java libicu4j-java
  libintellij-annotations-java libistack-commons-java libjansi-java libjansi-native-java
  libjaxb-api-java libjaxb-java libjaxen-java libjdom1-java libjetbrains-annotations-java
  libjexcelapi-java libjopendocument-java libjsoup-java libjsr305-java liblog4j1.2-java
  libmaven-file-management-java libmaven-parent-java libmaven-resolver-java
  libmaven-shared-io-java libmaven-shared-utils-java libmaven3-core-java
  libplexus-archiver-java libplexus-cipher-java libplexus-classworlds-java
  libplexus-component-annotations-java libplexus-interpolation-java libplexus-io-java
  libplexus-sec-dispatcher-java libplexus-utils2-java librelaxng-datatype-java
  librngom-java libsaxonhe-java libsisu-guice-java libsisu-inject-java libsisu-ioc-java
  libsisu-plexus-java libslf4j-java libslicot0 libsnappy-java libsnappy-jni libstax-ex-java
  libstreambuffer-java libtxw2-java libwagon-http-java libwagon-provider-api-java
  libxerces2-java libxml-commons-external-java libxml-commons-resolver1.1-java
  libxmlbeans-java libxom-java libxsom-java libxz-java octave-struct
Suggested packages:
  ant-doc antlr javacc junit junit4 jython libbcel-java libbsf-java libcommons-net-java
  libmail-java libjaxp1.3-java libjdepend-java libjsch-java liboro-java libregexp-java
  libxalan2-java libaopalliance-java-doc libapache-poi-java-doc
  libatinject-jsr330-api-java-doc libservlet3.1-java libcommons-collections4-java-doc
  libcommons-io-java-doc libcommons-lang3-java-doc libdom4j-java-doc libmsv-java
  libxpp2-java libxpp3-java libdtd-parser-java-doc libjetbrains-annotations-java-doc
  libjdom1-java-doc libjsoup-java-doc libjsr305-java-doc liblog4j1.2-java-doc
  libmaven-file-management-java-doc libmaven-shared-io-java-doc
  libmaven-shared-utils-java-doc liblogback-java libplexus-cipher-java-doc
  libplexus-classworlds-java-doc libplexus-sec-dispatcher-java-doc
  libplexus-utils2-java-doc testng libosgi-compendium-java libosgi-core-java
  libxerces2-java-doc libxml-commons-resolver1.1-java-doc libxom-java-doc octave-parallel
The following NEW packages will be installed:
  ant ant-optional libactivation-java libaopalliance-java libapache-poi-java libargs4j-java
  libasm-java libatinject-jsr330-api-java libcdi-api-java libcglib-java libcodemodel-java
  libcommons-cli-java libcommons-codec-java libcommons-collections4-java
  libcommons-compress-java libcommons-io-java libcommons-lang3-java libcommons-math3-java
  libcurvesapi-java libdom4j-java libdtd-parser-java libfastinfoset-java
  libgeronimo-annotation-1.3-spec-java libgeronimo-interceptor-3.0-spec-java libguava-java
  libguice-java libhawtjni-runtime-java libhttpclient-java libhttpcore-java libicu4j-java
  libintellij-annotations-java libistack-commons-java libjansi-java libjansi-native-java
  libjaxb-api-java libjaxb-java libjaxen-java libjdom1-java libjetbrains-annotations-java
  libjexcelapi-java libjopendocument-java libjsoup-java libjsr305-java liblog4j1.2-java
  libmaven-file-management-java libmaven-parent-java libmaven-resolver-java
  libmaven-shared-io-java libmaven-shared-utils-java libmaven3-core-java
  libplexus-archiver-java libplexus-cipher-java libplexus-classworlds-java
  libplexus-component-annotations-java libplexus-interpolation-java libplexus-io-java
  libplexus-sec-dispatcher-java libplexus-utils2-java librelaxng-datatype-java
  librngom-java libsaxonhe-java libsisu-guice-java libsisu-inject-java libsisu-ioc-java
  libsisu-plexus-java libslf4j-java libslicot0 libsnappy-java libsnappy-jni libstax-ex-java
  libstreambuffer-java libtxw2-java libwagon-http-java libwagon-provider-api-java
  libxerces2-java libxml-commons-external-java libxml-commons-resolver1.1-java
  libxmlbeans-java libxom-java libxsom-java libxz-java octave-control octave-image
  octave-io octave-optim octave-signal octave-statistics octave-struct
0 upgraded, 88 newly installed, 0 to remove and 100 not upgraded.

make was completed with a few warnings

libtool: warning: '/usr/lib/gcc/x86_64-linux-gnu/9/../../../x86_64-linux-gnu/libcurl.la' seems to be moved
  CXXLD    libgui/liboctgui.la
  CXXLD    src/octave-cli
libtool: warning: '/usr/lib/gcc/x86_64-linux-gnu/9/../../../x86_64-linux-gnu/libcurl.la' seems to be moved
libtool: warning: '/usr/lib/gcc/x86_64-linux-gnu/9/../../../x86_64-linux-gnu/libcurl.la' seems to be moved
libtool: warning: '/usr/lib/gcc/x86_64-linux-gnu/9/../../../x86_64-linux-gnu/libcurl.la' seems to be moved

Testing install packages from forge allways fail see below.
Same error as when I opened this thread.
Please advise

>> pkg install -forge fits
pkg: unable to find the mkoctfile command, Octave installation is incomplete
error: called from
    __gripe_missing_component__ at line 53 column 3
    configure_make at line 44 column 7
    install at line 190 column 7
    pkg at line 441 column 9
>> pkg install -forge Statistics
pkg: unable to find the mkoctfile command, Octave installation is incomplete
error: called from
    __gripe_missing_component__ at line 53 column 3
    configure_make at line 44 column 7
    install at line 190 column 7
    pkg at line 441 column 9
>> pkg install -forge optim
pkg: unable to find the mkoctfile command, Octave installation is incomplete
error: called from
    __gripe_missing_component__ at line 53 column 3
    configure_make at line 44 column 7
    install at line 190 column 7
    pkg at line 441 column 9
>> pkg install -forge io
pkg: unable to find the mkoctfile command, Octave installation is incomplete
error: called from
    __gripe_missing_component__ at line 53 column 3
    configure_make at line 44 column 7
    install at line 190 column 7
    pkg at line 441 column 9
>>

Emmanuel Brandt <emmanuelbrandt>
Thu 13 Feb 2020 03:17:46 PM UTC, comment #7: 

Can we please wait until Monday so I can test the list of required packages that were previously provided. I will report back for closure or comment. Thanks

Emmanuel Brandt <emmanuelbrandt>
Thu 13 Feb 2020 02:52:07 AM UTC, comment #6: 

Maybe a small change to make it easier for future developers

https://wiki.octave.org/Building#Dependencies

Kai Torben Ohlhus <siko1056>
Project Member
Wed 12 Feb 2020 10:22:09 PM UTC, comment #5: 

I think this but report can be closed, everyone is encouraged to improve the build instructions and tips on the wiki.

Building Octave is definitely an advanced user topic. If you want to build the latest version of Octave for Ubuntu, you might consider downloading the Debian source package and building it with 'dpkg-buildpackage'.

If you only want to install the latest version, and don't actually care about compiling it yourself, you might consider updating your Ubuntu to 19.10 and installing Octave with Flatpak or Snap. Ubuntu 18.10 is end-of-life (https://lists.ubuntu.com/archives/ubuntu-announce/2019-July/000247.html). Ubuntu 20.04 LTS should include Octave 5.2.0.

Mike Miller <mtmiller>
Project Administrator
Wed 12 Feb 2020 03:34:31 PM UTC, comment #4: 

@Kai agree often frustrating and  and time consumming .
Followed the first link unfortunately didn't know the one on dependencies
Many thanks

Emmanuel Brandt <emmanuelbrandt>
Wed 12 Feb 2020 10:54:09 AM UTC, comment #3: 

No didn't know about that one link is not on the wiki will give a try upon my return in the office. Many thanks

Emmanuel Brandt <emmanuelbrandt>
Wed 12 Feb 2020 10:46:03 AM UTC, comment #2: 

Have you seen these instructions?
https://wiki.octave.org/wiki/index.php?title=Octave_for_Debian_systems&mobileaction=toggle_view_desktop#The_right_way

what's exactly the problem?

In my experience with 18.10 and 18.04, the apt builddep commad provided more than enough dependencies for building. The link above should give only what's necessary

Juan Pablo Carbajal <juanpi>
Project Member
Wed 12 Feb 2020 10:45:48 AM UTC, comment #1: 

@emmanuelbrandt, I understand your frustration.  Starting Octave development is anything but easy and very time consuming.

General build instructions
https://wiki.octave.org/Building

Dependencies (look at 18.04 LTS)
https://wiki.octave.org/Octave_for_Debian_systems#The_right_way

For me, one reasonable action to fix this bug report is to make suggestions what about the wiki pages we can improve to make it easier for new developers.

Kai Torben Ohlhus <siko1056>
Project Member
Wed 12 Feb 2020 10:21:26 AM UTC, original submission:  

Trying to build from source on a fresh ubuntu 18.10 debian linux system is a nightmare. Long trial and error install of required packages. Gfortran, curl readline, mkoctfile, packages etc... there are so many and wiki is not helping enough.
Not talking about the optionals but basics requirements for gui, and basic usage.
I can contribute to provide some instructions but so far didn't managed to install

Emmanuel Brandt <emmanuelbrandt>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by juanpi (Posted a comment)
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by emmanuelbrandt (Submitted the item)
  • -email is unavailable- added by emmanuelbrandt
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 13 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-02-12 mtmiller StatusNone => Works For Me
        Open/ClosedOpen => Closed
    2020-02-12 juanpi Severity1 - Wish => 3 - Normal
        Priority3 - Low => 5 - Normal
        StatusNeed Info => None
        Releasedev => 5.2.0
        SummaryInsufficient instructions for build for linux => Insufficient instructions for build for linux
    2020-02-12 siko1056 Severity3 - Normal => 1 - Wish
        Priority5 - Normal => 3 - Low
        StatusNone => Need Info
        Release5.2.0 => dev
        SummaryInsufficient instructions for build for linux => Insufficient instructions for build for linux
    2020-02-12 emmanuelbrandt Carbon-Copy- => Added emmanuel.brandt@orange.fr

    Back to the top


    Powered by Savane 3.5