bugGNU Octave - Bugs: bug #57642, Unable to activate the debug in a...

 
 

bug #57642: Unable to activate the debug in a script called "test.m"

Submitted by:  None
Submitted on:  Mon 20 Jan 2020 02:12:58 PM UTC  
 
Category:  GUI Severity:  2 - Minor
Priority:  3 - Low Item Group:  Unexpected Error
Status:  Invalid Assigned to:  None
Originator Name:  Pierre Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  5.1.0
Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 21 Jan 2020 08:58:36 PM UTC, comment #4: 

In addition to comment #2: A 3rd method to set a breakpoint is to click into the margin left to the line number of the desired line.

Since this seems to be a help request and not a bug, I am closing this report as invalid. It can be reopened in case setting a break point really does not work on Pierre's system.

Torsten Lilge <ttl>
Project Member
Tue 21 Jan 2020 05:09:23 PM UTC, comment #3: 

Adding the OP to the list of recipients since he attached his email address.

Pantxo Diribarne <pantxo>
Project Member
Mon 20 Jan 2020 04:44:44 PM UTC, comment #2: 

@Pierre: Your post ends with "could you help me please ?", so this looks like a question for the help mailing list :-): -email is unavailable-

The rightmost debug buttons are only active once you are in debug mode : they are used to step through the code after hitting a break point. So you need to first setup a break point at the desired location :

  • place the cursor at the line you want to inspect first and press the big red dot button
  • or use the "dbstop" command in the command window dbstop , and

Then run your script.

Pantxo Diribarne <pantxo>
Project Member
Mon 20 Jan 2020 03:29:54 PM UTC, comment #1: 

Dear Pierre,

Thank you for your report.  The file name "test"/"test.m" is pretty reserved in Octave.  Please rename your file and try debugging again.

Does this help?

Kai Torben Ohlhus <siko1056>
Project Member
Mon 20 Jan 2020 02:12:58 PM UTC, original submission:  

Hello,
I can load and execute a simple script file by clicking on the yellow rear widget ("save and execute") and it works fine, but I cannot debug: the 4 buttons for debugging (on the right part of the menu bar) are not activated (see capture) could you help please ?
Pierre

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #48259:  Capture.GIF added by None (59KiB - image/gif)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by siko1056 (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-01-21 ttl StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2020-01-20 siko1056 Severity3 - Normal => 2 - Minor
        Priority5 - Normal => 3 - Low
        Item GroupNone => Unexpected Error
        StatusNone => Need Info
        SummaryUnable to activate the debug => Unable to activate the debug in a script called "test.m"
    2020-01-20 None Attached File- => Added Capture.GIF, #48259

    Back to the top


    Powered by Savane 3.5