bugGNU Octave - Bugs: bug #57288, "test legend" fails for...

 
 

bug #57288: "test legend" fails for graphics toolkit gnuplot

Submitted by:  Markus Mützel <mmuetzel>
Submitted on:  Thu 21 Nov 2019 06:37:36 PM UTC  
 
Category:  Plotting with gnuplot Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Fixed Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 21 Nov 2019 08:55:43 PM UTC, comment #2: 

Pantxo shouldn't have to do all the work on legend.  I checked in a fix for this issue here https://hg.savannah.gnu.org/hgweb/octave/rev/f9c334a207bb.

Marking as fixed and closing report.

Rik <rik5>
Project Administrator
Thu 21 Nov 2019 07:57:01 PM UTC, comment #1: 

This shouldn't be too hard to fix, although it will require someone who is motivated to continue work on the gnuplot toolkit.  A new legend.m function has completely replaced the old function, except for the gnuplot toolkit which uses the old code now stored at scripts/plot/appearance/private/__gnuplot_legend__.m.

I get two test failures, and a third which is a known bug.  The two failures are

***** test
hf = figure ("visible", "off");
unwind_protect
   axes ();
   hplot = plot (rand (3));
   try
     legend (hplot, struct);
   catch
     [~, id] = lasterr ();
     assert (id, "Octave:invalid-fun-call");
   end_try_catch
unwind_protect_cleanup
   close (hf);
end_unwind_protect
!!!!! test failed
ASSERT errors for:  assert (id,"Octave:invalid-fun-call")

  Location  |  Observed  |  Expected  |  Reason
     []                   Octave:invalid-fun-call   Strings don't match
***** test
hf = figure ("visible", "off");
unwind_protect
   axes ();
   hplot = plot (rand (3));
   try
     legend ("a", "b", "c", hplot);
   catch
     [~, id] = lasterr ();
     assert (id, "Octave:invalid-fun-call");
   end_try_catch
unwind_protect_cleanup
   close (hf);
end_unwind_protect
!!!!! test failed
ASSERT errors for:  assert (id,"Octave:invalid-fun-call")

Rik <rik5>
Project Administrator
Thu 21 Nov 2019 06:37:36 PM UTC, original submission:  

Running "test legend" with the graphics toolkit gnuplot fais with the following error:

>> graphics_toolkit gnuplot
>> test legend
***** test
hf = figure ("visible", "off");
unwind_protect
   axes ();
   hplot = plot (rand (3));
   try
     legend (hplot, struct);
   catch
     [~, id] = lasterr ();
     assert (id, "Octave:invalid-fun-call");
   end_try_catch
unwind_protect_cleanup
   close (hf);
end_unwind_protect
!!!!! test failed
ASSERT errors for:  assert (id,"Octave:invalid-fun-call")

  Location  |  Observed  |  Expected  |  Reason
     []                   Octave:invalid-fun-call   Strings don't match

There also seem to be a few other cases where the error id has changed with respect to the legacy legend function that is used for gnuplot.

Markus Mützel <mmuetzel>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by mmuetzel (Submitted the item)
  • -email is unavailable- added by mmuetzel
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-11-21 rik5 StatusConfirmed => Fixed
        Open/ClosedOpen => Closed
    2019-11-21 rik5 StatusNone => Confirmed
    2019-11-21 mmuetzel Carbon-Copy- => Added pantxo

    Back to the top


    Powered by Savane 3.5