bugGNU Octave - Bugs: bug #56983, Plotting constant values with...

 
 

bug #56983: Plotting constant values with small noise gives erratic results

Submitter:  Roland Baudin <roland65>
Submitted:  Wed 02 Oct 2019 02:15:15 PM UTC
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

( Jump to the original submission )

Thu 03 Oct 2019 07:46:03 AM UTC, comment #6: 

OK, I didn't know about fltk and OpenGL.

I checked there is no issue with gnuplot, so the bug is clearly related to OpenGL.

Roland Baudin <roland65>
Thu 03 Oct 2019 07:36:14 AM UTC, comment #5: 

Yes indeed, this is a duplicate of bug #32980. Closing report as a duplicate.

Pantxo Diribarne <pantxo>
Project Member
Wed 02 Oct 2019 11:03:12 PM UTC, comment #4: 

The fltk toolkit does use OpenGL for rendering.

John W. Eaton <jwe>
Project Administrator
Wed 02 Oct 2019 08:50:06 PM UTC, comment #3: 

> Looks like the known issue that OpenGL only works in single precision.


The fltk toolkit doesn't use OpenGL, as far as I know...

Roland Baudin <roland65>
Wed 02 Oct 2019 05:40:01 PM UTC, comment #2: 

Looks like the known issue that OpenGL only works in single precision. There are several open bug reports about his (can't find them ATM).

A way around is to, yes, try the gnuplot backend:
graphics_toolkit ("gnuplot")

Please report back if that works better for you.

Philip Nienhuis <philipnienhuis>
Project Member
Wed 02 Oct 2019 02:17:05 PM UTC, comment #1: 

Here are the screenshots.


Roland Baudin <roland65>
Wed 02 Oct 2019 02:15:15 PM UTC, original submission:  

Here is the problematic code:

close all;
clear all;
s = 1e-3;
x = 100 * ones(1, 1000) + s * randn(1, 1000);
plot(x);

When s is higher than 1e-6, this plots (as expected) a noise around the mean value 100.

When s = 1e-6, this plots a line that is sometimes at the top of the figure, or at the bottom, or there is no line at all. The figure frame is corrupted, etc. (see screenshot1).

When s = 1e-8, there is sometimes no frame in the figure. The line is often not displayed (see screenshot2).

When s <= 1e-10, the plot correctly displays a line in the middle of the figure and the frame is also displayed, as expected.

I was able to reproduce this issue in Octave 4.2.1 (windows), 4.4.1 (windows), 5.1.0 (windows), 5.1.0 (Ubuntu Linux 18.04).

The problem is the same with qt or fltk toolkit. I didn't test with Gnuplot.

Roland Baudin <roland65>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #47610:  screenshot1.png added by roland65 (10KiB - image/png)
file #47611:  screenshot2.png added by roland65 (8KiB - image/png)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by roland65 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 10 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-10-03 pantxo Open/ClosedOpen Closed
    2019-10-03 pantxo CategoryPlotting Plotting with OpenGL
        Item GroupUnexpected Error or Warning Incorrect Result
        StatusNeed Info Duplicate
        Release4.4.1 dev
        Dependencies- Depends on bugs #32980
    2019-10-02 philipnienhuis Item GroupIncorrect Result Unexpected Error or Warning
        StatusNone Need Info
    2019-10-02 roland65 Attached File- Added screenshot1.png, #47610
        Attached File- Added screenshot2.png, #47611

    Back to the top


    Powered by Savane 3.9