bugGNU Octave - Bugs: bug #56973, display of string/char objects...

 
 

bug #56973: display of string/char objects using quotes

Submitter:  Colin Macdonald <cbm>
Submitted:  Mon 30 Sep 2019 06:54:51 PM UTC
   
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Matlab Compatibility
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Fri 21 May 2021 06:57:14 AM UTC, comment #1: 

This is a duplicate of bug #53469.

Closing report.

Markus M├╝tzel <mmuetzel>
Group administrator
Mon 30 Sep 2019 06:54:51 PM UTC, original submission:  

Sometime between R2015 and R2018b, Matlab starting printing strings and char arrays with quotes:

>> c = 'hello'

c =

    'hello'

>> s = "hello"

s =

    "hello"

>> disp(c)
hello
>> disp(s)
hello


Note "disp" still behaves the same.  I think I like this change.  Should we do it as well?

Colin Macdonald <cbm>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by apjanke (subscribing because interested)
  • -email is unavailable- added by cbm (Submitted the item)
  • -email is unavailable- added by cbm
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-05-21 mmuetzel StatusNone Duplicate
        Open/ClosedOpen Closed
        Dependencies- Depends on bugs #53469
    2019-10-24 apjanke Carbon-Copy- Added apjanke
    2019-09-30 cbm Carbon-Copy- Added mtmiller

    Back to the top

    Powered by Savane 3.13-04b1.
    Corresponding source code